You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/package/broadcom-wl/patches/002-ctype.patch

31 lines
622 B
Diff

--- a/shared/Makefile
+++ b/shared/Makefile
@@ -19,7 +19,7 @@ LDFLAGS += -L.
AR=ar
RANLIB=ranlib
-OBJS := shutils.o wl.o wl_linux.o linux_timer.o
+OBJS := shutils.o wl.o wl_linux.o linux_timer.o ctype.o
all: libshared.a
clean:
--- /dev/null
+++ b/shared/ctype.c
@@ -0,0 +1,16 @@
+#include <features.h>
+
+#ifndef __UCLIBC__
+extern void **__ctype_b_loc();
+extern void **__ctype_tolower_loc();
+
+void *__ctype_b;
+void *__ctype_tolower;
+
+static void init(void) __attribute__((constructor));
+static void init(void)
+{
+ __ctype_b = *__ctype_b_loc();
+ __ctype_tolower = *__ctype_tolower_loc();
+}
+#endif