You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/toolchain/uClibc/patches-0.9.29/190-install_tls.patch

13 lines
656 B
Diff

--- a/libpthread/linuxthreads/Makefile.in
+++ b/libpthread/linuxthreads/Makefile.in
@@ -128,7 +128,9 @@ linuxthreads_headers:
$(Q)$(LN) -sf ../$(PTDIR)/sysdeps/pthread/pthread.h $(top_builddir)include/
$(Q)$(LN) -sf ../$(PTDIR)/semaphore.h $(top_builddir)include/
$(Q)$(INSTALL) -d $(top_builddir)include/bits
+ $(Q)$(INSTALL) -d $(top_builddir)include/sys
$(Q)$(LN) -sf ../../$(PTDIR)/sysdeps/pthread/bits/pthreadtypes.h $(top_builddir)include/bits/
+ $(Q)$(LN) -sf ../../$(PTDIR)/sysdeps/$(TARGET_ARCH)/tls.h $(top_builddir)include/sys/
linuxthreads_headers_clean:
$(RM) $(top_builddir)include/pthread.h $(top_builddir)include/semaphore.h \