You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/oxnas/patches-3.18/500-oxnas-sata.patch

31 lines
959 B
Diff

Index: linux-3.18-rc4/drivers/ata/Kconfig
===================================================================
--- linux-3.18-rc4.orig/drivers/ata/Kconfig
+++ linux-3.18-rc4/drivers/ata/Kconfig
@@ -385,6 +385,13 @@ config SATA_VITESSE
If unsure, say N.
+config SATA_OXNAS
+ tristate "PLXTECH NAS782X SATA support"
+ help
+ This option enables support for Nas782x Serial ATA controller.
+
+ If unsure, say N.
+
comment "PATA SFF controllers with BMDMA"
config PATA_ALI
Index: linux-3.18-rc4/drivers/ata/Makefile
===================================================================
--- linux-3.18-rc4.orig/drivers/ata/Makefile
+++ linux-3.18-rc4/drivers/ata/Makefile
@@ -37,6 +37,7 @@ obj-$(CONFIG_SATA_SVW) += sata_svw.o
obj-$(CONFIG_SATA_ULI) += sata_uli.o
obj-$(CONFIG_SATA_VIA) += sata_via.o
obj-$(CONFIG_SATA_VITESSE) += sata_vsc.o
+obj-$(CONFIG_SATA_OXNAS) += sata_oxnas.o
# SFF PATA w/ BMDMA
obj-$(CONFIG_PATA_ALI) += pata_ali.o