You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/brcm2708/patches-4.4/0547-ARM-dts-Visit-overlays...

35 lines
1.0 KiB
Diff

From 2e743a4c2f496667937b899770b4329788f0a0a0 Mon Sep 17 00:00:00 2001
From: Phil Elwell <phil@raspberrypi.org>
Date: Fri, 18 Nov 2016 10:52:49 +0000
Subject: [PATCH] ARM: dts: Visit overlays subdir unconditionally
make clean processing occurs without loading the configuration, so the
overlays subdir must be added unconditionally.
See: https://github.com/raspberrypi/linux/issues/1723
---
arch/arm/boot/dts/Makefile | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -18,9 +18,6 @@ endif
ifeq ($(CONFIG_ARCH_BCM2835),y)
RPI_DT_OVERLAYS=y
endif
-ifeq ($(RPI_DT_OVERLAYS),y)
- dts-dirs += overlays
-endif
dtb-$(CONFIG_ARCH_ALPINE) += \
alpine-db.dtb
@@ -809,7 +806,7 @@ dtstree := $(srctree)/$(src)
dtb-$(CONFIG_OF_ALL_DTBS) := $(patsubst $(dtstree)/%.dts,%.dtb, $(wildcard $(dtstree)/*.dts))
always := $(dtb-y)
-subdir-y := $(dts-dirs)
+subdir-y := $(dts-dirs) overlays
clean-files := *.dtb
# Enable fixups to support overlays on BCM2708 platforms