OpenWRT firmware for routers
You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 
Go to file
Sandeep Sheriker M 0b7c66c93b at91bootstrap: add sama5d27_som1_eksd1_uboot as default defconfig
Signed-off-by: Sandeep Sheriker M <sandeep.sheriker@microchip.com>
5 years ago
.github build: Update README & github help 6 years ago
config build: add buildinfo files for reproducibility 5 years ago
include build: fix indent in image-commands.mk 5 years ago
package at91bootstrap: add sama5d27_som1_eksd1_uboot as default defconfig 5 years ago
scripts build: allow overriding default selection state for devices 5 years ago
target at91bootstrap: add sama5d27_som1_eksd1_uboot as default defconfig 5 years ago
toolchain musl: ldso/dlsym: fix mips returning undef dlsym 5 years ago
tools tools/e2fsprogs: Update to 1.45.3 5 years ago
.gitattributes add .gitattributes to prevent the git autocrlf option from messing with CRLF/LF in files 12 years ago
.gitignore .gitignore: add .project & .cproject for eclipse users 6 years ago
BSDmakefile add missing copyright header 17 years ago
Config.in merge: base: update base-files and basic config 6 years ago
LICENSE finally move buildroot-ng to trunk 8 years ago
Makefile build: add buildinfo files for reproducibility 5 years ago
README build: switch to Python 3 5 years ago
feeds.conf.default feeds: switch git.lede-project.org URLs to git.openwrt.org 6 years ago
rules.mk librpc: remove package 5 years ago

README

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------

This is the buildsystem for the OpenWrt Linux distribution.

To build your own firmware you need a Linux, BSD or MacOSX system (case
sensitive filesystem required). Cygwin is unsupported because of the lack
of a case sensitive file system.

You need gcc, binutils, bzip2, flex, python3.5+, perl, make, find, grep, diff,
unzip, gawk, getopt, subversion, libz-dev and libc headers installed.

1. Run "./scripts/feeds update -a" to obtain all the latest package definitions
defined in feeds.conf / feeds.conf.default

2. Run "./scripts/feeds install -a" to install symlinks for all obtained
packages into package/feeds/

3. Run "make menuconfig" to select your preferred configuration for the
toolchain, target system & firmware packages.

4. Run "make" to build your firmware. This will download all sources, build
the cross-compile toolchain and then cross-compile the Linux kernel & all
chosen applications for your target system.

Sunshine!
	Your OpenWrt Community
	http://www.openwrt.org