You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/package/madwifi/patches/106-get_arch.patch

22 lines
436 B
Diff

--- a/scripts/get_arch.mk
+++ b/scripts/get_arch.mk
@@ -36,11 +36,14 @@ ifeq (,$(ARCH-y))
$(Cannot determine ARCH)
endif
+# Allow ARCH to be x86
+ifneq (,$(CONFIG_X86))
+ifeq (x86,$(ARCH))
+ARCH-y = $(ARCH)
+endif
+endif
+
# Don't allow ARCH to be overridden by a different value.
ifeq (,$(ARCH))
ARCH = $(ARCH-y)
-else
-ifneq ($(ARCH),$(ARCH-y))
-$(error ARCH mismatch: supplied "$(ARCH)", determined "$(ARCH-y)")
-endif
endif