dropbear: update to 2014.65

Signed-off-by: Steven Barth <steven@midlink.org>

SVN-Revision: 42131
v19.07.3_mercusys_ac12_duma
Steven Barth 10 years ago
parent ecba34a3ee
commit ff6363dc19

@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dropbear
PKG_VERSION:=2014.63
PKG_VERSION:=2014.65
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
http://matt.ucc.asn.au/dropbear/releases/ \
https://dropbear.nl/mirror/releases/
PKG_MD5SUM:=7066bb9a2da708f3ed06314fdc9c47fd
PKG_MD5SUM:=1918604238817385a156840fa2c39490
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE

@ -1,6 +1,6 @@
--- a/svr-chansession.c
+++ b/svr-chansession.c
@@ -889,12 +889,12 @@ static void execchild(void *user_data) {
@@ -902,12 +902,12 @@ static void execchild(void *user_data) {
/* We can only change uid/gid as root ... */
if (getuid() == 0) {

@ -1,6 +1,6 @@
--- a/cli-runopts.c
+++ b/cli-runopts.c
@@ -309,6 +309,10 @@ void cli_getopts(int argc, char ** argv)
@@ -312,6 +312,10 @@ void cli_getopts(int argc, char ** argv)
debug_trace = 1;
break;
#endif
@ -11,10 +11,10 @@
case 'F':
case 'e':
#ifndef ENABLE_USER_ALGO_LIST
@@ -322,7 +326,6 @@ void cli_getopts(int argc, char ** argv)
#ifndef ENABLE_CLI_LOCALTCPFWD
case 'L':
#endif
@@ -329,7 +333,6 @@ void cli_getopts(int argc, char ** argv)
print_version();
exit(EXIT_SUCCESS);
break;
- case 'o':
case 'b':
next = &dummy;

@ -1,6 +1,6 @@
--- a/dbutil.h
+++ b/dbutil.h
@@ -92,7 +92,11 @@ int m_str_to_uint(const char* str, unsig
@@ -101,7 +101,11 @@ int m_str_to_uint(const char* str, unsig
#define DEF_MP_INT(X) mp_int X = {0, 0, 0, NULL}
/* Dropbear assertion */

@ -1,6 +1,6 @@
--- a/options.h
+++ b/options.h
@@ -318,7 +318,7 @@ be overridden at runtime with -I. 0 disa
@@ -323,7 +323,7 @@ be overridden at runtime with -I. 0 disa
#define DEFAULT_IDLE_TIMEOUT 0
/* The default path. This will often get replaced by the shell */

Loading…
Cancel
Save