set of_node before registring the switch

Signed-off-by: John Crispin <blogic@openwrt.org>

SVN-Revision: 36285
v19.07.3_mercusys_ac12_duma
John Crispin 11 years ago
parent 04dcd12c91
commit fcd962cc71

@ -26,8 +26,10 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
create mode 100644 drivers/net/ethernet/ramips/ramips_eth.h
create mode 100644 drivers/net/ethernet/ramips/ramips_main.c
--- /dev/null
+++ b/arch/mips/include/asm/mach-ralink/rt305x_esw_platform.h
Index: linux-3.8.6/arch/mips/include/asm/mach-ralink/rt305x_esw_platform.h
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-3.8.6/arch/mips/include/asm/mach-ralink/rt305x_esw_platform.h 2013-04-07 14:13:35.688091644 +0200
@@ -0,0 +1,27 @@
+/*
+ * Ralink RT305x SoC platform device registration
@ -56,9 +58,11 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+};
+
+#endif /* _RT305X_ESW_PLATFORM_H */
--- a/arch/mips/ralink/rt305x.c
+++ b/arch/mips/ralink/rt305x.c
@@ -182,6 +182,7 @@ void __init ralink_clk_init(void)
Index: linux-3.8.6/arch/mips/ralink/rt305x.c
===================================================================
--- linux-3.8.6.orig/arch/mips/ralink/rt305x.c 2013-04-07 14:13:35.580091641 +0200
+++ linux-3.8.6/arch/mips/ralink/rt305x.c 2013-04-07 14:13:35.688091644 +0200
@@ -182,6 +182,7 @@
}
ralink_clk_add("cpu", cpu_rate);
@ -66,9 +70,11 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
ralink_clk_add("10000b00.spi", sys_rate);
ralink_clk_add("10000100.timer", wdt_rate);
ralink_clk_add("10000120.watchdog", wdt_rate);
--- a/drivers/net/ethernet/Kconfig
+++ b/drivers/net/ethernet/Kconfig
@@ -136,6 +136,7 @@ source "drivers/net/ethernet/packetengin
Index: linux-3.8.6/drivers/net/ethernet/Kconfig
===================================================================
--- linux-3.8.6.orig/drivers/net/ethernet/Kconfig 2013-04-05 18:49:06.000000000 +0200
+++ linux-3.8.6/drivers/net/ethernet/Kconfig 2013-04-07 14:13:35.688091644 +0200
@@ -136,6 +136,7 @@
source "drivers/net/ethernet/pasemi/Kconfig"
source "drivers/net/ethernet/qlogic/Kconfig"
source "drivers/net/ethernet/racal/Kconfig"
@ -76,9 +82,11 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
source "drivers/net/ethernet/realtek/Kconfig"
source "drivers/net/ethernet/renesas/Kconfig"
source "drivers/net/ethernet/rdc/Kconfig"
--- a/drivers/net/ethernet/Makefile
+++ b/drivers/net/ethernet/Makefile
@@ -54,6 +54,7 @@ obj-$(CONFIG_NET_PACKET_ENGINE) += packe
Index: linux-3.8.6/drivers/net/ethernet/Makefile
===================================================================
--- linux-3.8.6.orig/drivers/net/ethernet/Makefile 2013-04-05 18:49:06.000000000 +0200
+++ linux-3.8.6/drivers/net/ethernet/Makefile 2013-04-07 14:13:35.688091644 +0200
@@ -54,6 +54,7 @@
obj-$(CONFIG_NET_VENDOR_PASEMI) += pasemi/
obj-$(CONFIG_NET_VENDOR_QLOGIC) += qlogic/
obj-$(CONFIG_NET_VENDOR_RACAL) += racal/
@ -86,8 +94,10 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
obj-$(CONFIG_NET_VENDOR_REALTEK) += realtek/
obj-$(CONFIG_SH_ETH) += renesas/
obj-$(CONFIG_NET_VENDOR_RDC) += rdc/
--- /dev/null
+++ b/drivers/net/ethernet/ramips/Kconfig
Index: linux-3.8.6/drivers/net/ethernet/ramips/Kconfig
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-3.8.6/drivers/net/ethernet/ramips/Kconfig 2013-04-07 14:13:35.688091644 +0200
@@ -0,0 +1,18 @@
+config NET_RAMIPS
+ tristate "Ralink RT288X/RT3X5X/RT3662/RT3883 ethernet driver"
@ -107,8 +117,10 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+ depends on DEBUG_FS
+
+endif
--- /dev/null
+++ b/drivers/net/ethernet/ramips/Makefile
Index: linux-3.8.6/drivers/net/ethernet/ramips/Makefile
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-3.8.6/drivers/net/ethernet/ramips/Makefile 2013-04-07 14:13:35.688091644 +0200
@@ -0,0 +1,9 @@
+#
+# Makefile for the Ramips SoCs built-in ethernet macs
@ -119,8 +131,10 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+ramips-$(CONFIG_NET_RAMIPS_DEBUG_FS) += ramips_debugfs.o
+
+obj-$(CONFIG_NET_RAMIPS) += ramips.o
--- /dev/null
+++ b/drivers/net/ethernet/ramips/ramips_debugfs.c
Index: linux-3.8.6/drivers/net/ethernet/ramips/ramips_debugfs.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-3.8.6/drivers/net/ethernet/ramips/ramips_debugfs.c 2013-04-07 14:13:35.688091644 +0200
@@ -0,0 +1,127 @@
+/*
+ * Ralink SoC ethernet driver debugfs code
@ -249,9 +263,11 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+ debugfs_remove(raeth_debugfs_root);
+ raeth_debugfs_root = NULL;
+}
--- /dev/null
+++ b/drivers/net/ethernet/ramips/ramips_esw.c
@@ -0,0 +1,1220 @@
Index: linux-3.8.6/drivers/net/ethernet/ramips/ramips_esw.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-3.8.6/drivers/net/ethernet/ramips/ramips_esw.c 2013-04-07 16:16:56.172408006 +0200
@@ -0,0 +1,1221 @@
+#include <linux/ioport.h>
+#include <linux/switch.h>
+#include <linux/mii.h>
@ -1406,6 +1422,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+ esw->reg_initval_fpa2 = be32_to_cpu(*reg_init);
+
+ swdev = &esw->swdev;
+ swdev->of_node = pdev->dev.of_node;
+ swdev->name = "rt305x-esw";
+ swdev->alias = "rt305x";
+ swdev->cpu_port = RT305X_ESW_PORT6;
@ -1472,8 +1489,10 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+{
+ platform_driver_unregister(&rt305x_esw_driver);
+}
--- /dev/null
+++ b/drivers/net/ethernet/ramips/ramips_eth.h
Index: linux-3.8.6/drivers/net/ethernet/ramips/ramips_eth.h
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-3.8.6/drivers/net/ethernet/ramips/ramips_eth.h 2013-04-07 14:13:35.688091644 +0200
@@ -0,0 +1,375 @@
+/*
+ * This program is free software; you can redistribute it and/or modify
@ -1850,8 +1869,10 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+#endif /* CONFIG_NET_RAMIPS_DEBUG_FS */
+
+#endif /* RAMIPS_ETH_H */
--- /dev/null
+++ b/drivers/net/ethernet/ramips/ramips_main.c
Index: linux-3.8.6/drivers/net/ethernet/ramips/ramips_main.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-3.8.6/drivers/net/ethernet/ramips/ramips_main.c 2013-04-07 14:13:35.688091644 +0200
@@ -0,0 +1,1285 @@
+/*
+ * This program is free software; you can redistribute it and/or modify

Loading…
Cancel
Save