b43-tools: fix compile error: undefined reference to `yydebug'

With bison 2.7 YYDEBUG will be set to 0 if it was not set, then #ifdef
YYDEBUG returns true, but bison 2.7 treets YYDEBUG 0 as not set.

This fixes the following error:
obj/main.o: In function `main':
main.c:(.text.startup+0xaf): undefined reference to `yydebug'
collect2: error: ld returned 1 exit status

This closes #13093.

SVN-Revision: 35830
v19.07.3_mercusys_ac12_duma
Hauke Mehrtens 11 years ago
parent d8f57c4e6c
commit f3bfc60e1c

@ -0,0 +1,27 @@
--- a/assembler/Makefile
+++ b/assembler/Makefile
@@ -30,7 +30,7 @@ BIN = b43-asm.bin
SRCS = parser.c scanner.c main.c initvals.c util.c args.c
# YACC related CFLAGS
-CFLAGS += -DYYSTYPE="void *" -DYYERROR_VERBOSE -DYYDEBUG -DYYENABLE_NLS=0 -DYYLTYPE_IS_TRIVIAL=0 -Wno-unused
+CFLAGS += -DYYSTYPE="void *" -DYYERROR_VERBOSE -DYYDEBUG=1 -DYYENABLE_NLS=0 -DYYLTYPE_IS_TRIVIAL=0 -Wno-unused
.SUFFIXES:
.PHONY: all install clean distclean
diff --git a/assembler/main.c b/assembler/main.c
index afca996..a62a15e 100644
--- a/assembler/main.c
+++ b/assembler/main.c
@@ -1260,7 +1260,7 @@ static void initialize(void)
{
INIT_LIST_HEAD(&infile.sl);
INIT_LIST_HEAD(&infile.ivals);
-#ifdef YYDEBUG
+#if YYDEBUG
if (IS_INSANE_DEBUG)
yydebug = 1;
else
--
1.7.10.4
Loading…
Cancel
Save