package/acx-mac80211: refresh patches

SVN-Revision: 20449
v19.07.3_mercusys_ac12_duma
Gabor Juhos 14 years ago
parent 0bf7a71a2a
commit f34e2fc939

@ -1,8 +1,6 @@
Index: acx-mac80211-20100302/acx_func.h
===================================================================
--- acx-mac80211-20100302.orig/acx_func.h 2010-03-06 12:57:25.000000000 +0100
+++ acx-mac80211-20100302/acx_func.h 2010-03-06 12:58:10.000000000 +0100
@@ -704,9 +704,9 @@
--- a/acx_func.h
+++ b/acx_func.h
@@ -704,9 +704,9 @@ int acx_setup_modes(acx_device_t *adev);
void acx_free_modes(acx_device_t *adev);
int acx_i_op_tx(struct ieee80211_hw *ieee, struct sk_buff *skb);
int acx_e_op_add_interface(struct ieee80211_hw* ieee,
@ -14,11 +12,9 @@ Index: acx-mac80211-20100302/acx_func.h
int acx_net_reset(struct ieee80211_hw *ieee);
int acx_e_op_set_key(struct ieee80211_hw *hw, enum set_key_cmd cmd,
struct ieee80211_vif *vif, struct ieee80211_sta *sta,
Index: acx-mac80211-20100302/common.c
===================================================================
--- acx-mac80211-20100302.orig/common.c 2010-03-06 12:57:31.000000000 +0100
+++ acx-mac80211-20100302/common.c 2010-03-06 12:59:51.000000000 +0100
@@ -4402,7 +4402,7 @@
--- a/common.c
+++ b/common.c
@@ -4402,7 +4402,7 @@ static void acx_s_select_opmode(acx_devi
}
int acx_e_op_add_interface(struct ieee80211_hw *ieee,
@ -27,7 +23,7 @@ Index: acx-mac80211-20100302/common.c
{
acx_device_t *adev = ieee2adev(ieee);
unsigned long flags;
@@ -4414,14 +4414,14 @@
@@ -4414,14 +4414,14 @@ int acx_e_op_add_interface(struct ieee80
acx_sem_lock(adev);
acx_lock(adev, flags);
@ -45,7 +41,7 @@ Index: acx-mac80211-20100302/common.c
}
// adev->mode = conf->type;
@@ -4436,8 +4436,8 @@
@@ -4436,8 +4436,8 @@ int acx_e_op_add_interface(struct ieee80
printk(KERN_INFO "acx: Virtual interface added "
"(type: 0x%08X, MAC: %s)\n",
@ -56,7 +52,7 @@ Index: acx-mac80211-20100302/common.c
out_unlock:
acx_unlock(adev, flags);
@@ -4448,7 +4448,7 @@
@@ -4448,7 +4448,7 @@ int acx_e_op_add_interface(struct ieee80
}
void acx_e_op_remove_interface(struct ieee80211_hw *hw,
@ -65,7 +61,7 @@ Index: acx-mac80211-20100302/common.c
{
acx_device_t *adev = ieee2adev(hw);
@@ -4457,23 +4457,23 @@
@@ -4457,23 +4457,23 @@ void acx_e_op_remove_interface(struct ie
FN_ENTER;
acx_sem_lock(adev);

@ -1,8 +1,6 @@
Index: acx-mac80211-20100302/acx_func.h
===================================================================
--- acx-mac80211-20100302.orig/acx_func.h 2010-03-06 13:01:36.000000000 +0100
+++ acx-mac80211-20100302/acx_func.h 2010-03-06 13:01:56.000000000 +0100
@@ -714,7 +714,6 @@
--- a/acx_func.h
+++ b/acx_func.h
@@ -714,7 +714,6 @@ int acx_e_op_set_key(struct ieee80211_hw
int acx_e_op_config(struct ieee80211_hw *hw, u32 changed);
void acx_e_op_bss_info_changed(struct ieee80211_hw *hw,
struct ieee80211_vif *vif, struct ieee80211_bss_conf *info, u32 changed);
@ -10,11 +8,9 @@ Index: acx-mac80211-20100302/acx_func.h
int acx_e_conf_tx(struct ieee80211_hw* ieee, u16 queue,
const struct ieee80211_tx_queue_params *params);
//int acx_passive_scan(struct net_device *net_dev, int state, struct ieee80211_scan_conf *conf);
Index: acx-mac80211-20100302/common.c
===================================================================
--- acx-mac80211-20100302.orig/common.c 2010-03-06 13:01:38.000000000 +0100
+++ acx-mac80211-20100302/common.c 2010-03-06 13:02:37.000000000 +0100
@@ -4662,24 +4662,6 @@
--- a/common.c
+++ b/common.c
@@ -4662,24 +4662,6 @@ extern void acx_e_op_bss_info_changed(st
return;
}
@ -39,11 +35,9 @@ Index: acx-mac80211-20100302/common.c
int acx_e_conf_tx(struct ieee80211_hw *hw,
u16 queue, const struct ieee80211_tx_queue_params *params)
{
Index: acx-mac80211-20100302/mem.c
===================================================================
--- acx-mac80211-20100302.orig/mem.c 2010-03-06 13:01:46.000000000 +0100
+++ acx-mac80211-20100302/mem.c 2010-03-06 13:02:28.000000000 +0100
@@ -2321,7 +2321,6 @@
--- a/mem.c
+++ b/mem.c
@@ -2321,7 +2321,6 @@ static const struct ieee80211_ops acxmem
.bss_info_changed = acx_e_op_bss_info_changed,
.set_key = acx_e_op_set_key,
.get_stats = acx_e_op_get_stats,
@ -51,11 +45,9 @@ Index: acx-mac80211-20100302/mem.c
};
Index: acx-mac80211-20100302/pci.c
===================================================================
--- acx-mac80211-20100302.orig/pci.c 2010-03-06 13:01:40.000000000 +0100
+++ acx-mac80211-20100302/pci.c 2010-03-06 13:02:18.000000000 +0100
@@ -1482,7 +1482,6 @@
--- a/pci.c
+++ b/pci.c
@@ -1482,7 +1482,6 @@ static const struct ieee80211_ops acxpci
.bss_info_changed = acx_e_op_bss_info_changed,
.set_key = acx_e_op_set_key,
.get_stats = acx_e_op_get_stats,
@ -63,11 +55,9 @@ Index: acx-mac80211-20100302/pci.c
};
Index: acx-mac80211-20100302/usb.c
===================================================================
--- acx-mac80211-20100302.orig/usb.c 2010-03-06 13:01:44.000000000 +0100
+++ acx-mac80211-20100302/usb.c 2010-03-06 13:02:22.000000000 +0100
@@ -757,7 +757,6 @@
--- a/usb.c
+++ b/usb.c
@@ -757,7 +757,6 @@ static const struct ieee80211_ops acxusb
.bss_info_changed = acx_e_op_bss_info_changed,
.set_key = acx_e_op_set_key,
.get_stats = acx_e_op_get_stats,

@ -1,8 +1,6 @@
Index: acx-mac80211-20100302/Makefile
===================================================================
--- acx-mac80211-20100302.orig/Makefile 2010-03-06 22:13:23.000000000 +0100
+++ acx-mac80211-20100302/Makefile 2010-03-06 22:13:28.000000000 +0100
@@ -29,7 +29,7 @@
--- a/Makefile
+++ b/Makefile
@@ -29,7 +29,7 @@ ifneq ($(KERNELRELEASE),)
acx-mac80211-obj-$(CONFIG_ACX_MAC80211_PCI) += pci.o
acx-mac80211-obj-$(CONFIG_ACX_MAC80211_USB) += usb.o
acx-mac80211-obj-$(CONFIG_ACX_MAC80211_MEM) += mem.o

@ -1,8 +1,6 @@
Index: acx-mac80211-20100302/pci.c
===================================================================
--- acx-mac80211-20100302.orig/pci.c 2010-03-06 22:22:02.000000000 +0100
+++ acx-mac80211-20100302/pci.c 2010-03-06 22:22:29.000000000 +0100
@@ -4309,7 +4309,7 @@
--- a/pci.c
+++ b/pci.c
@@ -4309,7 +4309,7 @@ static __devinit int vlynq_probe(struct
addr = (u32)ioremap(vdev->mem_start, 0x1000);
if (!addr) {
printk(KERN_ERR "acx: %s: failed to remap io memory\n",
@ -11,7 +9,7 @@ Index: acx-mac80211-20100302/pci.c
result = -ENXIO;
goto fail;
}
@@ -4323,7 +4323,7 @@
@@ -4323,7 +4323,7 @@ static __devinit int vlynq_probe(struct
ieee = ieee80211_alloc_hw(sizeof(struct acx_device), &acxpci_hw_ops);
if (!ieee) {
printk("acx: could not allocate ieee80211 structure %s\n",
@ -20,7 +18,7 @@ Index: acx-mac80211-20100302/pci.c
goto fail_alloc_netdev;
}
ieee->flags &= ~IEEE80211_HW_RX_INCLUDES_FCS;
@@ -4365,7 +4365,7 @@
@@ -4365,7 +4365,7 @@ static __devinit int vlynq_probe(struct
printk("acx: found %s-based wireless network card at %s, irq:%d, "
"phymem:0x%x, mem:0x%p\n",
@ -29,7 +27,7 @@ Index: acx-mac80211-20100302/pci.c
vdev->mem_start, adev->iobase);
log(L_ANY, "acx: the initial debug setting is 0x%04X\n", acx_debug);
@@ -4416,7 +4416,7 @@
@@ -4416,7 +4416,7 @@ static __devinit int vlynq_probe(struct
* firmware operations happening in parallel or uninitialized data */
@ -38,7 +36,7 @@ Index: acx-mac80211-20100302/pci.c
/* Now we have our device, so make sure the kernel doesn't try
* to send packets even though we're not associated to a network yet */
@@ -4536,7 +4536,7 @@
@@ -4536,7 +4536,7 @@ static void vlynq_remove(struct vlynq_de
CLEAR_BIT(adev->dev_state_mask, ACX_STATE_IFACE_UP);
}

@ -1,7 +1,5 @@
Index: acx-mac80211-20100302/pci.c
===================================================================
--- acx-mac80211-20100302.orig/pci.c 2010-03-07 12:39:38.000000000 +0100
+++ acx-mac80211-20100302/pci.c 2010-03-07 12:40:02.000000000 +0100
--- a/pci.c
+++ b/pci.c
@@ -17,8 +17,6 @@
*/
#define ACX_MAC80211_PCI 1

Loading…
Cancel
Save