update dropbear to 0.49

SVN-Revision: 6890
v19.07.3_mercusys_ac12_duma
Tim Yardley 17 years ago
parent 169e9ea9a2
commit f114756689

@ -9,12 +9,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dropbear
PKG_VERSION:=0.48.1
PKG_VERSION:=0.49
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/
PKG_MD5SUM:=ca8e53a766faec831882831364568421
PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/ \
http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
PKG_MD5SUM:=7b20c85f1ee34f018a1b948eae003df9
include $(INCLUDE_DIR)/package.mk

@ -1,12 +1,11 @@
diff -urN dropbear-0.45.old/cli-kex.c dropbear-0.45/cli-kex.c
--- dropbear-0.45.old/cli-kex.c 2005-03-07 05:27:01.000000000 +0100
+++ dropbear-0.45/cli-kex.c 2005-03-25 11:13:57.000000000 +0100
@@ -119,7 +119,7 @@
char response = 'z';
fp = sign_key_fingerprint(keyblob, keybloblen);
--- dropbear-0.49/cli-kex.c.orig 2007-02-22 09:51:36.000000000 -0600
+++ dropbear-0.49/cli-kex.c 2007-03-22 13:45:57.000000000 -0500
@@ -126,7 +126,7 @@
m_free(fp);
return;
}
- fprintf(stderr, "\nHost '%s' is not in the trusted hosts file.\n(fingerprint %s)\nDo you want to continue connecting? (y/n)\n",
+ fprintf(stderr, "\nHost '%s' is not in the trusted hosts file.\n(fingerprint %s)\nDo you want to continue connecting? (y/n) ",
+ fprintf(stderr, "\nHost '%s' is not in the trusted hosts file.\n(fingerprint %s)\nDo you want to continue connecting? (y/n)",
cli_opts.remotehost,
fp);
m_free(fp);

@ -1,19 +0,0 @@
diff -ur dropbear.old/svr-authpam.c dropbear.dev/svr-authpam.c
--- dropbear.old/svr-authpam.c 2006-03-12 05:52:52.000000000 +0100
+++ dropbear.dev/svr-authpam.c 2007-02-27 02:55:41.382234344 +0100
@@ -31,14 +31,13 @@
#include "dbutil.h"
#include "auth.h"
+#ifdef ENABLE_SVR_PAM_AUTH
#if defined(HAVE_SECURITY_PAM_APPL_H)
#include <security/pam_appl.h>
#elif defined (HAVE_PAM_PAM_APPL_H)
#include <pam/pam_appl.h>
#endif
-#ifdef ENABLE_SVR_PAM_AUTH
-
struct UserDataS {
char* user;
char* passwd;
Loading…
Cancel
Save