nuke util-linux in favor of util-linux-ng, build only what we need

SVN-Revision: 9444
v19.07.3_mercusys_ac12_duma
Imre Kaloz 17 years ago
parent 34b4f11508
commit ee65a02320

@ -1,20 +1,21 @@
#
# Copyright (C) 2006 OpenWrt.org
#
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=util-linux
PKG_VERSION:=2.12r
PKG_RELEASE:=2
PKG_NAME:=util-linux-ng
PKG_VERSION:=2.13.0.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/
PKG_MD5SUM:=c261230b27fc0fbcc287c76884caf2d3
PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.13
PKG_MD5SUM:=c841dc8743905c8f0db20c9db5094f57
PKG_BUILD_DEPENDS=libblkid libuuid
include $(INCLUDE_DIR)/package.mk
@ -22,7 +23,7 @@ define Package/util-linux/Default
SECTION:=utils
CATEGORY:=Utilities
DEPENDS:=@!TARGET_etrax
URL:=http://www.kernel.org/pub/linux/utils/util-linux/
URL:=http://www.kernel.org/pub/linux/utils/util-linux-ng/
endef
define Package/fdisk
@ -77,53 +78,38 @@ define Package/hwclock/description
This package contains a utility for managing the hardware clock.
endef
define Build/Configure
# this is NOT GNU configure!
( cd $(PKG_BUILD_DIR); \
CC="$(TARGET_CC)" \
CFLAGS="$(TARGET_CPPFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
./configure \
);
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
OPT="$(TARGET_CFLAGS)" \
INSTALLSUID="install -m 4755" \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
endef
define Package/Template
@if [ \! -f "$(PKG_INSTALL_DIR)/$(1)" ]; then \
rm -f $(PKG_BUILD_DIR)/.built; \
$(MAKE) $(PKG_BUILD_DIR)/.built; \
fi
$(INSTALL_DIR) $(2)
$(CP) $(PKG_INSTALL_DIR)/$(1) $(2)/
$(MAKE) -C $(PKG_BUILD_DIR)/disk-utils mkswap
$(MAKE) -C $(PKG_BUILD_DIR)/mount swapon losetup
$(MAKE) -C $(PKG_BUILD_DIR)/fdisk fdisk cfdisk
$(MAKE) -C $(PKG_BUILD_DIR)/hwclock hwclock
endef
define Package/fdisk/install
$(call Package/Template,sbin/fdisk,$(1)/usr/sbin)
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/fdisk $(1)/usr/sbin/
endef
define Package/cfdisk/install
$(call Package/Template,sbin/cfdisk,$(1)/usr/sbin)
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/cfdisk $(1)/usr/sbin/
endef
define Package/losetup/install
$(call Package/Template,sbin/losetup,$(1)/usr/sbin)
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/losetup $(1)/usr/sbin/
endef
define Package/swap-utils/install
$(call Package/Template,sbin/mkswap,$(1)/usr/sbin)
$(call Package/Template,sbin/swapon,$(1)/usr/sbin)
$(call Package/Template,sbin/swapoff,$(1)/usr/sbin)
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/disk-utils/mkswap $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/swapon $(1)/usr/sbin/
ln -sf swapon $(1)/usr/sbin/swapoff
endef
define Package/hwclock/install
$(call Package/Template,sbin/hwclock,$(1)/usr/sbin)
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hwclock/hwclock $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,fdisk))

@ -1,74 +0,0 @@
Index: util-linux-2.12r/fdisk/llseek.c
===================================================================
--- util-linux-2.12r.orig/fdisk/llseek.c 2007-06-04 13:22:28.258559328 +0200
+++ util-linux-2.12r/fdisk/llseek.c 2007-06-04 13:22:28.339547016 +0200
@@ -29,16 +29,10 @@
static int _llseek (unsigned int, unsigned long,
unsigned long, long long *, unsigned int);
-#ifdef __NR__llseek
-
-static _syscall5(int,_llseek,unsigned int,fd,unsigned long,offset_high,
- unsigned long, offset_low,long long *,result,
- unsigned int, origin)
-
-#else
+#ifndef __NR__llseek
/* no __NR__llseek on compilation machine - might give it explicitly */
-static int _llseek (unsigned int fd, unsigned long oh,
+static int __llseek (unsigned int fd, unsigned long oh,
unsigned long ol, long long *result,
unsigned int origin) {
errno = ENOSYS;
@@ -47,17 +41,8 @@
#endif
-static long long my_llseek (unsigned int fd, long long offset,
- unsigned int origin)
-{
- long long result;
- int retval;
-
- retval = _llseek (fd, ((unsigned long long) offset) >> 32,
- ((unsigned long long) offset) & 0xffffffff,
- &result, origin);
- return (retval == -1 ? (long long) retval : result);
-}
+extern long long llseek(unsigned int fd, long long offset, unsigned int origin);
+#define my_llseek llseek
#endif /* __alpha__ */
Index: util-linux-2.12r/fdisk/sfdisk.c
===================================================================
--- util-linux-2.12r.orig/fdisk/sfdisk.c 2007-06-04 13:22:28.265558264 +0200
+++ util-linux-2.12r/fdisk/sfdisk.c 2007-06-04 13:22:28.338547168 +0200
@@ -176,12 +176,6 @@
#define use_lseek
#endif
-#ifndef use_lseek
-static __attribute__used
-_syscall5(int, _llseek, unsigned int, fd, ulong, hi, ulong, lo,
- loff_t *, res, unsigned int, wh);
-#endif
-
static int
sseek(char *dev, unsigned int fd, unsigned long s) {
loff_t in, out;
Index: util-linux-2.12r/partx/partx.c
===================================================================
--- util-linux-2.12r.orig/partx/partx.c 2007-06-04 13:22:28.272557200 +0200
+++ util-linux-2.12r/partx/partx.c 2007-06-04 13:22:28.339547016 +0200
@@ -339,9 +339,6 @@
#ifdef NEED__llseek
#include <linux/unistd.h> /* _syscall */
-static
-_syscall5(int, _llseek, uint, fd, ulong, hi, ulong, lo,
- long long *, res, uint, wh);
#endif
static int

@ -1,70 +0,0 @@
Index: util-linux-2.12r/MCONFIG
===================================================================
--- util-linux-2.12r.orig/MCONFIG 2007-06-04 13:22:28.239562216 +0200
+++ util-linux-2.12r/MCONFIG 2007-06-04 13:22:28.549515096 +0200
@@ -16,8 +16,8 @@
# Select for ARCH one of intel, alpha, sparc, arm, m68k, mips
# Select for CPU i386 if the binaries must be able to run on an intel 386
# (by default i486 code is generated, see below)
-CPU=$(shell uname -m)
-ARCH=$(shell echo $(CPU) | sed 's/i.86/intel/;s/arm.*/arm/')
+CPU=
+ARCH=mips
# If HAVE_PAM is set to "yes", then login, chfn, chsh, and newgrp
# will use PAM for authentication. Additionally, passwd will not be
@@ -64,12 +64,12 @@
# If HAVE_WRITE is set to "yes", then write will not be built or
# installed from the misc-utils subdirectory.
# (There is a network aware write in netwrite from NetKit 0.16 or later.)
-HAVE_WRITE=no
+HAVE_WRITE=yes
# If HAVE_GETTY is set to "yes", then agetty will not be built or
# installed from the login-utils subdirectory. Note that agetty can
# co-exist with other gettys, so this option should never be used.
-HAVE_GETTY=no
+HAVE_GETTY=yes
# If USE_TTY_GROUP is set to "yes", then wall and write will be installed
# setgid to the "tty" group, and mesg will only set the group write bit.
@@ -82,13 +82,13 @@
# If HAVE_KILL is set to "yes", then kill will not be built or
# installed from the misc-utils subdirectory.
# (There is also a kill in the procps package.)
-HAVE_KILL=no
+HAVE_KILL=yes
# If ALLOW_VCS_USE is set to "yes", then login will chown /dev/vcsN
# to the current user, allowing her to make a screendump and do other
# nifty things on the console, but also allowing him to keep an open
# file descriptor after logging out to trick the next user.
-ALLOW_VCS_USE=yes
+ALLOW_VCS_USE=no
# If DO_STAT_MAIL is set to "yes", then login will stat() the mailbox
# and tell the user that she has new mail. This can hang the login if
@@ -102,19 +102,19 @@
# If HAVE_SLN is set to "yes", then sln won't be installed
# (but the man page sln.8 will be installed anyway).
# sln also comes with libc and glibc.
-HAVE_SLN=no
+HAVE_SLN=yes
# If HAVE_FDUTILS is set to "yes", then setfdprm won't be installed.
-HAVE_FDUTILS=no
+HAVE_FDUTILS=yes
# If SILENT_PG is set to "yes", then pg will not ring the bell
# when an invalid key is pressed
-SILENT_PG=no
+SILENT_PG=yes
# If configure decides that Native Language Support (NLS) is available,
# it sets MAY_ENABLE_NLS in defines.h. If you don't want NLS, set
# DISABLE_NLS to "yes".
-DISABLE_NLS=no
+DISABLE_NLS=yes
# Different optimizations for different cpus.
# Before gcc 2.8.0 only -m486

@ -1,13 +0,0 @@
Index: util-linux-2.12r/mount/umount.c
===================================================================
--- util-linux-2.12r.orig/mount/umount.c 2007-06-04 13:22:28.218565408 +0200
+++ util-linux-2.12r/mount/umount.c 2007-06-04 13:22:28.736486672 +0200
@@ -31,7 +31,7 @@
#include <arpa/inet.h>
#endif
-#if defined(MNT_FORCE) && !defined(__sparc__) && !defined(__arm__)
+#if defined(MNT_FORCE)
/* Interesting ... it seems libc knows about MNT_FORCE and presumably
about umount2 as well -- need not do anything */
#else /* MNT_FORCE */

@ -1,11 +0,0 @@
--- util-linux-2.12r.orig/fdisk/fdiskbsdlabel.h 2007-06-12 21:32:25.000000000 +0200
+++ util-linux-2.12r/fdisk/fdiskbsdlabel.h 2007-06-12 21:33:20.000000000 +0200
@@ -43,7 +43,7 @@
#define BSD_LINUX_BOOTDIR "/usr/ucb/mdec"
-#if defined (i386) || defined (__sparc__) || defined (__arm__) || defined (__mips__) || defined (__s390__) || defined (__sh__) || defined(__x86_64__)
+#if defined (i386) || defined (__sparc__) || defined (__arm__) || defined (__mips__) || defined (__s390__) || defined (__sh__) || defined(__x86_64__) || defined (__cris__) || defined(__avr32__)
#define BSD_LABELSECTOR 1
#define BSD_LABELOFFSET 0
#elif defined (__alpha__) || defined (__powerpc__) || defined (__ia64__) || defined (__hppa__)
Loading…
Cancel
Save