utils/util-linux: Update to 2.29.2

Update util-linux to 2.29.2
Remote 0001-fix-uClibc-ng-scanf-check.patch as it's been merged upstream.
Refresh patches
Change ncurses to ncursesw to fix compilation and avoid confusion

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
v19.07.3_mercusys_ac12_duma
Daniel Engberg 7 years ago committed by John Crispin
parent 480a6aec98
commit eac1a54857

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=util-linux
PKG_VERSION:=2.28
PKG_VERSION:=2.29.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.28
PKG_HASH:=395847e2a18a2c317170f238892751e73a57104565344f8644090c8b091014bb
PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.29
PKG_HASH:=accea4d678209f97f634f40a93b7e9fcad5915d1f4749f6c47bee6bf110fe8e3
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:= COPYING \
@ -147,7 +147,7 @@ endef
define Package/cal
$(call Package/util-linux/Default)
TITLE:=display a calendar
DEPENDS:= +libncurses
DEPENDS:= +libncursesw
endef
define Package/cal/description
@ -157,7 +157,7 @@ endef
define Package/cfdisk
$(call Package/util-linux/Default)
TITLE:=display or manipulate disk partition table
DEPENDS:= +libblkid +libncurses +libsmartcols +libfdisk +libmount
DEPENDS:= +libblkid +libncursesw +libsmartcols +libfdisk +libmount
SUBMENU:=Disc
endef
@ -341,7 +341,7 @@ endef
define Package/setterm
$(call Package/util-linux/Default)
TITLE:=set terminal attributes
DEPENDS:= +libncurses
DEPENDS:= +libncursesw
SUBMENU:=Terminal
endef
@ -440,7 +440,7 @@ CONFIGURE_ARGS += \
--without-python \
--without-udev \
--without-readline \
$(if $(CONFIG_PACKAGE_cal)$(CONFIG_PACKAGE_cfdisk)$(CONFIG_PACKAGE_setterm),--with-ncurses,--without-ncurses)
$(if $(CONFIG_PACKAGE_cal)$(CONFIG_PACKAGE_cfdisk)$(CONFIG_PACKAGE_setterm),--with-ncursesw,--without-ncurses)
TARGET_CFLAGS += $(FPIC) -std=gnu99

@ -1,34 +0,0 @@
From 180c908e2e80552b19bf3552667fc197d6edf7b3 Mon Sep 17 00:00:00 2001
From: Waldemar Brodkorb <wbx@uclibc-ng.org>
Date: Fri, 3 Jun 2016 04:13:08 +0200
Subject: [PATCH] fix uClibc-ng scanf check
uClibc-ng tries to be compatible with GNU libc and defines
__GLIBC__ and pretend to be version 2.2.
We once changed it to 2.10, but then some hard to fix problems
in different software packages (gcc) occured.
It would be better if we disable the special GNU libc checks
for uClibc-ng here. uClibc-ng implements the required scanf
functionality.
Signed-off-by: Waldemar Brodkorb <wbx@uclibc-ng.org>
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index f36b18c..4661c0d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -581,7 +581,7 @@ AC_CACHE_VAL([scanf_cv_alloc_modifier],
#include <stdio.h>
#include <unistd.h>
- #ifdef __GLIBC__
+ #if defined(__GLIBC__) && !defined(__UCLIBC__)
#if !(__GLIBC_PREREQ(2, 7))
#error %m is not available
--
2.1.4

@ -10,7 +10,7 @@
endif # BUILD_LIBUUID
--- a/configure.ac
+++ b/configure.ac
@@ -2122,18 +2122,23 @@ AC_CONFIG_HEADERS([config.h])
@@ -2165,18 +2165,23 @@ AC_CONFIG_HEADERS([config.h])
#
AC_CONFIG_FILES([
Makefile

Loading…
Cancel
Save