Browse Source

treewide: add sysupgrade comment for early DSA-adopters

Add a specific comment for early DSA-adopters that they can keep
their config when prompted due to compat-version increase.

This is a temporary solution, the patch should be simply reverted
before any release.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
master
Adrian Schmutzler 2 years ago
parent
commit
e81e625ca3
  1. 3
      target/linux/kirkwood/image/Makefile
  2. 3
      target/linux/mvebu/image/cortexa9.mk
  3. 3
      target/linux/ramips/image/mt7621.mk

3
target/linux/kirkwood/image/Makefile

@ -12,7 +12,8 @@ KERNEL_LOADADDR:=0x8000
define Device/dsa-migration
DEVICE_COMPAT_VERSION := 1.1
DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA \
(early adopters with DSA already set up may just force-flash keeping existing config)
endef
define Device/Default

3
target/linux/mvebu/image/cortexa9.mk

@ -8,7 +8,8 @@
define Device/dsa-migration
DEVICE_COMPAT_VERSION := 1.1
DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA \
(early adopters with DSA already set up may just force-flash keeping existing config)
endef
define Device/buffalo_ls421de

3
target/linux/ramips/image/mt7621.mk

@ -107,7 +107,8 @@ endef
define Device/dsa-migration
DEVICE_COMPAT_VERSION := 1.1
DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA \
(early adopters with DSA already set up may just force-flash keeping existing config)
endef
define Device/adslr_g7

Loading…
Cancel
Save