iperf3: update to 3.2

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
v19.07.3_mercusys_ac12_duma
Philip Prindeville 7 years ago committed by John Crispin
parent e665b3df2a
commit d55fff4ae7

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=iperf
PKG_VERSION:=3.1.7
PKG_VERSION:=3.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://downloads.es.net/pub/iperf
PKG_HASH:=a4ef73406fe92250602b8da2ae89ec53211f805df97a1d1d629db5a14043734f
PKG_HASH:=f207b36f861485845dbdf09f909c62f3d2222a3cf3d2682095aede8213cd9c1d
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=BSD-3-Clause
@ -23,15 +23,19 @@ PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
DISABLE_NLS:=
define Package/iperf3
SECTION:=net
CATEGORY:=Network
TITLE:=Internet Protocol bandwidth measuring tool
URL:=https://github.com/esnet/iperf
DEPENDS:= +libopenssl
endef
TARGET_CFLAGS += -D_GNU_SOURCE
CONFIGURE_ARGS += --disable-shared
CONFIGURE_ARGS += --disable-shared \
--with-openssl="$(STAGING_DIR)/usr"
MAKE_FLAGS += noinst_PROGRAMS=

@ -0,0 +1,17 @@
commit 31d5b6b580a356c5149dbc4f53118b7f83c60822
Author: Philip Prindeville <philipp@redfish-solutions.com>
Date: Sun Jul 30 18:54:46 2017 -0600
Subject: Add required RSA header for OpenSSL
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
--- a/src/iperf_auth.c 2017-06-26 11:42:56.000000000 -0600
+++ b/src/iperf_auth.c 2017-07-30 17:42:43.070447875 -0600
@@ -40,6 +40,7 @@
#include <openssl/pem.h>
#include <openssl/sha.h>
#include <openssl/buffer.h>
+#include <openssl/rsa.h>
void sha256(const char *string, char outputBuffer[65])
{
Loading…
Cancel
Save