dropbear: bump to 2020.80

- drop patches (applied upstream)
 * 001-backport_GNU_SOURCE-for-random.patch
 * 002-backport-move-GNU_SOURCE-earlier.patch
 * 010-backport-disable-toom-and-karatsuba.patch

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
master
Hans Dedecker 4 years ago
parent 835c932ccb
commit d4c80f5b17

@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dropbear
PKG_VERSION:=2020.79
PKG_VERSION:=2020.80
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
http://matt.ucc.asn.au/dropbear/releases/ \
https://dropbear.nl/mirror/releases/
PKG_HASH:=084f00546b1610a3422a0773e2c04cbe1a220d984209e033b548b49f379cc441
PKG_HASH:=d927941b91f2da150b2033f1a88b6a47999bf0afb1493a73e9216cffdb5d7949
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE

@ -1,25 +0,0 @@
From 3f5c106a880a02b21739f2022746e6aa7672474c Mon Sep 17 00:00:00 2001
From: Matt Johnston <matt@ucc.asn.au>
Date: Tue, 23 Jun 2020 21:38:46 +0800
Subject: [PATCH] _GNU_SOURCE for random
---
includes.h | 2 ++
1 file changed, 2 insertions(+)
diff --git a/includes.h b/includes.h
index e8c3e18..2789f23 100644
--- a/includes.h
+++ b/includes.h
@@ -125,6 +125,8 @@
#endif
#ifdef HAVE_SYS_RANDOM_H
+/* uclibc needs _GNU_SOURCE */
+#define _GNU_SOURCE
#include <sys/random.h>
#endif
--
2.25.1

@ -1,34 +0,0 @@
From a7a67585cbc3fe5df85c641618b347a51a943356 Mon Sep 17 00:00:00 2001
From: Matt Johnston <matt@ucc.asn.au>
Date: Tue, 23 Jun 2020 22:24:58 +0800
Subject: [PATCH] move GNU_SOURCE earlier
---
includes.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/includes.h b/includes.h
index 2789f23..884ebf7 100644
--- a/includes.h
+++ b/includes.h
@@ -25,6 +25,8 @@
#ifndef DROPBEAR_INCLUDES_H_
#define DROPBEAR_INCLUDES_H_
+/* uclibc needs _GNU_SOURCE, maybe other things? */
+#define _GNU_SOURCE
#include "options.h"
#include "debug.h"
@@ -125,8 +127,6 @@
#endif
#ifdef HAVE_SYS_RANDOM_H
-/* uclibc needs _GNU_SOURCE */
-#define _GNU_SOURCE
#include <sys/random.h>
#endif
--
2.25.1

@ -1,17 +0,0 @@
From: Matt Johnston <matt@ucc.asn.au>
Date: Thu, 18 Jun 2020 19:12:07 +0800
Subject: Disable toom and karatsuba for new libtommath
--- a/libtommath/tommath_class.h
+++ b/libtommath/tommath_class.h
@@ -1312,6 +1312,10 @@
#undef BN_MP_KARATSUBA_SQR_C
#undef BN_MP_TOOM_MUL_C
#undef BN_MP_TOOM_SQR_C
+#undef BN_S_MP_KARATSUBA_MUL_C
+#undef BN_S_MP_KARATSUBA_SQR_C
+#undef BN_S_MP_TOOM_MUL_C
+#undef BN_S_MP_TOOM_SQR_C
#include "dbmalloc.h"
#define MP_MALLOC m_malloc
Loading…
Cancel
Save