kernel: update kernel 4.4 to version 4.4.20

Refresh patches for all targets that support kernel 4.4.
Compile-tested on brcm2708 only.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
v19.07.3_mercusys_ac12_duma
Álvaro Fernández Rojas 8 years ago
parent 65c5d097a4
commit d14c28fc80

@ -4,11 +4,11 @@ LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .29
LINUX_VERSION-4.1 = .20
LINUX_VERSION-4.4 = .19
LINUX_VERSION-4.4 = .20
LINUX_KERNEL_MD5SUM-3.18.29 = b25737a0bc98e80d12200de93f239c28
LINUX_KERNEL_MD5SUM-4.1.20 = 075c38a3a23ca5bc80437b13606df00a
LINUX_KERNEL_MD5SUM-4.4.19 = 03dfcd3522015afde8d7a5c0b6e5d6b6
LINUX_KERNEL_MD5SUM-4.4.20 = c66bec8499919b3058d4792c12c4e98c
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))

@ -37,19 +37,17 @@ Signed-off-by: Jacek Anaszewski <j.anaszewski@samsung.com>
create mode 100644 drivers/leds/trigger/ledtrig-disk.c
delete mode 100644 drivers/leds/trigger/ledtrig-ide-disk.c
diff --git a/drivers/ata/libata-core.c b/drivers/ata/libata-core.c
index 6be7770..2eca572 100644
--- a/drivers/ata/libata-core.c
+++ b/drivers/ata/libata-core.c
@@ -69,6 +69,7 @@
#include <asm/unaligned.h>
@@ -67,6 +67,7 @@
#include <asm/byteorder.h>
#include <linux/cdrom.h>
#include <linux/ratelimit.h>
+#include <linux/leds.h>
#include <linux/pm_runtime.h>
#include <linux/platform_device.h>
@@ -5072,6 +5073,9 @@ void ata_qc_complete(struct ata_queued_cmd *qc)
@@ -4914,6 +4915,9 @@ void ata_qc_complete(struct ata_queued_c
{
struct ata_port *ap = qc->ap;
@ -59,11 +57,9 @@ index 6be7770..2eca572 100644
/* XXX: New EH and old EH use different mechanisms to
* synchronize EH with regular execution path.
*
diff --git a/drivers/ide/ide-disk.c b/drivers/ide/ide-disk.c
index 05dbcce..5ceb176 100644
--- a/drivers/ide/ide-disk.c
+++ b/drivers/ide/ide-disk.c
@@ -186,7 +186,7 @@ static ide_startstop_t ide_do_rw_disk(ide_drive_t *drive, struct request *rq,
@@ -186,7 +186,7 @@ static ide_startstop_t ide_do_rw_disk(id
BUG_ON(drive->dev_flags & IDE_DFLAG_BLOCKED);
BUG_ON(rq->cmd_type != REQ_TYPE_FS);
@ -72,8 +68,6 @@ index 05dbcce..5ceb176 100644
pr_debug("%s: %sing: block=%llu, sectors=%u\n",
drive->name, rq_data_dir(rq) == READ ? "read" : "writ",
diff --git a/drivers/leds/trigger/Kconfig b/drivers/leds/trigger/Kconfig
index 9893d91..3f9ddb9 100644
--- a/drivers/leds/trigger/Kconfig
+++ b/drivers/leds/trigger/Kconfig
@@ -33,12 +33,12 @@ config LEDS_TRIGGER_ONESHOT
@ -92,9 +86,7 @@ index 9893d91..3f9ddb9 100644
+ This allows LEDs to be controlled by disk activity.
If unsure, say Y.
config LEDS_TRIGGER_MTD
diff --git a/drivers/leds/trigger/Makefile b/drivers/leds/trigger/Makefile
index 8cc64a4..a72c43c 100644
config LEDS_TRIGGER_HEARTBEAT
--- a/drivers/leds/trigger/Makefile
+++ b/drivers/leds/trigger/Makefile
@@ -1,6 +1,6 @@
@ -104,10 +96,7 @@ index 8cc64a4..a72c43c 100644
+obj-$(CONFIG_LEDS_TRIGGER_DISK) += ledtrig-disk.o
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
diff --git a/drivers/leds/trigger/ledtrig-disk.c b/drivers/leds/trigger/ledtrig-disk.c
new file mode 100644
index 0000000..cd525b4
obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
--- /dev/null
+++ b/drivers/leds/trigger/ledtrig-disk.c
@@ -0,0 +1,41 @@
@ -152,11 +141,8 @@ index 0000000..cd525b4
+ return 0;
+}
+device_initcall(ledtrig_disk_init);
diff --git a/drivers/leds/trigger/ledtrig-ide-disk.c b/drivers/leds/trigger/ledtrig-ide-disk.c
deleted file mode 100644
index 15123d3..0000000
--- a/drivers/leds/trigger/ledtrig-ide-disk.c 2016-07-11 18:31:24.000000000 +0200
+++ /dev/null 2016-08-08 12:56:55.887448160 +0200
--- a/drivers/leds/trigger/ledtrig-ide-disk.c
+++ /dev/null
@@ -1,47 +0,0 @@
-/*
- * LED IDE-Disk Activity Trigger
@ -205,11 +191,9 @@ index 15123d3..0000000
-MODULE_AUTHOR("Richard Purdie <rpurdie@openedhand.com>");
-MODULE_DESCRIPTION("LED IDE Disk Activity Trigger");
-MODULE_LICENSE("GPL");
diff --git a/include/linux/leds.h b/include/linux/leds.h
index e5e7f2e..0aa3701 100644
--- a/include/linux/leds.h
+++ b/include/linux/leds.h
@@ -325,10 +325,10 @@ static inline void *led_get_trigger_data(struct led_classdev *led_cdev)
@@ -302,10 +302,10 @@ static inline void *led_get_trigger_data
#endif /* CONFIG_LEDS_TRIGGERS */
/* Trigger specific functions */
@ -222,7 +206,4 @@ index e5e7f2e..0aa3701 100644
+static inline void ledtrig_disk_activity(void) {}
#endif
#ifdef CONFIG_LEDS_TRIGGER_MTD
--
2.8.1
#if defined(CONFIG_LEDS_TRIGGER_CAMERA) || defined(CONFIG_LEDS_TRIGGER_CAMERA_MODULE)

@ -1,6 +1,6 @@
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -1039,4 +1039,12 @@ config GPIO_VIPERBOARD
@@ -1040,4 +1040,12 @@ config GPIO_VIPERBOARD
endmenu

@ -99,7 +99,7 @@
+#endif
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -990,7 +990,6 @@ menu "SPI GPIO expanders"
@@ -991,7 +991,6 @@ menu "SPI GPIO expanders"
config GPIO_74X164
tristate "74x164 serial-in/parallel-out 8-bits shift register"

@ -1,6 +1,6 @@
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -1046,4 +1046,9 @@ config GPIO_NXP_74HC153
@@ -1047,4 +1047,9 @@ config GPIO_NXP_74HC153
Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
provides a GPIO interface supporting input mode only.

@ -18,8 +18,6 @@ Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
drivers/net/ethernet/stmicro/stmmac/common.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/net/ethernet/stmicro/stmmac/common.h b/drivers/net/ethernet/stmicro/stmmac/common.h
index 623c6ed..6396b81 100644
--- a/drivers/net/ethernet/stmicro/stmmac/common.h
+++ b/drivers/net/ethernet/stmicro/stmmac/common.h
@@ -42,7 +42,7 @@
@ -31,6 +29,3 @@ index 623c6ed..6396b81 100644
/* Extra statistic and debug information exposed by ethtool */
struct stmmac_extra_stats {
--
2.7.4

@ -18,8 +18,6 @@ Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
drivers/net/ethernet/stmicro/stmmac/common.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/net/ethernet/stmicro/stmmac/common.h b/drivers/net/ethernet/stmicro/stmmac/common.h
index 623c6ed..6396b81 100644
--- a/drivers/net/ethernet/stmicro/stmmac/common.h
+++ b/drivers/net/ethernet/stmicro/stmmac/common.h
@@ -42,7 +42,7 @@
@ -31,6 +29,3 @@ index 623c6ed..6396b81 100644
/* Extra statistic and debug information exposed by ethtool */
struct stmmac_extra_stats {
--
2.7.4

@ -52,7 +52,7 @@
if (!ath25_board.radio)
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -141,6 +141,13 @@ config GPIO_BRCMSTB
@@ -142,6 +142,13 @@ config GPIO_BRCMSTB
help
Say yes here to enable GPIO support for Broadcom STB (BCM7XXX) SoCs.

@ -75,7 +75,7 @@
* workaround. Attempt to jump to the mips reset location -
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -141,6 +141,13 @@ config GPIO_BRCMSTB
@@ -142,6 +142,13 @@ config GPIO_BRCMSTB
help
Say yes here to enable GPIO support for Broadcom STB (BCM7XXX) SoCs.

@ -659,7 +659,7 @@ dwc_otg: Remove duplicate gadget probe/unregister function
}
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
@@ -4973,7 +4973,7 @@ static void port_event(struct usb_hub *h
@@ -4972,7 +4972,7 @@ static void port_event(struct usb_hub *h
if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
u16 status = 0, unused;

@ -26,7 +26,7 @@ request that the VPU toggles LEDs.
CONFIG_W1=m
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -132,6 +132,12 @@ config GPIO_BCM_KONA
@@ -133,6 +133,12 @@ config GPIO_BCM_KONA
help
Turn on GPIO support for Broadcom "Kona" chips.

@ -14,7 +14,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -132,6 +132,13 @@ config GPIO_BCM_KONA
@@ -133,6 +133,13 @@ config GPIO_BCM_KONA
help
Turn on GPIO support for Broadcom "Kona" chips.

@ -1,6 +1,6 @@
--- a/arch/arm/mach-cns3xxx/laguna.c
+++ b/arch/arm/mach-cns3xxx/laguna.c
@@ -849,7 +849,6 @@ static struct map_desc laguna_io_desc[]
@@ -864,7 +864,6 @@ static struct map_desc laguna_io_desc[]
static void __init laguna_map_io(void)
{
cns3xxx_map_io();
@ -8,7 +8,7 @@
iotable_init(ARRAY_AND_SIZE(laguna_io_desc));
laguna_early_serial_setup();
}
@@ -873,15 +872,6 @@ static int laguna_register_gpio(struct g
@@ -888,15 +887,6 @@ static int laguna_register_gpio(struct g
return ret;
}
@ -24,7 +24,7 @@
static int __init laguna_model_setup(void)
{
u32 __iomem *mem;
@@ -1077,5 +1067,6 @@ MACHINE_START(GW2388, "Gateworks Corpora
@@ -1099,5 +1089,6 @@ MACHINE_START(GW2388, "Gateworks Corpora
.init_irq = cns3xxx_init_irq,
.init_time = cns3xxx_timer_init,
.init_machine = laguna_init,

@ -8,7 +8,7 @@
#include <linux/gpio.h>
#include <linux/dma-mapping.h>
#include <linux/serial_core.h>
@@ -872,6 +873,47 @@ static int laguna_register_gpio(struct g
@@ -887,6 +888,47 @@ static int laguna_register_gpio(struct g
return ret;
}
@ -56,7 +56,7 @@
static int __init laguna_model_setup(void)
{
u32 __iomem *mem;
@@ -883,8 +925,33 @@ static int __init laguna_model_setup(voi
@@ -898,8 +940,33 @@ static int __init laguna_model_setup(voi
printk("Running on Gateworks Laguna %s\n", laguna_info.model);
cns3xxx_gpio_init( 0, 32, CNS3XXX_GPIOA_BASE_VIRT, IRQ_CNS3XXX_GPIOA,
NR_IRQS_CNS3XXX);

@ -23,7 +23,7 @@
/* The Mellanox Tavor device gives false positive parity errors
* Mark this device with a broken_parity_status, to allow
* PCI scanning code to "skip" this now blacklisted device.
@@ -2963,6 +2964,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
@@ -2975,6 +2976,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x65f9, quirk_intel_mc_errata);
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x65fa, quirk_intel_mc_errata);
@ -31,7 +31,7 @@
/*
* Ivytown NTB BAR sizes are misreported by the hardware due to an erratum. To
@@ -3019,6 +3021,8 @@ static void fixup_debug_report(struct pc
@@ -3031,6 +3033,8 @@ static void fixup_debug_report(struct pc
}
}
@ -40,7 +40,7 @@
/*
* Some BIOS implementations leave the Intel GPU interrupts enabled,
* even though no one is handling them (f.e. i915 driver is never loaded).
@@ -3053,6 +3057,8 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_IN
@@ -3065,6 +3069,8 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_IN
DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x010a, disable_igfx_irq);
DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x0152, disable_igfx_irq);

@ -612,7 +612,7 @@
+module_exit(gpiommc_modexit);
--- a/drivers/mmc/host/Kconfig
+++ b/drivers/mmc/host/Kconfig
@@ -566,6 +566,31 @@ config MMC_SDHI
@@ -567,6 +567,31 @@ config MMC_SDHI
This provides support for the SDHI SD/SDIO controller found in
SuperH and ARM SH-Mobile SoCs

@ -34,7 +34,7 @@
+MODULE_LICENSE("GPL");
--- a/kernel/sched/core.c
+++ b/kernel/sched/core.c
@@ -2072,6 +2072,7 @@ int wake_up_state(struct task_struct *p,
@@ -2075,6 +2075,7 @@ int wake_up_state(struct task_struct *p,
{
return try_to_wake_up(p, state, 0);
}

@ -1,6 +1,6 @@
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -696,6 +696,14 @@ config GPIO_SX150X
@@ -697,6 +697,14 @@ config GPIO_SX150X
8 bits: sx1508q
16 bits: sx1509q

@ -20,7 +20,7 @@ Subject: [PATCH 32/36] USB: fix roothub for IFXHCD
choice
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
@@ -4358,7 +4358,7 @@ hub_port_init(struct usb_hub *hub, struc
@@ -4356,7 +4356,7 @@ hub_port_init(struct usb_hub *hub, struc
udev->ttport = hdev->ttport;
} else if (udev->speed != USB_SPEED_HIGH
&& hdev->speed == USB_SPEED_HIGH) {

@ -1428,7 +1428,7 @@ Reviewed-by: Daniel Thompson <daniel.thompson@linaro.org>
/*
* Returns zero if the TRB isn't in this segment, otherwise it returns the DMA
@@ -3083,17 +3084,22 @@ static u32 xhci_td_remainder(struct xhci
@@ -3084,17 +3085,22 @@ static u32 xhci_td_remainder(struct xhci
{
u32 maxp, total_packet_count;
@ -1455,7 +1455,7 @@ Reviewed-by: Daniel Thompson <daniel.thompson@linaro.org>
/* Queueing functions don't count the current TRB into transferred */
return (total_packet_count - ((transferred + trb_buff_len) / maxp));
}
@@ -3481,7 +3487,7 @@ int xhci_queue_ctrl_tx(struct xhci_hcd *
@@ -3482,7 +3488,7 @@ int xhci_queue_ctrl_tx(struct xhci_hcd *
field |= 0x1;
/* xHCI 1.0/1.1 6.4.1.2.1: Transfer Type field */

@ -23,7 +23,7 @@ Signed-off-by: Andrew Lunn <andrew@lunn.ch>
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -294,6 +294,11 @@ config GPIO_MVEBU
@@ -295,6 +295,11 @@ config GPIO_MVEBU
depends on OF
select GENERIC_IRQ_CHIP

@ -72,7 +72,7 @@
+ };
--- a/drivers/mmc/host/Kconfig
+++ b/drivers/mmc/host/Kconfig
@@ -436,6 +436,16 @@ config MMC_MXS
@@ -437,6 +437,16 @@ config MMC_MXS
If unsure, say N.

@ -47,7 +47,7 @@ Cc: linux-gpio@vger.kernel.org
+#endif /* __ASM_MACH_RALINK_GPIO_H */
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -351,6 +351,12 @@ config GPIO_SAMSUNG
@@ -352,6 +352,12 @@ config GPIO_SAMSUNG
Legacy GPIO support. Use only for platforms without support for
pinctrl.

@ -26,7 +26,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
bool "SGI IP22 (Indy/Indigo2)"
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -260,6 +260,12 @@ config GPIO_MB86S7X
@@ -261,6 +261,12 @@ config GPIO_MB86S7X
help
Say yes here to support the GPIO controller in Fujitsu MB86S70 SoCs.

@ -1420,7 +1420,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
/*
* Returns zero if the TRB isn't in this segment, otherwise it returns the DMA
@@ -3083,17 +3084,22 @@ static u32 xhci_td_remainder(struct xhci
@@ -3084,17 +3085,22 @@ static u32 xhci_td_remainder(struct xhci
{
u32 maxp, total_packet_count;
@ -1447,7 +1447,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
/* Queueing functions don't count the current TRB into transferred */
return (total_packet_count - ((transferred + trb_buff_len) / maxp));
}
@@ -3481,7 +3487,7 @@ int xhci_queue_ctrl_tx(struct xhci_hcd *
@@ -3482,7 +3488,7 @@ int xhci_queue_ctrl_tx(struct xhci_hcd *
field |= 0x1;
/* xHCI 1.0/1.1 6.4.1.2.1: Transfer Type field */

@ -25,7 +25,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/mmc/host/Kconfig
+++ b/drivers/mmc/host/Kconfig
@@ -810,3 +810,5 @@ config MMC_MTK
@@ -811,3 +811,5 @@ config MMC_MTK
If you have a machine with a integrated SD/MMC card reader, say Y or M here.
This is needed if support for any SD/SDIO/MMC devices is required.
If unsure, say N.

Loading…
Cancel
Save