ar71xx: refresh patches

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 37349
v19.07.3_mercusys_ac12_duma
Felix Fietkau 11 years ago
parent 3197479290
commit c77eca3108

@ -1,6 +1,6 @@
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
@@ -163,6 +163,12 @@ config MTD_BCM47XX_PARTS
@@ -172,6 +172,12 @@ config MTD_BCM47XX_PARTS
This provides partitions parser for devices based on BCM47xx
boards.

@ -1,6 +1,6 @@
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
@@ -165,7 +165,7 @@ config MTD_BCM47XX_PARTS
@@ -174,7 +174,7 @@ config MTD_BCM47XX_PARTS
config MTD_WRT160NL_PARTS
tristate "Linksys WRT160NL partitioning support"
@ -9,7 +9,7 @@
---help---
Linksys WRT160NL partitioning support
@@ -185,6 +185,12 @@ config MTD_MYLOADER_PARTS
@@ -194,6 +194,12 @@ config MTD_MYLOADER_PARTS
You will still need the parsing functions to be called by the driver
for your particular device. It won't happen automatically.

@ -1,7 +1,5 @@
Index: linux-3.10/arch/mips/ath79/machtypes.h
===================================================================
--- linux-3.10.orig/arch/mips/ath79/machtypes.h 2013-07-11 22:29:04.592988418 +0200
+++ linux-3.10/arch/mips/ath79/machtypes.h 2013-07-11 22:42:15.781006779 +0200
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
@@ -16,22 +16,125 @@
enum ath79_mach_type {
@ -128,11 +126,9 @@ Index: linux-3.10/arch/mips/ath79/machtypes.h
};
#endif /* _ATH79_MACHTYPE_H */
Index: linux-3.10/arch/mips/ath79/Kconfig
===================================================================
--- linux-3.10.orig/arch/mips/ath79/Kconfig 2013-07-11 22:29:04.592988418 +0200
+++ linux-3.10/arch/mips/ath79/Kconfig 2013-07-11 22:41:53.245006256 +0200
@@ -2,6 +2,61 @@
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
@@ -2,6 +2,61 @@ if ATH79
menu "Atheros AR71XX/AR724X/AR913X machine selection"
@ -194,7 +190,7 @@ Index: linux-3.10/arch/mips/ath79/Kconfig
config ATH79_MACH_AP121
bool "Atheros AP121 reference board"
select SOC_AR933X
@@ -11,62 +66,654 @@
@@ -11,62 +66,654 @@ config ATH79_MACH_AP121
select ATH79_DEV_M25P80
select ATH79_DEV_USB
select ATH79_DEV_WMAC
@ -875,7 +871,7 @@ Index: linux-3.10/arch/mips/ath79/Kconfig
config ATH79_MACH_UBNT_XM
bool "Ubiquiti Networks XM/UniFi boards"
@@ -83,6 +730,34 @@
@@ -83,6 +730,34 @@ config ATH79_MACH_UBNT_XM
Say 'Y' here if you want your kernel to support the
Ubiquiti Networks XM (rev 1.0) board.
@ -910,7 +906,7 @@ Index: linux-3.10/arch/mips/ath79/Kconfig
endmenu
config SOC_AR71XX
@@ -132,7 +807,10 @@
@@ -132,7 +807,10 @@ config ATH79_DEV_DSA
config ATH79_DEV_ETH
def_bool n
@ -922,7 +918,7 @@ Index: linux-3.10/arch/mips/ath79/Kconfig
def_bool n
config ATH79_DEV_GPIO_BUTTONS
@@ -164,4 +842,7 @@
@@ -164,4 +842,7 @@ config ATH79_PCI_ATH9K_FIXUP
config ATH79_ROUTERBOOT
def_bool n
@ -930,11 +926,9 @@ Index: linux-3.10/arch/mips/ath79/Kconfig
+ def_bool n
+
endif
Index: linux-3.10/arch/mips/ath79/Makefile
===================================================================
--- linux-3.10.orig/arch/mips/ath79/Makefile 2013-07-11 22:29:04.400988414 +0200
+++ linux-3.10/arch/mips/ath79/Makefile 2013-07-11 22:42:39.673007333 +0200
@@ -38,9 +38,79 @@
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
@@ -38,9 +38,79 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
#
# Machines
#
@ -1014,11 +1008,9 @@ Index: linux-3.10/arch/mips/ath79/Makefile
+obj-$(CONFIG_ATH79_MACH_WZR_HP_G450H) += mach-wzr-hp-g450h.o
+obj-$(CONFIG_ATH79_MACH_ZCN_1523H) += mach-zcn-1523h.o
+obj-$(CONFIG_ATH79_MACH_CARAMBOLA2) += mach-carambola2.o
Index: linux-3.10/arch/mips/ath79/prom.c
===================================================================
--- linux-3.10.orig/arch/mips/ath79/prom.c 2013-07-11 22:29:04.128988408 +0200
+++ linux-3.10/arch/mips/ath79/prom.c 2013-07-11 22:29:04.620988419 +0200
@@ -180,6 +180,11 @@
--- a/arch/mips/ath79/prom.c
+++ b/arch/mips/ath79/prom.c
@@ -180,6 +180,11 @@ void __init prom_init(void)
ath79_prom_append_cmdline("board", env);
}
}

@ -4,11 +4,9 @@ If the userland tries to set a timeout higher than the max_timeout, then we shou
Signed-off-by: John Crispin <blogic@openwrt.org>
Index: linux-3.8.13/drivers/watchdog/ath79_wdt.c
===================================================================
--- linux-3.8.13.orig/drivers/watchdog/ath79_wdt.c 2013-07-14 14:10:19.198826462 +0200
+++ linux-3.8.13/drivers/watchdog/ath79_wdt.c 2013-07-14 14:25:40.810848422 +0200
@@ -103,10 +103,14 @@
--- a/drivers/watchdog/ath79_wdt.c
+++ b/drivers/watchdog/ath79_wdt.c
@@ -105,10 +105,14 @@ static inline void ath79_wdt_disable(voi
static int ath79_wdt_set_timeout(int val)
{

Loading…
Cancel
Save