move ltq-ifxos

SVN-Revision: 34692
v19.07.3_mercusys_ac12_duma
John Crispin 12 years ago
parent 2c33df0376
commit c2738a9559

@ -1,12 +0,0 @@
--- a/src/linux/ifxos_linux_thread_drv.c
+++ b/src/linux/ifxos_linux_thread_drv.c
@@ -34,7 +34,9 @@
#include <linux/sched.h>
#include <linux/version.h>
#include <linux/completion.h>
+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,33))
#include <linux/smp_lock.h>
+#endif
#include <linux/signal.h>

@ -1,9 +1,7 @@
#
# Copyright (C) 2009-2010 OpenWrt.org
# Copyright (C) 2009-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
@ -19,7 +17,9 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
include $(INCLUDE_DIR)/package.mk
define KernelPackage/ltq-ifxos
SUBMENU:=Voice over IP
SECTION:=sys
CATEGORY:=Kernel modules
SUBMENU:=Libraries
TITLE:=Lantiq OS abstraction library
URL:=http://www.lantiq.com/
DEPENDS:=@TARGET_lantiq

@ -9,3 +9,13 @@
AC_SUBST([KERNEL_BUILD_PATH],[$enableval])
else
AC_MSG_ERROR([The kernel build directory is not valid or not configured!])
--- a/src/linux/ifxos_linux_thread_drv.c
+++ b/src/linux/ifxos_linux_thread_drv.c
@@ -34,7 +34,6 @@
#include <linux/sched.h>
#include <linux/version.h>
#include <linux/completion.h>
-#include <linux/smp_lock.h>
#include <linux/signal.h>
Loading…
Cancel
Save