samba36: update to 3.6.11 and refresh patches (based on patch from #12914)

SVN-Revision: 35382
v19.07.3_mercusys_ac12_duma
Felix Fietkau 11 years ago
parent b31c63b42a
commit c16879a385

@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=samba
PKG_VERSION:=3.6.5
PKG_RELEASE:=2
PKG_VERSION:=3.6.11
PKG_RELEASE:=1
PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
http://ftp.samba.org/pub/samba/old-versions
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_MD5SUM:=2f0c14547333c1b48fd4728b031e7040
PKG_MD5SUM:=9039e0ab3e4fc632ff0a1a8f2433edb4
PKG_LICENSE:=GPLv3
PKG_LICENSE_FILES:=COPYING

@ -1,13 +1,13 @@
--- a/source3/configure
+++ b/source3/configure
@@ -13285,10 +13285,7 @@ if test x"$libreplace_cv_HAVE_GETADDRINF
@@ -13318,10 +13318,7 @@ if test x"$libreplace_cv_HAVE_GETADDRINF
# see bug 5910, use our replacements if we detect
# a broken system.
if test "$cross_compiling" = yes; then :
- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
-as_fn_error "cannot run test program while cross compiling
-See \`config.log' for more details." "$LINENO" 5; }
-as_fn_error $? "cannot run test program while cross compiling
-See \`config.log' for more details" "$LINENO" 5; }
+ $as_echo "assuming valid getaddrinfo without bug 5910" >&2
else
cat confdefs.h - <<_ACEOF >conftest.$ac_ext

@ -34,7 +34,7 @@
BIN_PROGS1 = bin/smbclient@EXEEXT@ bin/net@EXEEXT@ bin/smbspool@EXEEXT@ \
bin/testparm@EXEEXT@ bin/smbstatus@EXEEXT@ bin/smbget@EXEEXT@ \
@@ -1774,6 +1774,42 @@ bin/.dummy:
@@ -1775,6 +1775,42 @@ bin/.dummy:
dir=bin $(MAKEDIR); fi
@: >> $@ || : > $@ # what a fancy emoticon!

@ -1,6 +1,6 @@
--- a/source3/Makefile.in
+++ b/source3/Makefile.in
@@ -1016,7 +1016,7 @@ TEST_LP_LOAD_OBJ = param/test_lp_load.o
@@ -1017,7 +1017,7 @@ TEST_LP_LOAD_OBJ = param/test_lp_load.o
PASSWD_UTIL_OBJ = utils/passwd_util.o
@ -9,7 +9,7 @@
$(PARAM_OBJ) $(LIBSMB_OBJ) $(PASSDB_OBJ) \
$(GROUPDB_OBJ) $(LIB_NONSMBD_OBJ) $(KRBCLIENT_OBJ) \
$(POPT_LIB_OBJ) $(SMBLDAP_OBJ) \
@@ -1788,7 +1788,7 @@ nmbd/nmbd_multicall.o: nmbd/nmbd.c nmbd/
@@ -1789,7 +1789,7 @@ nmbd/nmbd_multicall.o: nmbd/nmbd.c nmbd/
echo "$(COMPILE_CC_PATH)" 1>&2;\
$(COMPILE_CC_PATH) >/dev/null 2>&1
@ -18,7 +18,7 @@
@echo Compiling $<.c
@$(COMPILE_CC_PATH) -Dmain=smbpasswd_main && exit 0;\
echo "The following command failed:" 1>&2;\
@@ -1797,7 +1797,7 @@ utils/smbpasswd_multicall.o: utils/smbpa
@@ -1798,7 +1798,7 @@ utils/smbpasswd_multicall.o: utils/smbpa
SMBD_MULTI_O = $(patsubst smbd/server.o,smbd/server_multicall.o,$(SMBD_OBJ))
NMBD_MULTI_O = $(patsubst nmbd/nmbd.o,nmbd/nmbd_multicall.o,$(filter-out $(LIB_DUMMY_OBJ),$(NMBD_OBJ)))

@ -38,7 +38,7 @@
pid = sys_fork();
--- a/source3/utils/net_rpc.c
+++ b/source3/utils/net_rpc.c
@@ -7791,6 +7791,10 @@ int net_rpc_printer(struct net_context *
@@ -7798,6 +7798,10 @@ int net_rpc_printer(struct net_context *
{NULL, NULL, 0, NULL, NULL}
};
@ -51,7 +51,7 @@
d_printf(_("Usage:\n"));
--- a/source3/smbd/reply.c
+++ b/source3/smbd/reply.c
@@ -5194,7 +5194,11 @@ void reply_printopen(struct smb_request
@@ -5196,7 +5196,11 @@ void reply_printopen(struct smb_request
return;
}
@ -64,7 +64,7 @@
reply_nterror(req, NT_STATUS_ACCESS_DENIED);
END_PROFILE(SMBsplopen);
return;
@@ -5300,7 +5304,10 @@ void reply_printqueue(struct smb_request
@@ -5302,7 +5306,10 @@ void reply_printqueue(struct smb_request
is really quite gross and only worked when there was only
one printer - I think we should now only accept it if they
get it right (tridge) */
@ -212,7 +212,7 @@
}
--- a/source3/smbd/server_exit.c
+++ b/source3/smbd/server_exit.c
@@ -142,7 +142,9 @@ static void exit_server_common(enum serv
@@ -141,7 +141,9 @@ static void exit_server_common(enum serv
rpc_eventlog_shutdown();
rpc_ntsvcs_shutdown();
rpc_svcctl_shutdown();
@ -224,7 +224,7 @@
rpc_winreg_shutdown();
--- a/source3/smbd/open.c
+++ b/source3/smbd/open.c
@@ -1556,6 +1556,9 @@ static NTSTATUS open_file_ntcreate(conne
@@ -1566,6 +1566,9 @@ static NTSTATUS open_file_ntcreate(conne
* Most of the passed parameters are ignored.
*/
@ -236,7 +236,7 @@
}
--- a/source3/smbd/close.c
+++ b/source3/smbd/close.c
@@ -638,6 +638,9 @@ static NTSTATUS close_normal_file(struct
@@ -643,6 +643,9 @@ static NTSTATUS close_normal_file(struct
status = ntstatus_keeperror(status, tmp);
if (fsp->print_file) {
@ -261,7 +261,7 @@
errno = ret;
--- a/source3/smbd/smb2_create.c
+++ b/source3/smbd/smb2_create.c
@@ -485,7 +485,10 @@ static struct tevent_req *smbd_smb2_crea
@@ -486,7 +486,10 @@ static struct tevent_req *smbd_smb2_crea
info = FILE_WAS_OPENED;
} else if (CAN_PRINT(smb1req->conn)) {
status = file_new(smb1req, smb1req->conn, &result);
@ -303,7 +303,7 @@
}
--- a/source3/smbd/process.c
+++ b/source3/smbd/process.c
@@ -2475,8 +2475,10 @@ static bool housekeeping_fn(const struct
@@ -2476,8 +2476,10 @@ static bool housekeeping_fn(const struct
change_to_root_user();
@ -327,30 +327,20 @@
DEBUG(10,("Got message saying pcap was updated. Reloading.\n"));
change_to_root_user();
reload_printers(ev_ctx, msg);
@@ -1211,8 +1213,10 @@ extern void build_options(bool screen);
if (!W_ERROR_IS_OK(registry_init_full()))
exit(1);
@@ -1231,6 +1233,7 @@ extern void build_options(bool screen);
* The print backend init also migrates the printing tdb's,
* this requires a winreg pipe.
*/
+#ifdef PRINTER_SUPPORT
if (!print_backend_init(smbd_messaging_context()))
exit(1);
+#endif
/* Open the share_info.tdb here, so we don't have to open
after the fork on every single connection. This is a small
@@ -1256,6 +1260,7 @@ extern void build_options(bool screen);
exit(1);
}
+#ifdef PRINTER_SUPPORT
/* Publish nt printers, this requires a working winreg pipe */
pcap_cache_reload(server_event_context(), smbd_messaging_context(),
&reload_printers);
@@ -1284,6 +1289,7 @@ extern void build_options(bool screen);
@@ -1262,7 +1265,7 @@ extern void build_options(bool screen);
smbd_messaging_context());
}
}
-
+#endif
if (!is_daemon) {
/* inetd mode */
TALLOC_FREE(frame);

@ -59,7 +59,7 @@
wkssvc_cb.shutdown = NULL;
--- a/source3/smbd/server_exit.c
+++ b/source3/smbd/server_exit.c
@@ -133,7 +133,9 @@ static void exit_server_common(enum serv
@@ -132,7 +132,9 @@ static void exit_server_common(enum serv
if (am_parent) {
rpc_wkssvc_shutdown();

@ -69,7 +69,7 @@
initshutdown_cb.shutdown = NULL;
--- a/source3/smbd/server_exit.c
+++ b/source3/smbd/server_exit.c
@@ -141,9 +141,11 @@ static void exit_server_common(enum serv
@@ -140,9 +140,11 @@ static void exit_server_common(enum serv
#endif
rpc_netdfs_shutdown();
rpc_initshutdown_shutdown();

@ -59,7 +59,7 @@
srvsvc_cb.shutdown = NULL;
--- a/source3/smbd/server_exit.c
+++ b/source3/smbd/server_exit.c
@@ -151,7 +151,9 @@ static void exit_server_common(enum serv
@@ -150,7 +150,9 @@ static void exit_server_common(enum serv
#endif
rpc_srvsvc_shutdown();

@ -47,7 +47,7 @@
return false;
--- a/source3/smbd/server_exit.c
+++ b/source3/smbd/server_exit.c
@@ -139,7 +139,9 @@ static void exit_server_common(enum serv
@@ -138,7 +138,9 @@ static void exit_server_common(enum serv
#ifdef DEVELOPER
rpc_rpcecho_shutdown();
#endif

@ -48,7 +48,7 @@
}
--- a/source3/smbd/server_exit.c
+++ b/source3/smbd/server_exit.c
@@ -157,7 +157,9 @@ static void exit_server_common(enum serv
@@ -156,7 +156,9 @@ static void exit_server_common(enum serv
rpc_winreg_shutdown();
#endif
@ -172,7 +172,7 @@
}
--- a/source3/smbd/process.c
+++ b/source3/smbd/process.c
@@ -2483,8 +2483,10 @@ static bool housekeeping_fn(const struct
@@ -2484,8 +2484,10 @@ static bool housekeeping_fn(const struct
/* check if we need to reload services */
check_reload(sconn, time_mono(NULL));

@ -63,7 +63,7 @@
netlogon_cb.init = netlogon_init_cb;
--- a/source3/smbd/server_exit.c
+++ b/source3/smbd/server_exit.c
@@ -160,7 +160,9 @@ static void exit_server_common(enum serv
@@ -159,7 +159,9 @@ static void exit_server_common(enum serv
#ifdef NETLOGON_SUPPORT
rpc_netlogon_shutdown();
#endif

@ -30,7 +30,7 @@
"supported by backend");
--- a/source3/smbd/server.c
+++ b/source3/smbd/server.c
@@ -1210,8 +1210,10 @@ extern void build_options(bool screen);
@@ -1184,8 +1184,10 @@ extern void build_options(bool screen);
exit(1);
}
@ -39,5 +39,5 @@
exit(1);
+#endif
#ifdef PRINTER_SUPPORT
if (!print_backend_init(smbd_messaging_context()))
/* Open the share_info.tdb here, so we don't have to open
after the fork on every single connection. This is a small

@ -14,7 +14,7 @@
return false;
--- a/source3/smbd/server_exit.c
+++ b/source3/smbd/server_exit.c
@@ -163,7 +163,9 @@ static void exit_server_common(enum serv
@@ -162,7 +162,9 @@ static void exit_server_common(enum serv
#ifdef SAMR_SUPPORT
rpc_samr_shutdown();
#endif

@ -65,7 +65,7 @@
}
--- a/librpc/ndr/libndr.h
+++ b/librpc/ndr/libndr.h
@@ -598,4 +598,20 @@ _PUBLIC_ enum ndr_err_code ndr_push_enum
@@ -604,4 +604,20 @@ _PUBLIC_ enum ndr_err_code ndr_push_enum
_PUBLIC_ void ndr_print_bool(struct ndr_print *ndr, const char *name, const bool b);

@ -8844,7 +8844,7 @@
+done
--- a/librpc/ndr/libndr.h
+++ b/librpc/ndr/libndr.h
@@ -597,6 +597,7 @@ _PUBLIC_ enum ndr_err_code ndr_push_enum
@@ -603,6 +603,7 @@ _PUBLIC_ enum ndr_err_code ndr_push_enum
_PUBLIC_ enum ndr_err_code ndr_push_enum_uint1632(struct ndr_push *ndr, int ndr_flags, uint16_t v);
_PUBLIC_ void ndr_print_bool(struct ndr_print *ndr, const char *name, const bool b);

Loading…
Cancel
Save