(hopefully) fix dsl driver, add linux-atm package

SVN-Revision: 1614
v19.07.3_mercusys_ac12_duma
Felix Fietkau 19 years ago
parent 108b75b30b
commit bde2223432

@ -57,6 +57,7 @@ source "package/iproute2/Config.in"
source "package/kismet/Config.in"
source "package/l2tpd/Config.in"
source "package/lighttpd/Config.in"
source "package/linux-atm/Config.in"
source "package/maradns/Config.in"
source "package/mini_httpd/Config.in"
source "package/mini_sendmail/Config.in"

@ -71,6 +71,7 @@ package-$(BR2_PACKAGE_LIBTASN1) += libtasn1
package-$(BR2_PACKAGE_LIBTOOL) += libtool
package-$(BR2_PACKAGE_LIBUSB) += libusb
package-$(BR2_PACKAGE_LIGHTTPD) += lighttpd
package-$(BR2_PACKAGE_LINUX_ATM) += linux-atm
package-$(BR2_PACKAGE_LUA) += lua
package-$(BR2_PACKAGE_LZO) += lzo
package-$(BR2_PACKAGE_MARADNS) += maradns

@ -0,0 +1,7 @@
config BR2_PACKAGE_LINUX_ATM
tristate "linux-atm - ATM Library/Utilities for Linux"
default y if BR2_LINUX_2_4_AR7
help
ATM Library/Utilities for linux
http://ftp.debian.org/debian/pool/main/l/linux-atm/

@ -0,0 +1,66 @@
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=linux-atm
PKG_VERSION:=2.4.1
PKG_RELEASE:=1
PKG_MD5SUM:=84fef49cc39ff2605204246666f65864
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/l/linux-atm/
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
include $(TOPDIR)/package/rules.mk
ifneq ($(BOARD),ar7)
BR2_PACKAGE_LINUX_ATM:=m
endif
$(eval $(call PKG_template,LINUX_ATM,linux-atm,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
autoconf; \
$(TARGET_CONFIGURE_OPTS) \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--program-prefix="" \
--program-suffix="" \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
--datadir=/usr/share \
--includedir=/usr/src/openwrt/build_mipsel/linux/include/ \
--infodir=/usr/share/info \
--libdir=/usr/lib \
--libexecdir=/usr/lib \
--localstatedir=/var \
--mandir=/usr/share/man \
--sbindir=/usr/sbin \
--sysconfdir=/etc \
)
touch $@
$(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR)
touch $@
$(IPKG_LINUX_ATM):
mkdir -p $(IDIR_LINUX_ATM)/usr/sbin
mkdir -p $(IDIR_LINUX_ATM)/lib
cp $(PKG_BUILD_DIR)/src/br2684/.libs/br2684ctl $(IDIR_LINUX_ATM)/usr/sbin/
cp $(PKG_BUILD_DIR)/src/lib/.libs/libatm.1.0.0 $(IDIR_LINUX_ATM)/lib
ln -sf libatm.1.0.0 $(IDIR_LINUX_ATM)/lib/libatm
ln -sf libatm.1.0.0 $(IDIR_LINUX_ATM)/lib/libatm.1
$(RSTRIP) $(IDIR_LINUX_ATM)/
$(IPKG_BUILD) $(IDIR_LINUX_ATM) $(PACKAGE_DIR)
mostlyclean:
$(MAKE) -C $(PKG_BUILD_DIR) clean
rm -f $(PKG_BUILD_DIR)/.built

@ -0,0 +1,6 @@
Package: linux-atm
Priority: optional
Section: net
Maintainer: nobody
Source: buildroot internal
Description: ATM library and utilities for linux

File diff suppressed because it is too large Load Diff

@ -0,0 +1,311 @@
--- linux-atm-2.4.1.orig/src/br2684/br2684ctl.c
+++ linux-atm-2.4.1/src/br2684/br2684ctl.c
@@ -0,0 +1,251 @@
+#include <stdio.h>
+#include <stdlib.h>
+#include <unistd.h>
+#include <errno.h>
+#include <sys/ioctl.h>
+#include <string.h>
+#include <syslog.h>
+#include <atm.h>
+#include <linux/atmdev.h>
+#include <linux/atmbr2684.h>
+
+/* Written by Marcell GAL <cell@sch.bme.hu> to make use of the */
+/* ioctls defined in the br2684... kernel patch */
+/* Compile with cc -o br2684ctl br2684ctl.c -latm */
+
+/*
+ Modified feb 2001 by Stephen Aaskov (saa@lasat.com)
+ - Added daemonization code
+ - Added syslog
+
+ TODO: Delete interfaces after exit?
+*/
+
+
+#define LOG_NAME "RFC1483/2684 bridge"
+#define LOG_OPTION LOG_PERROR
+#define LOG_FACILITY LOG_LOCAL0
+
+
+int lastsock, lastitf;
+
+
+void fatal(const char *str, int i)
+{
+ syslog (LOG_ERR,"Fatal: %s",str);
+ exit(-2);
+};
+
+
+void exitFunc(void)
+{
+ syslog (LOG_PID,"Daemon terminated\n");
+}
+
+
+int create_br(char *nstr)
+{
+ int num, err;
+
+ if(lastsock<0) {
+ lastsock = socket(PF_ATMPVC, SOCK_DGRAM, ATM_AAL5);
+ }
+ if (lastsock<0) {
+ syslog(LOG_ERR, "socket creation failed: %s",strerror(errno));
+ } else {
+ /* create the device with ioctl: */
+ num=atoi(nstr);
+ if( num>=0 && num<1234567890){
+ struct atm_newif_br2684 ni;
+ ni.backend_num = ATM_BACKEND_BR2684;
+ ni.media = BR2684_MEDIA_ETHERNET;
+ ni.mtu = 1500;
+ sprintf(ni.ifname, "nas%d", num);
+ err=ioctl (lastsock, ATM_NEWBACKENDIF, &ni);
+
+ if (err == 0)
+ syslog(LOG_INFO, "Interface \"%s\" created sucessfully\n",ni.ifname);
+ else
+ syslog(LOG_INFO, "Interface \"%s\" could not be created, reason: %s\n",
+ ni.ifname,
+ strerror(errno));
+ lastitf=num; /* even if we didn't create, because existed, assign_vcc wil want to know it! */
+ } else {
+ syslog(LOG_ERR,"err: strange interface number %d", num );
+ }
+ }
+ return 0;
+}
+
+
+int assign_vcc(char *astr, int encap, int bufsize, struct atm_qos qos)
+{
+ int err;
+ struct sockaddr_atmpvc addr;
+ int fd;
+ struct atm_backend_br2684 be;
+
+ memset(&addr, 0, sizeof(addr));
+ err=text2atm(astr,(struct sockaddr *)(&addr), sizeof(addr), T2A_PVC);
+ if (err!=0)
+ syslog(LOG_ERR,"Could not parse ATM parameters (error=%d)\n",err);
+
+#if 0
+ addr.sap_family = AF_ATMPVC;
+ addr.sap_addr.itf = itf;
+ addr.sap_addr.vpi = 0;
+ addr.sap_addr.vci = vci;
+#endif
+ syslog(LOG_INFO,"Communicating over ATM %d.%d.%d, encapsulation: %s\n", addr.sap_addr.itf,
+ addr.sap_addr.vpi,
+ addr.sap_addr.vci,
+ encap?"VC mux":"LLC");
+
+ if ((fd = socket(PF_ATMPVC, SOCK_DGRAM, ATM_AAL5)) < 0)
+ syslog(LOG_ERR,"failed to create socket %d, reason: %s", errno,strerror(errno));
+
+ if (qos.aal == 0) {
+ qos.aal = ATM_AAL5;
+ qos.txtp.traffic_class = ATM_UBR;
+ qos.txtp.max_sdu = 1524;
+ qos.txtp.pcr = ATM_MAX_PCR;
+ qos.rxtp = qos.txtp;
+ }
+
+ if ( (err=setsockopt(fd,SOL_SOCKET,SO_SNDBUF, &bufsize ,sizeof(bufsize))) )
+ syslog(LOG_ERR,"setsockopt SO_SNDBUF: (%d) %s\n",err, strerror(err));
+
+ if (setsockopt(fd, SOL_ATM, SO_ATMQOS, &qos, sizeof(qos)) < 0)
+ syslog(LOG_ERR,"setsockopt SO_ATMQOS %d", errno);
+
+ err = connect(fd, (struct sockaddr*)&addr, sizeof(struct sockaddr_atmpvc));
+
+ if (err < 0)
+ fatal("failed to connect on socket", err);
+
+ /* attach the vcc to device: */
+
+ be.backend_num = ATM_BACKEND_BR2684;
+ be.ifspec.method = BR2684_FIND_BYIFNAME;
+ sprintf(be.ifspec.spec.ifname, "nas%d", lastitf);
+ be.fcs_in = BR2684_FCSIN_NO;
+ be.fcs_out = BR2684_FCSOUT_NO;
+ be.fcs_auto = 0;
+ be.encaps = encap ? BR2684_ENCAPS_VC : BR2684_ENCAPS_LLC;
+ be.has_vpiid = 0;
+ be.send_padding = 0;
+ be.min_size = 0;
+ err=ioctl (fd, ATM_SETBACKEND, &be);
+ if (err == 0)
+ syslog (LOG_INFO,"Interface configured");
+ else {
+ syslog (LOG_ERR,"Could not configure interface:%s",strerror(errno));
+ exit(2);
+ }
+ return fd ;
+}
+
+
+void usage(char *s)
+{
+ printf("usage: %s [-b] [[-c number] [-e 0|1] [-s sndbuf] [-q qos] [-a [itf.]vpi.vci]*]*\n", s);
+ exit(1);
+}
+
+
+
+int main (int argc, char **argv)
+{
+ int c, background=0, encap=0, sndbuf=8192;
+ struct atm_qos reqqos;
+ lastsock=-1;
+ lastitf=0;
+
+ /* st qos to 0 */
+ memset(&reqqos, 0, sizeof(reqqos));
+
+ openlog (LOG_NAME,LOG_OPTION,LOG_FACILITY);
+ if (argc>1)
+ while ((c = getopt(argc, argv,"q:a:bc:e:s:?h")) !=EOF)
+ switch (c) {
+ case 'q':
+ printf ("optarg : %s",optarg);
+ if (text2qos(optarg,&reqqos,0)) fprintf(stderr,"QOS parameter invalid\n");
+ break;
+ case 'a':
+ assign_vcc(optarg, encap, sndbuf, reqqos);
+ break;
+ case 'b':
+ background=1;
+ break;
+ case 'c':
+ create_br(optarg);
+ break;
+ case 'e':
+ encap=(atoi(optarg));
+ if(encap<0){
+ syslog (LOG_ERR, "invalid encapsulation: %s:\n",optarg);
+ encap=0;
+ }
+ break;
+ case 's':
+ sndbuf=(atoi(optarg));
+ if(sndbuf<0){
+ syslog(LOG_ERR, "Invalid sndbuf: %s, using size of 8192 instead\n",optarg);
+ sndbuf=8192;
+ }
+ break;
+ case '?':
+ case 'h':
+ default:
+ usage(argv[0]);
+ }
+ else
+ usage(argv[0]);
+
+ if (argc != optind) usage(argv[0]);
+
+ if(lastsock>=0) close(lastsock);
+
+ if (background) {
+ pid_t pid;
+
+ pid=fork();
+ if (pid < 0) {
+ fprintf(stderr,"Error detaching\n");
+ exit(2);
+ } else if (pid)
+ exit(0); // This is the parent
+
+ // Become a process group and session group leader
+ if (setsid()<0) {
+ fprintf (stderr,"Could not set process group\n");
+ exit(2);
+ }
+
+ // Fork again to let process group leader exit
+ pid = fork();
+ if (pid < 0) {
+ fprintf(stderr,"Error detaching during second fork\n");
+ exit(2);
+ } else if (pid)
+ exit(0); // This is the parent
+
+ // Now we're ready for buisness
+ chdir("/"); // Don't keep directories in use
+ close(0); close(1); close(2); // Close stdin, -out and -error
+ /*
+ Note that this implementation does not keep an open
+ stdout/err.
+ If we need them they can be opened now
+ */
+
+ }
+
+ syslog (LOG_INFO, "RFC 1483/2684 bridge daemon started\n");
+ atexit (exitFunc);
+
+ while (1) sleep(30); /* to keep the sockets... */
+ return 0;
+}
+
diff -ruN linux-atm-2.4.1/configure.in linux-atm-2.4.1.new/configure.in
--- linux-atm-2.4.1/configure.in 2003-04-25 04:17:05.000000000 +0200
+++ linux-atm-2.4.1.new/configure.in 2005-07-27 15:45:49.532396543 +0200
@@ -153,26 +153,6 @@
src/Makefile \
src/include/Makefile \
src/lib/Makefile \
- src/test/Makefile \
- src/debug/Makefile \
- src/qgen/Makefile \
- src/saal/Makefile \
- src/sigd/Makefile \
- src/maint/Makefile \
- src/arpd/Makefile \
- src/ilmid/Makefile \
- src/ilmid/asn1/Makefile \
- src/man/Makefile \
- src/led/Makefile \
- src/lane/Makefile \
- src/mpoad/Makefile \
- src/switch/Makefile \
- src/switch/debug/Makefile \
- src/switch/tcp/Makefile \
- src/config/Makefile \
- src/config/init-redhat/Makefile \
- src/extra/Makefile \
- src/extra/linux-atm.spec \
- src/extra/ANS/Makefile
+ src/br2684/Makefile \
)
diff -ruN linux-atm-2.4.1/src/br2684/Makefile linux-atm-2.4.1.new/src/br2684/Makefile
--- linux-atm-2.4.1/src/br2684/Makefile 1970-01-01 02:00:00.000000000 +0200
+++ linux-atm-2.4.1.new/src/br2684/Makefile 2002-07-15 23:44:25.000000000 +0200
@@ -0,0 +1,13 @@
+PREFIX=${TI_FILESYSTEM}
+
+all: br2684ctl
+
+br2684ctl: br2684ctl.c
+ gcc -latm -o br2684ctl br2684ctl.c
+ strip br2684ctl
+
+install: br2684ctl
+ cp br2684ctl $(PREFIX)/usr/sbin/
+
+clean:
+ rm -rf br2684ctl *.o
diff -ruN linux-atm-2.4.1/src/Makefile.am linux-atm-2.4.1.new/src/Makefile.am
--- linux-atm-2.4.1/src/Makefile.am 2001-10-03 23:14:53.000000000 +0200
+++ linux-atm-2.4.1.new/src/Makefile.am 2005-07-27 15:33:52.389309711 +0200
@@ -1,3 +1,2 @@
-SUBDIRS = include lib test debug qgen saal sigd maint arpd ilmid man led lane \
- mpoad switch config extra
+SUBDIRS = include lib br2684

@ -0,0 +1,193 @@
diff -ruN linux-atm-2.4.1/src/qgen/Makefile.am linux-atm-2.4.1.new/src/qgen/Makefile.am
--- linux-atm-2.4.1/src/qgen/Makefile.am 2001-09-03 20:41:05.000000000 +0200
+++ linux-atm-2.4.1.new/src/qgen/Makefile.am 2005-07-26 14:49:05.000000000 +0200
@@ -3,7 +3,7 @@
qgen_SOURCES = common.c common.h file.c file.h first.c ql_y.y ql_l.l qgen.c \
qgen.h second.c third.c
-qgen_LDADD = -lfl
+qgen_LDADD =
q_dump_SOURCES = common.c
q_dump_LDADD = qd.dump.standalone.o
diff -ruN linux-atm-2.4.1/src/qgen/Makefile.in linux-atm-2.4.1.new/src/qgen/Makefile.in
--- linux-atm-2.4.1/src/qgen/Makefile.in 2003-04-30 16:44:01.000000000 +0200
+++ linux-atm-2.4.1.new/src/qgen/Makefile.in 2005-07-26 14:49:13.000000000 +0200
@@ -91,7 +91,7 @@
qgen_SOURCES = common.c common.h file.c file.h first.c ql_y.y ql_l.l qgen.c \
qgen.h second.c third.c
-qgen_LDADD = -lfl
+qgen_LDADD =
q_dump_SOURCES = common.c
q_dump_LDADD = qd.dump.standalone.o
diff -ruN linux-atm-2.4.1/src/qgen/ql_l.c linux-atm-2.4.1.new/src/qgen/ql_l.c
--- linux-atm-2.4.1/src/qgen/ql_l.c 2003-04-24 21:46:49.000000000 +0200
+++ linux-atm-2.4.1.new/src/qgen/ql_l.c 2005-07-26 20:45:40.000000000 +0200
@@ -11,6 +11,11 @@
#include <stdio.h>
#include <unistd.h>
+int yywrap(void)
+{
+ return 1;
+}
+
/* cfront 1.2 defines "c_plusplus" instead of "__cplusplus" */
#ifdef c_plusplus
diff -ruN linux-atm-2.4.1/src/sigd/cfg_l.c linux-atm-2.4.1.new/src/sigd/cfg_l.c
--- linux-atm-2.4.1/src/sigd/cfg_l.c 2003-04-24 21:47:21.000000000 +0200
+++ linux-atm-2.4.1.new/src/sigd/cfg_l.c 2005-07-26 22:04:13.000000000 +0200
@@ -11,6 +11,10 @@
#include <stdio.h>
#include <unistd.h>
+int yywrap(void)
+{
+ return 1;
+}
/* cfront 1.2 defines "c_plusplus" instead of "__cplusplus" */
#ifdef c_plusplus
diff -ruN linux-atm-2.4.1/src/sigd/Makefile.am linux-atm-2.4.1.new/src/sigd/Makefile.am
--- linux-atm-2.4.1/src/sigd/Makefile.am 2001-10-04 23:17:26.000000000 +0200
+++ linux-atm-2.4.1.new/src/sigd/Makefile.am 2005-07-26 14:49:44.000000000 +0200
@@ -8,7 +8,7 @@
$(top_builddir)/src/qgen/qd.dump.o \
$(top_builddir)/src/lib/libatm.la \
$(top_builddir)/src/saal/libsaal.a
-atmsigd_LDADD = $(atmsigd_XTRAS) -lfl
+atmsigd_LDADD = $(atmsigd_XTRAS)
atmsigd_DEPENDENCIES = mess.c $(atmsigd_XTRAS)
CLEANFILES = mess.c
diff -ruN linux-atm-2.4.1/src/sigd/Makefile.in linux-atm-2.4.1.new/src/sigd/Makefile.in
--- linux-atm-2.4.1/src/sigd/Makefile.in 2003-04-30 16:44:03.000000000 +0200
+++ linux-atm-2.4.1.new/src/sigd/Makefile.in 2005-07-26 14:49:48.000000000 +0200
@@ -97,7 +97,7 @@
$(top_builddir)/src/lib/libatm.la \
$(top_builddir)/src/saal/libsaal.a
-atmsigd_LDADD = $(atmsigd_XTRAS) -lfl
+atmsigd_LDADD = $(atmsigd_XTRAS)
atmsigd_DEPENDENCIES = mess.c $(atmsigd_XTRAS)
CLEANFILES = mess.c
diff -ruN linux-atm-2.4.1/src/switch/debug/debug.c linux-atm-2.4.1.new/src/switch/debug/debug.c
--- linux-atm-2.4.1/src/switch/debug/debug.c 2001-09-03 20:41:06.000000000 +0200
+++ linux-atm-2.4.1.new/src/switch/debug/debug.c 2005-07-26 22:06:53.000000000 +0200
@@ -20,6 +20,11 @@
#define PRV(call) ((FAB *) (call)->fab)
+int yywrap(void)
+{
+ return 1;
+}
+
typedef struct _fab {
CALL *next; /* relay.c may not keep track of calls, but WE are */
diff -ruN linux-atm-2.4.1/src/switch/debug/Makefile.am linux-atm-2.4.1.new/src/switch/debug/Makefile.am
--- linux-atm-2.4.1/src/switch/debug/Makefile.am 2001-10-04 23:17:26.000000000 +0200
+++ linux-atm-2.4.1.new/src/switch/debug/Makefile.am 2005-07-26 14:50:03.000000000 +0200
@@ -5,7 +5,7 @@
sw_debug_SOURCES = debug.c
sw_debug_XTRAS = $(top_builddir)/src/switch/libsw.a \
$(top_builddir)/src/lib/libatm.la
-sw_debug_LDADD = $(sw_debug_XTRAS) -lfl
+sw_debug_LDADD = $(sw_debug_XTRAS)
sw_debug_DEPENDENCIES = $(sw_debug_XTRAS)
diff -ruN linux-atm-2.4.1/src/switch/debug/Makefile.in linux-atm-2.4.1.new/src/switch/debug/Makefile.in
--- linux-atm-2.4.1/src/switch/debug/Makefile.in 2003-04-30 16:44:13.000000000 +0200
+++ linux-atm-2.4.1.new/src/switch/debug/Makefile.in 2005-07-26 14:50:08.000000000 +0200
@@ -93,7 +93,7 @@
sw_debug_XTRAS = $(top_builddir)/src/switch/libsw.a \
$(top_builddir)/src/lib/libatm.la
-sw_debug_LDADD = $(sw_debug_XTRAS) -lfl
+sw_debug_LDADD = $(sw_debug_XTRAS)
sw_debug_DEPENDENCIES = $(sw_debug_XTRAS)
diff -ruN linux-atm-2.4.1/src/switch/tcp/Makefile.am linux-atm-2.4.1.new/src/switch/tcp/Makefile.am
--- linux-atm-2.4.1/src/switch/tcp/Makefile.am 2001-10-04 23:17:27.000000000 +0200
+++ linux-atm-2.4.1.new/src/switch/tcp/Makefile.am 2005-07-26 14:50:16.000000000 +0200
@@ -5,7 +5,7 @@
sw_tcp_SOURCES = tcpsw.c
sw_tcp_XTRAS = $(top_builddir)/src/switch/libsw.a \
$(top_builddir)/src/lib/libatm.la
-sw_tcp_LDADD = $(sw_tcp_XTRAS) -lfl
+sw_tcp_LDADD = $(sw_tcp_XTRAS)
sw_tcp_DEPENDENCIES = $(sw_tcp_XTRAS)
EXTRA_DIST = mkfiles README
diff -ruN linux-atm-2.4.1/src/switch/tcp/Makefile.in linux-atm-2.4.1.new/src/switch/tcp/Makefile.in
--- linux-atm-2.4.1/src/switch/tcp/Makefile.in 2003-04-30 16:44:14.000000000 +0200
+++ linux-atm-2.4.1.new/src/switch/tcp/Makefile.in 2005-07-26 14:50:19.000000000 +0200
@@ -93,7 +93,7 @@
sw_tcp_XTRAS = $(top_builddir)/src/switch/libsw.a \
$(top_builddir)/src/lib/libatm.la
-sw_tcp_LDADD = $(sw_tcp_XTRAS) -lfl
+sw_tcp_LDADD = $(sw_tcp_XTRAS)
sw_tcp_DEPENDENCIES = $(sw_tcp_XTRAS)
EXTRA_DIST = mkfiles README
diff -ruN linux-atm-2.4.1/src/switch/tcp/tcpsw.c linux-atm-2.4.1.new/src/switch/tcp/tcpsw.c
--- linux-atm-2.4.1/src/switch/tcp/tcpsw.c 2001-09-03 20:41:06.000000000 +0200
+++ linux-atm-2.4.1.new/src/switch/tcp/tcpsw.c 2005-07-26 22:08:25.000000000 +0200
@@ -35,6 +35,10 @@
#define MAX_PACKET (ATM_MAX_AAL5_PDU+sizeof(struct atmtcp_hdr))
#define BUFFER_SIZE (MAX_PACKET*2)
+int yywrap(void)
+{
+ return 1;
+}
typedef struct _table {
struct _link *out; /* output port */
diff -ruN linux-atm-2.4.1/src/test/ispl_l.c linux-atm-2.4.1.new/src/test/ispl_l.c
--- linux-atm-2.4.1/src/test/ispl_l.c 2003-04-24 21:46:39.000000000 +0200
+++ linux-atm-2.4.1.new/src/test/ispl_l.c 2005-07-26 20:45:19.000000000 +0200
@@ -11,6 +11,11 @@
#include <stdio.h>
#include <unistd.h>
+int yywrap(void)
+{
+ return 1;
+}
+
/* cfront 1.2 defines "c_plusplus" instead of "__cplusplus" */
#ifdef c_plusplus
diff -ruN linux-atm-2.4.1/src/test/Makefile.am linux-atm-2.4.1.new/src/test/Makefile.am
--- linux-atm-2.4.1/src/test/Makefile.am 2001-10-04 23:17:27.000000000 +0200
+++ linux-atm-2.4.1.new/src/test/Makefile.am 2005-07-26 14:49:27.000000000 +0200
@@ -15,7 +15,7 @@
bw_SOURCES = bw.c
isp_SOURCES = isp.c isp.h ispl_y.y ispl_l.l
isp_XTRAS = $(LDADD)
-isp_LDADD = $(isp_XTRAS) -lfl
+isp_LDADD = $(isp_XTRAS)
isp_DEPENDENCIES = $(isp_XTRAS) errnos.inc
window_SOURCES = window.c
diff -ruN linux-atm-2.4.1/src/test/Makefile.in linux-atm-2.4.1.new/src/test/Makefile.in
--- linux-atm-2.4.1/src/test/Makefile.in 2003-04-30 16:43:59.000000000 +0200
+++ linux-atm-2.4.1.new/src/test/Makefile.in 2005-07-26 14:49:32.000000000 +0200
@@ -102,7 +102,7 @@
bw_SOURCES = bw.c
isp_SOURCES = isp.c isp.h ispl_y.y ispl_l.l
isp_XTRAS = $(LDADD)
-isp_LDADD = $(isp_XTRAS) -lfl
+isp_LDADD = $(isp_XTRAS)
isp_DEPENDENCIES = $(isp_XTRAS) errnos.inc
window_SOURCES = window.c
Loading…
Cancel
Save