image.mk: prepare for defining device profile data in the Device section

Signed-off-by: Felix Fietkau <nbd@nbd.name>
v19.07.3_mercusys_ac12_duma
Felix Fietkau 8 years ago
parent 40f933d7ff
commit bcf67b6974

@ -439,6 +439,9 @@ endef
define Device/Init
PROFILES := $(PROFILE)
DEVICE_NAME := $(1)
DEVICE_TITLE :=
DEVICE_PACKAGES :=
DEVICE_DESCRIPTION = Build firmware images for $$(DEVICE_TITLE)
KERNEL:=
KERNEL_INITRAMFS = $$(KERNEL)
KERNEL_SIZE:=
@ -548,17 +551,37 @@ define Device/Build
$$(call Device/Build/image,$$(fs),$$(image),$(1)))))
endef
define Device/DumpInfo
Target-Profile: DEVICE_$(1)
Target-Profile-Name: $(DEVICE_TITLE)
Target-Profile-Packages: $(DEVICE_PACKAGES)
Target-Profile-Description:
$(DEVICE_DESCRIPTION)
@@
endef
define Device/Dump
$$(eval $$(if $$(DEVICE_TITLE),$$(info $$(call Device/DumpInfo,$(1)))))
endef
define Device
$(call Device/Init,$(1))
$(call Device/Default,$(1))
$(call Device/Check,$(1))
$(call Device/$(1),$(1))
$(call Device/Build,$(1))
$(call Device/$(if $(DUMP),Dump,Build),$(1))
endef
define BuildImage
ifneq ($(DUMP),)
all: dumpinfo
dumpinfo: FORCE
@true
endif
download:
prepare:
compile:

Loading…
Cancel
Save