busybox: remove i386-specific build flags

busybox tries to be smart and passes a number of additional flags to the
compiler. Unfortunately, the i386-specific flags break ABI compatiblity
with libc.

Fixes busybox crashes observed on x86-generic with GCC 7.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
v19.07.3_mercusys_ac12_duma
Matthias Schiffer 6 years ago
parent 61eee1adfb
commit b8d9a064f0
No known key found for this signature in database
GPG Key ID: 16EF3F64CB201D9C

@ -0,0 +1,10 @@
--- a/arch/i386/Makefile
+++ /dev/null
@@ -1,7 +0,0 @@
-# ==========================================================================
-# Build system
-# ==========================================================================
-
-# -mpreferred-stack-boundary=2 is essential in preventing gcc 4.2.x
-# from aligning stack to 16 bytes. (Which is gcc's way of supporting SSE).
-CFLAGS += $(call cc-option,-march=i386 -mpreferred-stack-boundary=2,)
Loading…
Cancel
Save