dropbear: update to 0.52 (#4635)

SVN-Revision: 15074
v19.07.3_mercusys_ac12_duma
Jo-Philipp Wich 15 years ago
parent 0180abdf49
commit b81b66061f

@ -1,5 +1,5 @@
#
# Copyright (C) 2006-2008 OpenWrt.org
# Copyright (C) 2006-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,14 +9,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dropbear
PKG_VERSION:=0.51
PKG_RELEASE:=2
PKG_VERSION:=0.52
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:= \
http://matt.ucc.asn.au/dropbear/releases/ \
http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
PKG_MD5SUM:=1045df60c2bdbd39c707238305a1e9e5
PKG_MD5SUM:=1c69ec674481d7745452f68f2ea5597e
include $(INCLUDE_DIR)/package.mk

@ -1,8 +1,8 @@
Index: dropbear-0.51/svr-authpubkey.c
Index: dropbear-0.52/svr-authpubkey.c
===================================================================
--- dropbear-0.51.orig/svr-authpubkey.c 2008-04-22 17:29:49.000000000 -0700
+++ dropbear-0.51/svr-authpubkey.c 2008-04-22 17:29:49.000000000 -0700
@@ -176,6 +176,8 @@
--- dropbear-0.52.orig/svr-authpubkey.c 2008-04-22 17:29:49.000000000 -0700
+++ dropbear-0.52/svr-authpubkey.c 2008-04-22 17:29:49.000000000 -0700
@@ -209,6 +209,8 @@
goto out;
}
@ -11,7 +11,7 @@ Index: dropbear-0.51/svr-authpubkey.c
/* we don't need to check pw and pw_dir for validity, since
* its been done in checkpubkeyperms. */
len = strlen(ses.authstate.pw_dir);
@@ -187,6 +189,9 @@
@@ -220,6 +222,9 @@
/* open the file */
authfile = fopen(filename, "r");
@ -21,7 +21,7 @@ Index: dropbear-0.51/svr-authpubkey.c
if (authfile == NULL) {
goto out;
}
@@ -274,6 +279,8 @@
@@ -372,6 +377,8 @@
goto out;
}
@ -30,7 +30,7 @@ Index: dropbear-0.51/svr-authpubkey.c
/* allocate max required pathname storage,
* = path + "/.ssh/authorized_keys" + '\0' = pathlen + 22 */
filename = m_malloc(len + 22);
@@ -295,6 +302,14 @@
@@ -381,6 +388,14 @@
if (checkfileperm(filename) != DROPBEAR_SUCCESS) {
goto out;
}
@ -43,5 +43,5 @@ Index: dropbear-0.51/svr-authpubkey.c
+ }
+ }
/* file looks ok, return success */
ret = DROPBEAR_SUCCESS;
/* check ~/.ssh */
strncat(filename, "/.ssh", 5); /* strlen("/.ssh") == 5 */

@ -1,8 +1,8 @@
Index: dropbear-0.51/svr-chansession.c
Index: dropbear-0.52/svr-chansession.c
===================================================================
--- dropbear-0.51.orig/svr-chansession.c 2008-04-22 17:29:49.000000000 -0700
+++ dropbear-0.51/svr-chansession.c 2008-04-22 17:29:49.000000000 -0700
@@ -912,12 +912,12 @@
--- dropbear-0.52.orig/svr-chansession.c 2008-04-22 17:29:49.000000000 -0700
+++ dropbear-0.52/svr-chansession.c 2008-04-22 17:29:49.000000000 -0700
@@ -852,12 +852,12 @@
/* We can only change uid/gid as root ... */
if (getuid() == 0) {

@ -1,8 +1,8 @@
Index: dropbear-0.51/cli-runopts.c
Index: dropbear-0.52/cli-runopts.c
===================================================================
--- dropbear-0.51.orig/cli-runopts.c 2008-04-22 17:29:49.000000000 -0700
+++ dropbear-0.51/cli-runopts.c 2008-04-22 17:29:50.000000000 -0700
@@ -220,6 +220,10 @@
--- dropbear-0.52.orig/cli-runopts.c 2008-04-22 17:29:49.000000000 -0700
+++ dropbear-0.52/cli-runopts.c 2008-04-22 17:29:50.000000000 -0700
@@ -271,6 +271,10 @@
debug_trace = 1;
break;
#endif
@ -13,7 +13,7 @@ Index: dropbear-0.51/cli-runopts.c
case 'F':
case 'e':
case 'c':
@@ -231,7 +235,6 @@
@@ -282,7 +286,6 @@
#ifndef ENABLE_CLI_LOCALTCPFWD
case 'L':
#endif

@ -1,7 +1,7 @@
Index: dropbear-0.51/options.h
Index: dropbear-0.52/options.h
===================================================================
--- dropbear-0.51.orig/options.h 2008-04-22 17:29:49.000000000 -0700
+++ dropbear-0.51/options.h 2008-04-22 17:29:50.000000000 -0700
--- dropbear-0.52.orig/options.h 2008-04-22 17:29:49.000000000 -0700
+++ dropbear-0.52/options.h 2008-04-22 17:29:50.000000000 -0700
@@ -5,6 +5,11 @@
#ifndef _OPTIONS_H_
#define _OPTIONS_H_

Loading…
Cancel
Save