nftables: bump to version 0.9.2

- exclude Python-related stuff from build
- drop patches:
  * 010-uclibc-ng.patch, applied upstream

ipkg size decrease by 2.8%:
old:
194.851 nftables_0.9.0-2_arm_cortex-a7_neon-vfpv4.ipk
new:
189.581 nftables_0.9.2-1_arm_cortex-a7_neon-vfpv4.ipk

Signed-off-by: Konstantin Demin <rockdrilla@gmail.com>
master
Konstantin Demin 5 years ago committed by Hauke Mehrtens
parent 699955a684
commit b74f1f335a

@ -7,12 +7,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=nftables
PKG_VERSION:=0.9.0
PKG_RELEASE:=2
PKG_VERSION:=0.9.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://netfilter.org/projects/$(PKG_NAME)/files
PKG_HASH:=ad8181b5fcb9ca572f444bed54018749588522ee97e4c21922648bb78d7e7e91
PKG_HASH:=5cb66180143e6bfc774f4eb316206d40ac1cb6df269a90882404cbf7165513f5
PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
PKG_LICENSE:=GPL-2.0
@ -28,6 +28,7 @@ CONFIGURE_ARGS += \
--disable-man-doc \
--with-mini-gmp \
--without-cli \
--disable-python \
define Package/nftables
SECTION:=net

@ -1,28 +0,0 @@
From c65c4f9998587a0c705b3635215f25fa5680c0d3 Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Fri, 3 May 2019 11:49:11 -0700
Subject: gmputil: Add missing header for va_list
Otherwise it errors with unknown type name when using uClibc.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
---
include/gmputil.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/include/gmputil.h b/include/gmputil.h
index 73959c17..ad63d67b 100644
--- a/include/gmputil.h
+++ b/include/gmputil.h
@@ -7,6 +7,7 @@
#include <gmp.h>
#else
#include <mini-gmp.h>
+#include <stdarg.h>
#include <stdio.h>
/* mini-gmp doesn't come with gmp_vfprintf, so we use our own minimal variant */
extern int mpz_vfprintf(FILE *fp, const char *format, va_list args);
--
cgit v1.2.1
Loading…
Cancel
Save