libnl: refresh patches

SVN-Revision: 14233
v19.07.3_mercusys_ac12_duma
Gabor Juhos 16 years ago
parent b05f64dd06
commit b665dfd554

@ -1,8 +1,6 @@
Index: libnl-1.0-pre7/lib/Makefile
===================================================================
--- libnl-1.0-pre7.orig/lib/Makefile 2007-11-16 03:19:22.404997365 +0100
+++ libnl-1.0-pre7/lib/Makefile 2007-11-16 03:22:22.903283376 +0100
@@ -34,6 +34,7 @@
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -36,6 +36,7 @@ CFLAGS += -fPIC
OUT_SLIB := $(PACKAGE_NAME).so.$(PACKAGE_VERSION)
LN_SLIB := $(PACKAGE_NAME).so
LN1_SLIB := $(LN_SLIB).1
@ -10,7 +8,7 @@ Index: libnl-1.0-pre7/lib/Makefile
export
@@ -42,7 +43,7 @@
@@ -44,7 +45,7 @@ export
all:
@echo " MAKE $(OUT_SLIB)"; \
@ -19,7 +17,7 @@ Index: libnl-1.0-pre7/lib/Makefile
$(OUT_SLIB): ../Makefile.opts $(OBJ)
@echo " LD $(OUT_SLIB)"; \
@@ -52,10 +53,15 @@
@@ -54,10 +55,15 @@ $(OUT_SLIB): ../Makefile.opts $(OBJ)
@echo " LN $(LN1_SLIB) $(LN_SLIB)"; \
rm -f $(LN_SLIB) ; $(LN) -s $(LN1_SLIB) $(LN_SLIB)
@ -36,7 +34,7 @@ Index: libnl-1.0-pre7/lib/Makefile
distclean:
@echo " DISTCLEAN lib"; \
@@ -64,6 +70,7 @@
@@ -66,6 +72,7 @@ distclean:
install:
mkdir -p $(DESTDIR)$(libdir)/
install -m 0644 $(OUT_SLIB) $(DESTDIR)$(libdir)

@ -1,8 +1,6 @@
Index: libnl-1.0-pre8/include/netlink-local.h
===================================================================
--- libnl-1.0-pre8.orig/include/netlink-local.h 2007-12-29 13:40:25.242226458 +0100
+++ libnl-1.0-pre8/include/netlink-local.h 2007-12-29 13:40:36.882889824 +0100
@@ -336,7 +336,9 @@
--- a/include/netlink-local.h
+++ b/include/netlink-local.h
@@ -337,7 +337,9 @@ static inline int nl_cb_call(struct nl_c
}
#define ARRAY_SIZE(X) (sizeof(X) / sizeof((X)[0]))

@ -11,9 +11,6 @@ older if_vlan.h versions. Add the current version from the kernel.
Signed-off-by: Patrick McHardy <kaber@trash.net>
---
diff --git a/include/linux/if_vlan.h b/include/linux/if_vlan.h
new file mode 100644
index 0000000..068cd7b
--- /dev/null
+++ b/include/linux/if_vlan.h
@@ -0,0 +1,61 @@

@ -10,11 +10,9 @@ Make valgrind happy ...
Signed-off-by: Patrick McHardy <kaber@trash.net>
---
diff --git a/lib/route/route_utils.c b/lib/route/route_utils.c
index a12d169..1386cda 100644
--- a/lib/route/route_utils.c
+++ b/lib/route/route_utils.c
@@ -63,6 +63,11 @@ static void __init init_routing_table_names(void)
@@ -63,6 +63,11 @@ static void __init init_routing_table_na
add_routing_table_name(RT_TABLE_LOCAL, "local");
};
@ -26,7 +24,7 @@ index a12d169..1386cda 100644
int rtnl_route_read_table_names(const char *path)
{
__trans_list_clear(&table_names);
@@ -104,6 +109,11 @@ static void __init init_proto_names(void)
@@ -104,6 +109,11 @@ static void __init init_proto_names(void
add_proto_name(RTPROT_STATIC, "static");
};

@ -1,7 +1,6 @@
diff -U 3 -H -d -r -N -- libnl-1.1.o/include/netlink/genl/mngt.h libnl-1.1/include/netlink/genl/mngt.h
--- libnl-1.1.o/include/netlink/genl/mngt.h 2008-01-14 18:48:45.000000000 +0300
+++ libnl-1.1/include/netlink/genl/mngt.h 2008-08-18 19:18:54.000000000 +0400
@@ -22,6 +22,15 @@
--- a/include/netlink/genl/mngt.h
+++ b/include/netlink/genl/mngt.h
@@ -22,6 +22,15 @@ extern "C" {
struct nl_cache_ops;
@ -17,10 +16,9 @@ diff -U 3 -H -d -r -N -- libnl-1.1.o/include/netlink/genl/mngt.h libnl-1.1/inclu
/**
* @ingroup genl_mngt
* Generic Netlink Command
diff -U 3 -H -d -r -N -- libnl-1.1.o/include/netlink-types.h libnl-1.1/include/netlink-types.h
--- libnl-1.1.o/include/netlink-types.h 2008-01-14 18:48:45.000000000 +0300
+++ libnl-1.1/include/netlink-types.h 2008-08-18 19:18:30.000000000 +0400
@@ -95,15 +95,6 @@
--- a/include/netlink-types.h
+++ b/include/netlink-types.h
@@ -95,15 +95,6 @@ struct nl_cache_mngr
struct nl_parser_param;
@ -36,9 +34,8 @@ diff -U 3 -H -d -r -N -- libnl-1.1.o/include/netlink-types.h libnl-1.1/include/n
#define LOOSE_FLAG_COMPARISON 1
#define NL_OBJ_MARK 1
diff -U 3 -H -d -r -N -- libnl-1.1.o/src/nl-list-caches.c libnl-1.1/src/nl-list-caches.c
--- libnl-1.1.o/src/nl-list-caches.c 2008-01-14 18:48:45.000000000 +0300
+++ libnl-1.1/src/nl-list-caches.c 2008-08-18 19:20:05.000000000 +0400
--- a/src/nl-list-caches.c
+++ b/src/nl-list-caches.c
@@ -10,6 +10,7 @@
*/
@ -47,9 +44,8 @@ diff -U 3 -H -d -r -N -- libnl-1.1.o/src/nl-list-caches.c libnl-1.1/src/nl-list-
static void print_usage(void)
{
diff -U 3 -H -d -r -N -- libnl-1.1.o/src/utils.c libnl-1.1/src/utils.c
--- libnl-1.1.o/src/utils.c 2008-01-14 18:48:45.000000000 +0300
+++ libnl-1.1/src/utils.c 2008-08-18 19:20:39.000000000 +0400
--- a/src/utils.c
+++ b/src/utils.c
@@ -12,6 +12,7 @@
#include "utils.h"
@ -58,9 +54,8 @@ diff -U 3 -H -d -r -N -- libnl-1.1.o/src/utils.c libnl-1.1/src/utils.c
int nltool_init(int argc, char *argv[])
{
diff -U 3 -H -d -r -N -- libnl-1.1.o/src/utils.h libnl-1.1/src/utils.h
--- libnl-1.1.o/src/utils.h 2008-01-14 18:48:45.000000000 +0300
+++ libnl-1.1/src/utils.h 2008-08-18 19:21:11.000000000 +0400
--- a/src/utils.h
+++ b/src/utils.h
@@ -22,7 +22,6 @@
#include <sys/types.h>
#include <sys/socket.h>

@ -1,5 +1,3 @@
diff --git a/libnl-1.pc.in b/libnl-1.pc.in
index 7ac8413..66a7cd9 100644
--- a/libnl-1.pc.in
+++ b/libnl-1.pc.in
@@ -1,7 +1,7 @@

Loading…
Cancel
Save