au1000: fix InternetBox idsel and remove broken flag

The following patch is necessary for the InternetBox (Surfbox) board-specific
idsel to work with newer kernels. Acutally I don't exactly understand why this
was not necessary before, but without the udelay, the MiniPCI adapter in slot 3
is not detected and set up correctly.

Also remove platform broken flag, it works.

Signed-off-by: Bruno Randolf <br1@einfach.org>

SVN-Revision: 32766
v19.07.3_mercusys_ac12_duma
Florian Fainelli 12 years ago
parent 81a84b03ea
commit b2d76e1e05

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=mipsel
BOARD:=au1000
BOARDNAME:=RMI/AMD AU1x00
FEATURES:=jffs2 usb pci broken
FEATURES:=jffs2 usb pci
SUBTARGETS=au1500 au1550
MAINTAINER:=Florian Fainelli <florian@openwrt.org>

@ -0,0 +1,12 @@
--- a/arch/mips/alchemy/board-mtx1.c 2012-06-11 22:02:34.686604093 +0100
+++ b/arch/mips/alchemy/board-mtx1.c 2012-06-11 22:04:23.375143044 +0100
@@ -228,6 +228,9 @@
* adapter on the mtx-1 "singleboard" variant. It triggers a custom
* logic chip connected to EXT_IO3 (GPIO1) to suppress IDSEL signals.
*/
+
+ udelay(1);
+
if (assert && devsel != 0)
/* Suppress signal to Cardbus */
alchemy_gpio_set_value(1, 0); /* set EXT_IO3 OFF */
Loading…
Cancel
Save