portability fix

SVN-Revision: 5082
v19.07.3_mercusys_ac12_duma
Felix Fietkau 18 years ago
parent f1d6fb4be1
commit afc9d921a7

@ -67,6 +67,7 @@ define Build/Compile
ARCH="$(LINUX_KARCH)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
c_opts="$(KERNEL_C_OPTS)" \
CP="$(CP)" \
all
endef

@ -0,0 +1,20 @@
diff -ur alsa.old/Makefile alsa.dev/Makefile
--- alsa.old/Makefile 2006-10-14 07:07:48.000000000 -0700
+++ alsa.dev/Makefile 2006-10-14 07:08:45.000000000 -0700
@@ -100,6 +100,7 @@
SUBDIRS += parisc
endif
CSUBDIRS += include test utils
+CP = cp -fPR
KCONFIG_FILES = $(shell find $(SND_TOPDIR) -name Kconfig) $(shell find $(SND_TOPDIR)/alsa-kernel/ -name Kconfig)
@@ -115,7 +116,7 @@
if [ ! -d include/sound -a ! -L include/sound ]; then \
ln -sf ../alsa-kernel/include include/sound ; \
fi
- cp -auvf include/version.h include/sound/version.h
+ $(CP) include/version.h include/sound/version.h
utils/mod-deps: utils/mod-deps.c
gcc utils/mod-deps.c -o utils/mod-deps
Loading…
Cancel
Save