toolchain/gcc: update linaro-gcc-4.8 to 2014.04

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 40664
v19.07.3_mercusys_ac12_duma
Felix Fietkau 10 years ago
parent c4ecc47f41
commit af4f534244

@ -34,10 +34,10 @@ ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
PKG_COMP:=bz2
endif
ifeq ($(CONFIG_GCC_VERSION),"4.8-linaro")
PKG_REV:=4.8-2014.01
PKG_REV:=4.8-2014.04
PKG_VERSION:=4.8.3
PKG_VERSION_MAJOR:=4.8
PKG_MD5SUM:=b8bc08b05ff079dcdc020336a67ca4e1
PKG_MD5SUM:=5ba2f3a449b1658ccc09d27cc7ab3c03
PKG_COMP:=xz
endif
PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/

@ -1,6 +1,6 @@
--- a/gcc/Makefile.in
+++ b/gcc/Makefile.in
@@ -4326,18 +4326,10 @@ doc/gcc.info: $(TEXI_GCC_FILES)
@@ -4327,18 +4327,10 @@ doc/gcc.info: $(TEXI_GCC_FILES)
doc/gccint.info: $(TEXI_GCCINT_FILES)
doc/cppinternals.info: $(TEXI_CPPINT_FILES)

@ -1,6 +1,6 @@
--- a/gcc/config.gcc
+++ b/gcc/config.gcc
@@ -551,7 +551,7 @@ case ${target} in
@@ -559,7 +559,7 @@ case ${target} in
esac
# Common C libraries.
@ -9,7 +9,7 @@
# Common parts for widely ported systems.
case ${target} in
@@ -654,6 +654,9 @@ case ${target} in
@@ -662,6 +662,9 @@ case ${target} in
*-*-*uclibc*)
tm_defines="$tm_defines DEFAULT_LIBC=LIBC_UCLIBC"
;;
@ -34,7 +34,7 @@
#undef LINK_SPEC
--- a/gcc/config/i386/linux.h
+++ b/gcc/config/i386/linux.h
@@ -21,3 +21,4 @@ along with GCC; see the file COPYING3.
@@ -21,3 +21,4 @@ along with GCC; see the file COPYING3.
#define GNU_USER_LINK_EMULATION "elf_i386"
#define GLIBC_DYNAMIC_LINKER "/lib/ld-linux.so.2"
@ -127,7 +127,7 @@
+Use musl C library
--- a/gcc/config/mips/linux.h
+++ b/gcc/config/mips/linux.h
@@ -18,3 +18,5 @@ along with GCC; see the file COPYING3.
@@ -18,3 +18,5 @@ along with GCC; see the file COPYING3.
<http://www.gnu.org/licenses/>. */
#define GLIBC_DYNAMIC_LINKER "/lib/ld.so.1"
@ -295,7 +295,7 @@
;;
--- a/gcc/config/mips/linux64.h
+++ b/gcc/config/mips/linux64.h
@@ -27,6 +27,9 @@ along with GCC; see the file COPYING3.
@@ -27,6 +27,9 @@ along with GCC; see the file COPYING3.
#define GLIBC_DYNAMIC_LINKERN32 "/lib32/ld.so.1"
#define UCLIBC_DYNAMIC_LINKERN32 "/lib32/ld-uClibc.so.0"
#define BIONIC_DYNAMIC_LINKERN32 "/system/bin/linker32"
@ -308,7 +308,7 @@
+ BIONIC_DYNAMIC_LINKERN32, MUSL_DYNAMIC_LINKERN32)
--- a/gcc/config/sparc/linux64.h
+++ b/gcc/config/sparc/linux64.h
@@ -95,6 +95,9 @@ along with GCC; see the file COPYING3.
@@ -95,6 +95,9 @@ along with GCC; see the file COPYING3.
#define GLIBC_DYNAMIC_LINKER32 "/lib/ld-linux.so.2"
#define GLIBC_DYNAMIC_LINKER64 "/lib64/ld-linux.so.2"

@ -1,6 +1,6 @@
--- a/gcc/config/arm/arm.h
+++ b/gcc/config/arm/arm.h
@@ -271,7 +271,7 @@ extern void (*arm_lang_output_object_att
@@ -277,7 +277,7 @@ extern void (*arm_lang_output_object_att
/* Thumb-1 only. */
#define TARGET_THUMB1_ONLY (TARGET_THUMB1 && !arm_arch_notm)
@ -8,4 +8,4 @@
+#define TARGET_LDRD (arm_arch6 && ARM_DOUBLEWORD_ALIGN \
&& !TARGET_THUMB1)
/* The following two macros concern the ability to execute coprocessor
#define TARGET_CRC32 (arm_arch_crc)

@ -1,6 +1,6 @@
--- a/gcc/config/rs6000/rs6000.c
+++ b/gcc/config/rs6000/rs6000.c
@@ -17661,7 +17661,7 @@ rs6000_savres_strategy (rs6000_stack_t *
@@ -17662,7 +17662,7 @@ rs6000_savres_strategy (rs6000_stack_t *
/* Define cutoff for using out-of-line functions to save registers. */
if (DEFAULT_ABI == ABI_V4 || TARGET_ELF)
{

@ -157,7 +157,7 @@
{ OPT_LEVELS_2_PLUS, OPT_freorder_blocks, NULL, 1 },
{ OPT_LEVELS_2_PLUS, OPT_freorder_functions, NULL, 1 },
{ OPT_LEVELS_2_PLUS, OPT_ftree_vrp, NULL, 1 },
@@ -488,6 +486,8 @@ static const struct default_options defa
@@ -489,6 +487,8 @@ static const struct default_options defa
{ OPT_LEVELS_2_PLUS, OPT_fhoist_adjacent_loads, NULL, 1 },
/* -O3 optimizations. */
@ -166,7 +166,7 @@
{ OPT_LEVELS_3_PLUS, OPT_ftree_loop_distribute_patterns, NULL, 1 },
{ OPT_LEVELS_3_PLUS, OPT_fpredictive_commoning, NULL, 1 },
/* Inlining of functions reducing size is a good idea with -Os
@@ -1423,6 +1423,17 @@ common_handle_option (struct gcc_options
@@ -1435,6 +1435,17 @@ common_handle_option (struct gcc_options
opts, opts_set, loc, dc);
break;
@ -209,7 +209,7 @@
-Wfatal-errors -Wfloat-equal -Wformat -Wformat=2 @gol
-Wno-format-contains-nul -Wno-format-extra-args -Wformat-nonliteral @gol
-Wformat-security -Wformat-y2k @gol
@@ -4817,6 +4817,22 @@ This option is only supported for C and
@@ -4817,6 +4817,22 @@ This option is only supported for C and
@option{-Wall} and by @option{-Wpedantic}, which can be disabled with
@option{-Wno-pointer-sign}.

Loading…
Cancel
Save