refresh patches

SVN-Revision: 16445
v19.07.3_mercusys_ac12_duma
Hauke Mehrtens 15 years ago
parent 567b6d1a27
commit af0d813825

@ -1,6 +1,6 @@
--- linux-2.6.28.10.orig/arch/mips/mm/c-r4k.c 2009-05-02 20:54:43.000000000 +0200
+++ linux-2.6.28.10/arch/mips/mm/c-r4k.c 2009-06-07 20:36:01.667918000 +0200
@@ -348,7 +348,7 @@
--- a/arch/mips/mm/c-r4k.c
+++ b/arch/mips/mm/c-r4k.c
@@ -360,7 +360,7 @@ static inline void local_r4k___flush_cac
}
}
@ -9,7 +9,7 @@
{
r4k_on_each_cpu(local_r4k___flush_cache_all, NULL, 1);
}
@@ -512,7 +512,7 @@
@@ -524,7 +524,7 @@ static inline void local_r4k_flush_cache
}
}
@ -18,9 +18,9 @@
unsigned long addr, unsigned long pfn)
{
struct flush_cache_page_args args;
@@ -1401,3 +1401,10 @@
#endif
@@ -1430,3 +1430,10 @@ void __cpuinit r4k_cache_init(void)
coherency_setup();
#endif
}
+
+// fuse package DCACHE BUG patch exports

@ -1,7 +1,6 @@
diff -ru linux-2.6.28.10.orig/fs/fuse/dev.c linux-2.6.28.10/fs/fuse/dev.c
--- linux-2.6.28.10.orig/fs/fuse/dev.c 2009-05-02 20:54:43.000000000 +0200
+++ linux-2.6.28.10/fs/fuse/dev.c 2009-06-07 20:29:50.229816000 +0200
@@ -525,6 +525,11 @@
--- a/fs/fuse/dev.c
+++ b/fs/fuse/dev.c
@@ -525,6 +525,11 @@ static void fuse_copy_finish(struct fuse
}
}
@ -13,7 +12,7 @@ diff -ru linux-2.6.28.10.orig/fs/fuse/dev.c linux-2.6.28.10/fs/fuse/dev.c
/*
* Get another pagefull of userspace buffer, and map it to kernel
* address space, and lock request
@@ -533,6 +538,9 @@
@@ -533,6 +538,9 @@ static int fuse_copy_fill(struct fuse_co
{
unsigned long offset;
int err;
@ -23,7 +22,7 @@ diff -ru linux-2.6.28.10.orig/fs/fuse/dev.c linux-2.6.28.10/fs/fuse/dev.c
unlock_request(cs->fc, cs->req);
fuse_copy_finish(cs);
@@ -544,14 +552,22 @@
@@ -544,14 +552,22 @@ static int fuse_copy_fill(struct fuse_co
cs->nr_segs --;
}
down_read(&current->mm->mmap_sem);
@ -46,7 +45,7 @@ diff -ru linux-2.6.28.10.orig/fs/fuse/dev.c linux-2.6.28.10/fs/fuse/dev.c
cs->buf = cs->mapaddr + offset;
cs->len = min(PAGE_SIZE - offset, cs->seglen);
cs->seglen -= cs->len;
@@ -565,6 +581,11 @@
@@ -565,6 +581,11 @@ static int fuse_copy_do(struct fuse_copy
{
unsigned ncpy = min(*size, cs->len);
if (val) {
@ -58,9 +57,8 @@ diff -ru linux-2.6.28.10.orig/fs/fuse/dev.c linux-2.6.28.10/fs/fuse/dev.c
if (cs->write)
memcpy(cs->buf, *val, ncpy);
else
diff -ru linux-2.6.28.10.orig/fs/fuse/fuse_i.h linux-2.6.28.10/fs/fuse/fuse_i.h
--- linux-2.6.28.10.orig/fs/fuse/fuse_i.h 2009-05-02 20:54:43.000000000 +0200
+++ linux-2.6.28.10/fs/fuse/fuse_i.h 2009-06-06 16:34:54.814468000 +0200
--- a/fs/fuse/fuse_i.h
+++ b/fs/fuse/fuse_i.h
@@ -8,6 +8,7 @@
#ifndef _FS_FUSE_I_H
@ -69,10 +67,9 @@ diff -ru linux-2.6.28.10.orig/fs/fuse/fuse_i.h linux-2.6.28.10/fs/fuse/fuse_i.h
#include <linux/fuse.h>
#include <linux/fs.h>
diff -ru linux-2.6.28.10.orig/fs/fuse/inode.c linux-2.6.28.10/fs/fuse/inode.c
--- linux-2.6.28.10.orig/fs/fuse/inode.c 2009-05-02 20:54:43.000000000 +0200
+++ linux-2.6.28.10/fs/fuse/inode.c 2009-06-07 20:33:34.156611000 +0200
@@ -1038,6 +1038,10 @@
--- a/fs/fuse/inode.c
+++ b/fs/fuse/inode.c
@@ -1038,6 +1038,10 @@ static int __init fuse_init(void)
printk("fuse init (API version %i.%i)\n",
FUSE_KERNEL_VERSION, FUSE_KERNEL_MINOR_VERSION);

@ -4,11 +4,9 @@ watchdog driver.
Signed-off-by: Matthieu CASTET <castet.matthieu@free.fr>
Acked-by : Michael Buesch <mb@bu3sch.de>
Index: linux-2.6/drivers/ssb/embedded.c
===================================================================
--- linux-2.6.orig/drivers/ssb/embedded.c 2009-05-22 21:45:50.000000000 +0200
+++ linux-2.6/drivers/ssb/embedded.c 2009-05-22 21:46:07.000000000 +0200
@@ -29,6 +29,7 @@
--- a/drivers/ssb/embedded.c
+++ b/drivers/ssb/embedded.c
@@ -29,6 +29,7 @@ int ssb_watchdog_timer_set(struct ssb_bu
}
return -ENODEV;
}

@ -10,11 +10,9 @@ be build as a module.
Signed-off-by: Aleksandar Radovanovic <biblbroks@sezampro.rs>
Signed-off-by: Matthieu CASTET <castet.matthieu@free.fr>
Index: linux-2.6/drivers/watchdog/Kconfig
===================================================================
--- linux-2.6.orig/drivers/watchdog/Kconfig 2009-05-25 22:22:02.000000000 +0200
+++ linux-2.6/drivers/watchdog/Kconfig 2009-06-05 22:05:19.000000000 +0200
@@ -764,6 +764,12 @@
--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
@@ -747,6 +747,12 @@ config TXX9_WDT
help
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
@ -27,11 +25,9 @@ Index: linux-2.6/drivers/watchdog/Kconfig
# PARISC Architecture
# POWERPC Architecture
Index: linux-2.6/drivers/watchdog/Makefile
===================================================================
--- linux-2.6.orig/drivers/watchdog/Makefile 2009-05-25 22:22:02.000000000 +0200
+++ linux-2.6/drivers/watchdog/Makefile 2009-05-25 23:02:27.000000000 +0200
@@ -105,6 +105,7 @@
--- a/drivers/watchdog/Makefile
+++ b/drivers/watchdog/Makefile
@@ -106,6 +106,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
@ -39,10 +35,8 @@ Index: linux-2.6/drivers/watchdog/Makefile
# PARISC Architecture
Index: linux-2.6/drivers/watchdog/bcm47xx_wdt.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-2.6/drivers/watchdog/bcm47xx_wdt.c 2009-06-05 22:25:37.000000000 +0200
--- /dev/null
+++ b/drivers/watchdog/bcm47xx_wdt.c
@@ -0,0 +1,286 @@
+/*
+ * Watchdog driver for Broadcom BCM47XX

@ -21,11 +21,9 @@ I also added some code to print the irq configuration before and after irq setup
[1] http://www.danm.de/files/src/bcm5365p/REPORTED_DEVICES
Signed-off-by: Matthieu CASTET <castet.matthieu@free.fr>
Index: linux-2.6/drivers/ssb/driver_mipscore.c
===================================================================
--- linux-2.6.orig/drivers/ssb/driver_mipscore.c 2009-05-25 19:47:26.000000000 +0200
+++ linux-2.6/drivers/ssb/driver_mipscore.c 2009-05-25 19:47:42.000000000 +0200
@@ -49,29 +49,54 @@
--- a/drivers/ssb/driver_mipscore.c
+++ b/drivers/ssb/driver_mipscore.c
@@ -49,29 +49,54 @@ static const u32 ipsflag_irq_shift[] = {
static inline u32 ssb_irqflag(struct ssb_device *dev)
{
@ -83,7 +81,7 @@ Index: linux-2.6/drivers/ssb/driver_mipscore.c
return irq;
}
@@ -97,25 +122,56 @@
@@ -97,25 +122,56 @@ static void set_irq(struct ssb_device *d
struct ssb_device *mdev = bus->mipscore.dev;
u32 irqflag = ssb_irqflag(dev);
@ -145,7 +143,7 @@ Index: linux-2.6/drivers/ssb/driver_mipscore.c
}
static void ssb_mips_serial_init(struct ssb_mipscore *mcore)
@@ -195,18 +251,26 @@
@@ -197,18 +253,26 @@ void ssb_mipscore_init(struct ssb_mipsco
else if (bus->chipco.dev)
ssb_chipco_timing_init(&bus->chipco, ns);
@ -174,7 +172,7 @@ Index: linux-2.6/drivers/ssb/driver_mipscore.c
/* fallthrough */
case SSB_DEV_PCI:
case SSB_DEV_ETHERNET:
@@ -220,6 +284,8 @@
@@ -222,6 +286,8 @@ void ssb_mipscore_init(struct ssb_mipsco
}
}
}

Loading…
Cancel
Save