upgrade to 3.0-rc7

SVN-Revision: 27600
v19.07.3_mercusys_ac12_duma
Imre Kaloz 13 years ago
parent 62daf628c0
commit ab5fd3c1cb

@ -3057,7 +3057,7 @@
+the future.
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -4717,6 +4717,13 @@ F: drivers/scsi/osd/
@@ -4727,6 +4727,13 @@ F: drivers/scsi/osd/
F: include/scsi/osd_*
F: fs/exofs/

@ -4,12 +4,12 @@
dst = NULL;
- if (is_multicast_ether_addr(dest)) {
- if (is_broadcast_ether_addr(dest))
+ if (skb->protocol == htons(ETH_P_PAE)) {
+ skb2 = skb;
+ /* Do not forward 802.1x/EAP frames */
+ skb = NULL;
+ } else if (is_multicast_ether_addr(dest)) {
+ } else if (is_broadcast_ether_addr(dest))
skb2 = skb;
else if (is_multicast_ether_addr(dest)) {
mdst = br_mdb_get(br, skb);
if (mdst || BR_INPUT_SKB_CB_MROUTERS_ONLY(skb)) {
if ((mdst && mdst->mglist) ||

@ -43,7 +43,7 @@
#endif
--- a/net/bridge/br_input.c
+++ b/net/bridge/br_input.c
@@ -95,7 +95,8 @@ int br_handle_frame_finish(struct sk_buf
@@ -97,7 +97,8 @@ int br_handle_frame_finish(struct sk_buf
skb2 = skb;
br->dev->stats.multicast++;

@ -829,7 +829,7 @@
+be done automatically.
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -2901,6 +2901,11 @@ L: linuxppc-dev@lists.ozlabs.org
@@ -2911,6 +2911,11 @@ L: linuxppc-dev@lists.ozlabs.org
S: Odd Fixes
F: drivers/tty/hvc/

@ -71,7 +71,7 @@
--- a/mm/memory.c
+++ b/mm/memory.c
@@ -1395,6 +1395,7 @@ unsigned long zap_page_range(struct vm_a
@@ -1396,6 +1396,7 @@ unsigned long zap_page_range(struct vm_a
tlb_finish_mmu(&tlb, address, end);
return end;
}
@ -79,7 +79,7 @@
/**
* zap_vma_ptes - remove ptes mapping the vma
@@ -3014,6 +3015,7 @@ static inline int check_stack_guard_page
@@ -3015,6 +3016,7 @@ static inline int check_stack_guard_page
}
return 0;
}

@ -1,28 +0,0 @@
To get hundredths of MHz the rate needs to be divided by 10'000.
Here is an example:
twd_timer_rate = 123456789
Before the patch:
twd_timer_rate / 1000000 = 123
(twd_timer_rate / 1000000) % 100 = 23
Result: 123.23MHz.
After being fixed:
twd_timer_rate / 1000000 = 123
(twd_timer_rate / 10000) % 100 = 45
Result: 123.45MHz.
Signed-off-by: Vitaly Kuzmichev <vkuzmichev@mvista.com>
---
arch/arm/kernel/smp_twd.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
--- a/arch/arm/kernel/smp_twd.c
+++ b/arch/arm/kernel/smp_twd.c
@@ -115,7 +115,7 @@ static void __cpuinit twd_calibrate_rate
twd_timer_rate = (0xFFFFFFFFU - count) * (HZ / 5);
printk("%lu.%02luMHz.\n", twd_timer_rate / 1000000,
- (twd_timer_rate / 1000000) % 100);
+ (twd_timer_rate / 10000) % 100);
}
}

@ -4,6 +4,6 @@
VERSION = 3
PATCHLEVEL = 0
-SUBLEVEL = 0
EXTRAVERSION = -rc6
EXTRAVERSION = -rc7
NAME = Sneaky Weasel

@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
CFLAGS=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
LINUX_VERSION:=3.0-rc6
LINUX_VERSION:=3.0-rc7
include $(INCLUDE_DIR)/target.mk

Loading…
Cancel
Save