kirkwood/goflexhome/goflexnet: merge "root" and unused mtd partitions into one volume "ubi"

The kernel will automatic attach mtd partitions named 'ubi' to ubi0.
Renaming the "root" partition into "ubi" will safe arguments
from the kernel cmdline.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>

SVN-Revision: 49014
v19.07.3_mercusys_ac12_duma
Luka Perkov 8 years ago
parent 33f76a486d
commit ab13a001dd

@ -1,5 +1,7 @@
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
Index: linux-3.18.27/arch/arm/boot/dts/Makefile
===================================================================
--- linux-3.18.27.orig/arch/arm/boot/dts/Makefile
+++ linux-3.18.27/arch/arm/boot/dts/Makefile
@@ -120,6 +120,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += kirkwood-
kirkwood-ds411.dtb \
kirkwood-ds411j.dtb \
@ -8,9 +10,11 @@
kirkwood-goflexnet.dtb \
kirkwood-guruplug-server-plus.dtb \
kirkwood-ib62x0.dtb \
Index: linux-3.18.27/arch/arm/boot/dts/kirkwood-goflexhome.dts
===================================================================
--- /dev/null
+++ b/arch/arm/boot/dts/kirkwood-goflexhome.dts
@@ -0,0 +1,127 @@
+++ linux-3.18.27/arch/arm/boot/dts/kirkwood-goflexhome.dts
@@ -0,0 +1,117 @@
+/dts-v1/;
+
+#include "kirkwood.dtsi"
@ -109,18 +113,8 @@
+ };
+
+ partition@100000 {
+ label = "uImage";
+ reg = <0x0100000 0x400000>;
+ };
+
+ partition@500000 {
+ label = "pogoplug";
+ reg = <0x0500000 0x2000000>;
+ };
+
+ partition@2500000 {
+ label = "root";
+ reg = <0x02500000 0xd800000>;
+ label = "ubi";
+ reg = <0x100000 0xfc00000>;
+ };
+};
+

@ -0,0 +1,25 @@
Index: linux-4.4.4/arch/arm/boot/dts/kirkwood-goflexnet.dts
===================================================================
--- linux-4.4.4.orig/arch/arm/boot/dts/kirkwood-goflexnet.dts
+++ linux-4.4.4/arch/arm/boot/dts/kirkwood-goflexnet.dts
@@ -158,18 +158,8 @@
};
partition@100000 {
- label = "uImage";
- reg = <0x0100000 0x400000>;
- };
-
- partition@500000 {
- label = "pogoplug";
- reg = <0x0500000 0x2000000>;
- };
-
- partition@2500000 {
- label = "root";
- reg = <0x02500000 0xd800000>;
+ label = "ubi";
+ reg = <0x0100000 0xfc00000>;
};
};
Loading…
Cancel
Save