fixed autoconf detection for 2.6.33 kernel

SVN-Revision: 21157
v19.07.3_mercusys_ac12_duma
Ralph Hempel 14 years ago
parent 8e143d06bf
commit aa418a50de

@ -1,8 +1,6 @@
Index: lib_ifxos-1.5.12/src/Makefile.am
===================================================================
--- lib_ifxos-1.5.12.orig/src/Makefile.am 2010-01-08 18:12:15.000000000 +0100
+++ lib_ifxos-1.5.12/src/Makefile.am 2010-03-31 18:56:12.000000000 +0200
@@ -639,7 +639,7 @@
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -639,7 +639,7 @@ if KERNEL_2_6
drv_ifxos_OBJS = "$(subst .c,.o,$(filter %.c,$(drv_ifxos_SOURCES)))"
drv_ifxos.ko: $(drv_ifxos_SOURCES)
@ -11,7 +9,7 @@ Index: lib_ifxos-1.5.12/src/Makefile.am
if test ! -e common/ifxos_debug.c ; then \
echo "copy source files (as links only!)"; \
for f in $(filter %.c,$(drv_ifxos_SOURCES)); do \
@@ -647,10 +647,10 @@
@@ -647,10 +647,10 @@ drv_ifxos.ko: $(drv_ifxos_SOURCES)
cp -s $(addprefix @abs_srcdir@/,$$f) $(PWD)/`dirname $$f`/ ; \
done \
fi
@ -26,3 +24,14 @@ Index: lib_ifxos-1.5.12/src/Makefile.am
$(MAKE) ARCH=@KERNEL_ARCH@ -C @KERNEL_BUILD_PATH@ O=@KERNEL_BUILD_PATH@ M=$(PWD) modules
clean-generic:
--- a/configure.in
+++ b/configure.in
@@ -64,7 +64,7 @@ dnl Set kernel build path
AC_ARG_ENABLE(kernelbuild,
AS_HELP_STRING(--enable-kernelbuild=x,Set the target kernel build path (only for kernel 2.6.x)),
[
- if test -e $enableval/include/linux/autoconf.h; then
+ if test -e $enableval/include/{linux,generated}/autoconf.h; then
AC_SUBST([KERNEL_BUILD_PATH],[$enableval])
else
AC_MSG_ERROR([The kernel build directory is not valid or not configured!])

Loading…
Cancel
Save