busybox: move traceroute applets to /bin

busybox currently installs traceroute and traceroute6 into /usr/bin
which prevents their 'full' iputils variants from being installed.
Move those applets to /bin so they can coexist with their iputils
siblings using the same PATH convention already applied for coreutils
and other drop-in 'full' versions.
Refresh existing patch while at it.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
v19.07.3_mercusys_ac12_duma
Daniel Golle 7 years ago committed by John Crispin
parent 343e3d2ba8
commit a63eb74bce

@ -17,8 +17,6 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
2 files changed, 921 insertions(+)
create mode 100644 networking/nslookup_lede.c
diff --git a/Makefile.flags b/Makefile.flags
index 65021de25..096ab7756 100644
--- a/Makefile.flags
+++ b/Makefile.flags
@@ -134,6 +134,12 @@ else
@ -34,9 +32,6 @@ index 65021de25..096ab7756 100644
# libpam may use libpthread, libdl and/or libaudit.
# On some platforms that requires an explicit -lpthread, -ldl, -laudit.
# However, on *other platforms* it fails when some of those flags
diff --git a/networking/nslookup_lede.c b/networking/nslookup_lede.c
new file mode 100644
index 000000000..c6c90ddf3
--- /dev/null
+++ b/networking/nslookup_lede.c
@@ -0,0 +1,915 @@
@ -955,6 +950,3 @@ index 000000000..c6c90ddf3
+
+ return rc;
+}
--
2.11.0

@ -0,0 +1,13 @@
--- a/networking/traceroute.c
+++ b/networking/traceroute.c
@@ -239,8 +239,8 @@
//config: Add option -I to use ICMP ECHO instead of UDP datagrams.
/* Needs socket(AF_INET, SOCK_RAW, IPPROTO_ICMP), therefore BB_SUID_MAYBE: */
-//applet:IF_TRACEROUTE(APPLET(traceroute, BB_DIR_USR_BIN, BB_SUID_MAYBE))
-//applet:IF_TRACEROUTE6(APPLET(traceroute6, BB_DIR_USR_BIN, BB_SUID_MAYBE))
+//applet:IF_TRACEROUTE(APPLET(traceroute, BB_DIR_BIN, BB_SUID_MAYBE))
+//applet:IF_TRACEROUTE6(APPLET(traceroute6, BB_DIR_BIN, BB_SUID_MAYBE))
//kbuild:lib-$(CONFIG_TRACEROUTE) += traceroute.o
//kbuild:lib-$(CONFIG_TRACEROUTE6) += traceroute.o
Loading…
Cancel
Save