refresh patches

SVN-Revision: 25195
v19.07.3_mercusys_ac12_duma
Imre Kaloz 14 years ago
parent d288f855e3
commit a48d1f3a70

@ -7,11 +7,9 @@ Subject: [PATCH 2/2] Fix PR44392
gcc/config/arm/arm.md | 43 +++++++++++++++++++------------------------
1 files changed, 19 insertions(+), 24 deletions(-)
diff --git a/gcc/config/arm/arm.md b/gcc/config/arm/arm.md
index 2096ec6..f0348f3 100644
--- a/gcc/config/arm/arm.md
+++ b/gcc/config/arm/arm.md
@@ -11318,34 +11318,29 @@
@@ -11523,34 +11523,29 @@
(define_expand "bswapsi2"
[(set (match_operand:SI 0 "s_register_operand" "=r")
(bswap:SI (match_operand:SI 1 "s_register_operand" "r")))]
@ -65,6 +63,3 @@ index 2096ec6..f0348f3 100644
"
)
--
1.6.2

@ -1,6 +1,6 @@
--- a/contrib/regression/objs-gcc.sh
+++ b/contrib/regression/objs-gcc.sh
@@ -106,6 +106,10 @@
@@ -106,6 +106,10 @@ if [ $H_REAL_TARGET = $H_REAL_HOST -a $H
then
make all-gdb all-dejagnu all-ld || exit 1
make install-gdb install-dejagnu install-ld || exit 1
@ -13,7 +13,7 @@
make install || exit 1
--- a/libjava/classpath/ltconfig
+++ b/libjava/classpath/ltconfig
@@ -603,7 +603,7 @@
@@ -603,7 +603,7 @@ host_os=`echo $host | sed 's/^\([^-]*\)-
# Transform linux* to *-*-linux-gnu*, to support old configure scripts.
case $host_os in
@ -22,7 +22,7 @@
linux*) host=`echo $host | sed 's/^\(.*-.*-linux\)\(.*\)$/\1-gnu\2/'`
esac
@@ -1251,7 +1251,7 @@
@@ -1251,7 +1251,7 @@ linux-gnuoldld* | linux-gnuaout* | linux
;;
# This must be Linux ELF.

@ -1,6 +1,6 @@
--- a/boehm-gc/include/gc.h
+++ b/boehm-gc/include/gc.h
@@ -503,7 +503,7 @@
@@ -503,7 +503,7 @@ GC_API GC_PTR GC_malloc_atomic_ignore_of
#if defined(__linux__) || defined(__GLIBC__)
# include <features.h>
# if (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 1 || __GLIBC__ > 2) \

@ -1,6 +1,6 @@
--- a/libstdc++-v3/include/c_global/cstdio
+++ b/libstdc++-v3/include/c_global/cstdio
@@ -139,7 +139,7 @@
@@ -139,7 +139,7 @@ _GLIBCXX_BEGIN_NAMESPACE(std)
_GLIBCXX_END_NAMESPACE

@ -1,6 +1,6 @@
--- a/libmudflap/mf-hooks2.c
+++ b/libmudflap/mf-hooks2.c
@@ -421,7 +421,7 @@
@@ -421,7 +421,7 @@ WRAPPER2(void, bzero, void *s, size_t n)
{
TRACE ("%s\n", __PRETTY_FUNCTION__);
MF_VALIDATE_EXTENT(s, n, __MF_CHECK_WRITE, "bzero region");
@ -9,7 +9,7 @@
}
@@ -431,7 +431,7 @@
@@ -431,7 +431,7 @@ WRAPPER2(void, bcopy, const void *src, v
TRACE ("%s\n", __PRETTY_FUNCTION__);
MF_VALIDATE_EXTENT(src, n, __MF_CHECK_READ, "bcopy src");
MF_VALIDATE_EXTENT(dest, n, __MF_CHECK_WRITE, "bcopy dest");
@ -18,7 +18,7 @@
}
@@ -441,7 +441,7 @@
@@ -441,7 +441,7 @@ WRAPPER2(int, bcmp, const void *s1, cons
TRACE ("%s\n", __PRETTY_FUNCTION__);
MF_VALIDATE_EXTENT(s1, n, __MF_CHECK_READ, "bcmp 1st arg");
MF_VALIDATE_EXTENT(s2, n, __MF_CHECK_READ, "bcmp 2nd arg");
@ -27,7 +27,7 @@
}
@@ -450,7 +450,7 @@
@@ -450,7 +450,7 @@ WRAPPER2(char *, index, const char *s, i
size_t n = strlen (s);
TRACE ("%s\n", __PRETTY_FUNCTION__);
MF_VALIDATE_EXTENT(s, CLAMPADD(n, 1), __MF_CHECK_READ, "index region");
@ -36,7 +36,7 @@
}
@@ -459,7 +459,7 @@
@@ -459,7 +459,7 @@ WRAPPER2(char *, rindex, const char *s,
size_t n = strlen (s);
TRACE ("%s\n", __PRETTY_FUNCTION__);
MF_VALIDATE_EXTENT(s, CLAMPADD(n, 1), __MF_CHECK_READ, "rindex region");

@ -1,6 +1,6 @@
--- a/configure
+++ b/configure
@@ -2688,6 +2688,9 @@ case "${target}" in
@@ -3730,6 +3730,9 @@ case "${target}" in
ip2k-*-*)
noconfigdirs="$noconfigdirs target-libiberty target-libstdc++-v3 ${libgcj}"
;;
@ -9313,7 +9313,7 @@
+#define FATAL_EXIT_CODE 33
--- a/gcc/config.gcc
+++ b/gcc/config.gcc
@@ -2314,6 +2314,34 @@ spu-*-elf*)
@@ -2497,6 +2497,34 @@ spu-*-elf*)
c_target_objs="${c_target_objs} spu-c.o"
cxx_target_objs="${cxx_target_objs} spu-c.o"
;;
@ -9347,10 +9347,10 @@
+ ;;
v850e1-*-*)
target_cpu_default="TARGET_CPU_v850e1"
tm_file="dbxelf.h elfos.h svr4.h v850/v850.h"
tm_file="dbxelf.h elfos.h svr4.h newlib-stdint.h v850/v850.h"
--- a/libgcc/config.host
+++ b/libgcc/config.host
@@ -551,6 +551,15 @@ sparc64-*-netbsd*)
@@ -560,6 +560,15 @@ sparc64-*-netbsd*)
;;
spu-*-elf*)
;;

@ -11,7 +11,7 @@
--- a/gcc/config/arm/t-linux
+++ b/gcc/config/arm/t-linux
@@ -4,7 +4,10 @@
@@ -23,7 +23,10 @@ TARGET_LIBGCC2_CFLAGS = -fomit-frame-poi
LIB1ASMSRC = arm/lib1funcs.asm
LIB1ASMFUNCS = _udivsi3 _divsi3 _umodsi3 _modsi3 _dvmd_lnx _clzsi2 _clzdi2 \

@ -1,6 +1,6 @@
--- a/libgcc/Makefile.in
+++ b/libgcc/Makefile.in
@@ -729,11 +729,12 @@ $(libgcov-objects): %$(objext): $(gcc_sr
@@ -746,11 +746,12 @@ $(libgcov-objects): %$(objext): $(gcc_sr
# Static libraries.
libgcc.a: $(libgcc-objects)
@ -14,7 +14,7 @@
-rm -f $@
objects="$(objects)"; \
@@ -755,7 +756,7 @@ libgcc_s$(SHLIB_EXT): libunwind$(SHLIB_E
@@ -772,7 +773,7 @@ libgcc_s$(SHLIB_EXT): libunwind$(SHLIB_E
endif
ifeq ($(enable_shared),yes)
@ -23,7 +23,7 @@
ifneq ($(LIBUNWIND),)
all: libunwind$(SHLIB_EXT)
endif
@@ -928,6 +929,10 @@ install-shared:
@@ -945,6 +946,10 @@ install-shared:
chmod 644 $(DESTDIR)$(inst_libdir)/libgcc_eh.a
$(RANLIB) $(DESTDIR)$(inst_libdir)/libgcc_eh.a

@ -19,7 +19,7 @@
--- a/gcc/c-opts.c
+++ b/gcc/c-opts.c
@@ -105,6 +105,9 @@
@@ -106,6 +106,9 @@ static size_t deferred_count;
/* Number of deferred options scanned for -include. */
static size_t include_cursor;
@ -29,8 +29,8 @@
static void set_Wimplicit (int);
static void handle_OPT_d (const char *);
static void set_std_cxx98 (int);
@@ -454,6 +457,9 @@
enable_warning_as_error ("implicit-function-declaration", value, CL_C | CL_ObjC);
@@ -472,6 +475,9 @@ c_common_handle_option (size_t scode, co
enable_warning_as_error ("implicit-function-declaration", value, CL_C | CL_ObjC);
break;
+ case OPT_Werror_maybe_reset:
@ -39,7 +39,7 @@
case OPT_Wformat:
set_Wformat (value);
break;
@@ -690,6 +701,12 @@
@@ -704,6 +710,12 @@ c_common_handle_option (size_t scode, co
flag_exceptions = value;
break;
@ -52,7 +52,7 @@
case OPT_fimplement_inlines:
flag_implement_inlines = value;
break;
@@ -1209,6 +1226,47 @@
@@ -1240,6 +1252,47 @@ c_common_init (void)
return false;
}
@ -102,7 +102,7 @@
--- a/gcc/c.opt
+++ b/gcc/c.opt
@@ -215,6 +215,10 @@
@@ -219,6 +219,10 @@ Werror-implicit-function-declaration
C ObjC RejectNegative Warning
This switch is deprecated; use -Werror=implicit-function-declaration instead
@ -113,7 +113,7 @@
Wfloat-equal
C ObjC C++ ObjC++ Var(warn_float_equal) Warning
Warn if testing floating point numbers for equality
@@ -609,6 +613,9 @@
@@ -637,6 +641,9 @@ C++ ObjC++ Optimization
fhonor-std
C++ ObjC++
@ -125,7 +125,7 @@
Assume normal C execution environment
--- a/gcc/common.opt
+++ b/gcc/common.opt
@@ -102,6 +102,10 @@
@@ -105,6 +105,10 @@ Werror=
Common Joined
Treat specified warning as error
@ -134,9 +134,9 @@
+If environment variable GCC_NO_WERROR is set, act as -Wno-error
+
Wextra
Common Warning
Common Var(extra_warnings) Warning
Print extra (possibly unwanted) warnings
@@ -573,6 +577,9 @@
@@ -625,6 +629,9 @@ fguess-branch-probability
Common Report Var(flag_guess_branch_prob) Optimization
Enable guessing of branch probabilities
@ -148,7 +148,7 @@
; On SVR4 targets, it also controls whether or not to emit a
--- a/gcc/opts.c
+++ b/gcc/opts.c
@@ -896,8 +896,6 @@
@@ -897,8 +897,6 @@ decode_options (unsigned int argc, const
flag_schedule_insns_after_reload = opt2;
#endif
flag_regmove = opt2;
@ -157,7 +157,7 @@
flag_reorder_blocks = opt2;
flag_reorder_functions = opt2;
flag_tree_vrp = opt2;
@@ -922,6 +919,8 @@
@@ -919,6 +917,8 @@ decode_options (unsigned int argc, const
/* -O3 optimizations. */
opt3 = (optimize >= 3);
@ -166,7 +166,7 @@
flag_predictive_commoning = opt3;
flag_inline_functions = opt3;
flag_unswitch_loops = opt3;
@@ -1601,6 +1601,17 @@
@@ -1647,6 +1647,17 @@ common_handle_option (size_t scode, cons
enable_warning_as_error (arg, value, lang_mask);
break;
@ -182,11 +182,11 @@
+ break;
+
case OPT_Wlarger_than_:
/* This form corresponds to -Wlarger-than-.
Kept for backward compatibility.
/* This form corresponds to -Wlarger-than-.
Kept for backward compatibility.
--- a/gcc/doc/cppopts.texi
+++ b/gcc/doc/cppopts.texi
@@ -164,6 +164,11 @@
@@ -164,6 +164,11 @@ in older programs. This warning is on b
Make all warnings into hard errors. Source code which triggers warnings
will be rejected.
@ -200,7 +200,7 @@
Issue warnings for code in system headers. These are normally unhelpful
--- a/gcc/doc/invoke.texi
+++ b/gcc/doc/invoke.texi
@@ -234,7 +234,7 @@
@@ -235,7 +235,7 @@ Objective-C and Objective-C++ Dialects}.
-Wconversion -Wcoverage-mismatch -Wno-deprecated @gol
-Wno-deprecated-declarations -Wdisabled-optimization @gol
-Wno-div-by-zero -Wdouble-promotion -Wempty-body -Wenum-compare @gol
@ -209,7 +209,7 @@
-Wfatal-errors -Wfloat-equal -Wformat -Wformat=2 @gol
-Wno-format-contains-nul -Wno-format-extra-args -Wformat-nonliteral @gol
-Wformat-security -Wformat-y2k @gol
@@ -4161,6 +4161,22 @@
@@ -4358,6 +4358,22 @@ This option is only supported for C and
@option{-Wall} and by @option{-pedantic}, which can be disabled with
@option{-Wno-pointer-sign}.
@ -232,7 +232,7 @@
@item -Wstack-protector
@opindex Wstack-protector
@opindex Wno-stack-protector
@@ -5699,7 +5715,7 @@
@@ -6110,7 +6126,7 @@ so, the first branch is redirected to ei
second branch or a point immediately following it, depending on whether
the condition is known to be true or false.
@ -243,7 +243,7 @@
@opindex fsplit-wide-types
--- a/gcc/java/jvspec.c
+++ b/gcc/java/jvspec.c
@@ -670,6 +670,7 @@
@@ -667,6 +667,7 @@ lang_specific_pre_link (void)
class name. Append dummy `.c' that can be stripped by set_input so %b
is correct. */
set_input (concat (main_class_name, "main.c", NULL));

@ -1,6 +1,6 @@
--- gcc-4.4.0/gcc/config/arm/arm-protos.h 2009-02-20 16:20:38.000000000 +0100
+++ gcc-4.4.0.new/gcc/config/arm/arm-protos.h 2009-04-22 16:00:58.000000000 +0200
@@ -43,10 +43,10 @@
--- a/gcc/config/arm/arm-protos.h
+++ b/gcc/config/arm/arm-protos.h
@@ -43,10 +43,10 @@ extern unsigned int arm_dbx_register_num
extern void arm_output_fn_unwind (FILE *, bool);
@ -11,4 +11,4 @@
+#ifdef RTX_CODE
extern int arm_split_constant (RTX_CODE, enum machine_mode, rtx,
HOST_WIDE_INT, rtx, rtx, int);
extern RTX_CODE arm_canonicalize_comparison (RTX_CODE, enum machine_mode,
extern RTX_CODE arm_canonicalize_comparison (RTX_CODE, rtx *, rtx *);

@ -1,8 +1,6 @@
Index: gcc-4.4.2/gcc/config.gcc
===================================================================
--- gcc-4.4.2.orig/gcc/config.gcc 2009-10-21 16:19:39.000000000 +0200
+++ gcc-4.4.2/gcc/config.gcc 2009-10-21 16:19:40.000000000 +0200
@@ -1506,6 +1506,7 @@
--- a/gcc/config.gcc
+++ b/gcc/config.gcc
@@ -1662,6 +1662,7 @@ m68k-*-linux*) # Motorola m68k's runnin
if test x$sjlj != x1; then
tmake_file="$tmake_file m68k/t-slibgcc-elf-ver"
fi

Loading…
Cancel
Save