kernel-headers: Fix patch application for kernel-headers and a patch that fixes exposure of a kernel-only data type (umode_t) to application layer which causes compile errors in ext2_fs.h using programs.

SVN-Revision: 31697
v19.07.3_mercusys_ac12_duma
Daniel Dickinson 12 years ago
parent 482b99a660
commit 9cc9e8b608

@ -22,7 +22,7 @@ HOST_BUILD_DIR:=$(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
PKG_MD5SUM:=$(LINUX_KERNEL_MD5SUM)
LINUX_DIR := $(HOST_BUILD_DIR)
FILES_DIR :=
PATCH_DIR := ./patches$(if $(wildcard ./patches-$(KERNEL_PATCHVER)),-$(KERNEL_PATCHVER))
PATCH_DIR := ./patches$(if $(wildcard ./patches-$(LINUX_VERSION)),-$(LINUX_VERSION))
include $(INCLUDE_DIR)/toolchain-build.mk
include $(INCLUDE_DIR)/kernel-defaults.mk

@ -0,0 +1,24 @@
Index: linux-3.3.5/include/linux/ext2_fs.h
===================================================================
--- linux-3.3.5.orig/include/linux/ext2_fs.h 2012-05-12 05:49:43.555033434 -0400
+++ linux-3.3.5/include/linux/ext2_fs.h 2012-05-12 05:51:01.895033564 -0400
@@ -209,7 +209,11 @@
#define EXT2_OTHER_FLMASK (EXT2_NODUMP_FL | EXT2_NOATIME_FL)
/* Mask out flags that are inappropriate for the given type of inode. */
+#ifdef __KERNEL__
static inline __u32 ext2_mask_flags(umode_t mode, __u32 flags)
+#else
+static inline __u32 ext2_mask_flags(unsigned short mode, __u32 flags)
+#endif
{
if (S_ISDIR(mode))
return flags;
@@ -219,6 +223,7 @@
return flags & EXT2_OTHER_FLMASK;
}
+
/*
* ioctl commands
*/
Loading…
Cancel
Save