mkimage: upgrade to version 2013.01.01

SVN-Revision: 35905
v19.07.3_mercusys_ac12_duma
Luka Perkov 11 years ago
parent e259ecad7e
commit 9c8ee9c264

@ -1,5 +1,5 @@
#
# Copyright (C) 2006-2012 OpenWrt.org
# Copyright (C) 2006-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mkimage
PKG_VERSION:=2012.04.01
PKG_VERSION:=2013.01.01
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
PKG_MD5SUM:=192bb231082d9159fb6e16de3039b6b2
PKG_MD5SUM:=73939f78606f89a1775c7e9acb2ca617
PKG_CAT:=bzcat
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
@ -22,12 +22,12 @@ define Host/Prepare
$(Host/Prepare/Default)
rm -f \
$(HOST_BUILD_DIR)/include/errno.h \
$(HOST_BUILD_DIR)/include/malloc.h
$(HOST_BUILD_DIR)/include/malloc.h \
$(HOST_BUILD_DIR)/tools/.depend
touch $(HOST_BUILD_DIR)/include/config.h
endef
define Host/Compile
rm -f $(HOST_BUILD_DIR)/tools/.depend
touch $(HOST_BUILD_DIR)/include/config.h
$(MAKE) -C $(HOST_BUILD_DIR) BUILD_DIR= BIN_FILES-y="mkimage" HOSTLDFLAGS="$(HOST_STATIC_LINKING)" tools
endef

@ -1,6 +1,6 @@
--- a/include/image.h
+++ b/include/image.h
@@ -50,6 +50,10 @@
@@ -51,6 +51,10 @@
#endif /* USE_HOSTCC */

@ -1,7 +1,6 @@
diff -Nur u-boot-2012.04.01.orig/tools/mkimage.c u-boot-2012.04.01/tools/mkimage.c
--- u-boot-2012.04.01.orig/tools/mkimage.c Wed Apr 25 15:22:50 2012
+++ u-boot-2012.04.01/tools/mkimage.c Wed Mar 6 17:09:29 2013
@@ -449,6 +449,7 @@
--- a/tools/mkimage.c
+++ b/tools/mkimage.c
@@ -464,6 +464,7 @@
#if defined(_POSIX_SYNCHRONIZED_IO) && \
!defined(__sun__) && \
!defined(__FreeBSD__) && \
@ -9,7 +8,7 @@ diff -Nur u-boot-2012.04.01.orig/tools/mkimage.c u-boot-2012.04.01/tools/mkimage
!defined(__APPLE__)
(void) fdatasync (ifd);
#else
@@ -492,6 +493,7 @@
@@ -507,6 +508,7 @@
#if defined(_POSIX_SYNCHRONIZED_IO) && \
!defined(__sun__) && \
!defined(__FreeBSD__) && \

@ -1,14 +1,14 @@
--- a/tools/mkimage.c
+++ b/tools/mkimage.c
@@ -37,6 +37,7 @@ struct mkimage_params params = {
@@ -37,6 +37,7 @@
.arch = IH_ARCH_PPC,
.type = IH_TYPE_KERNEL,
.comp = IH_COMP_GZIP,
+ .magic = IH_MAGIC,
.dtc = MKIMAGE_DEFAULT_DTC_OPTIONS,
.imagename = "",
};
@@ -186,6 +187,16 @@ main (int argc, char **argv)
.imagename2 = "",
@@ -189,6 +190,16 @@
genimg_get_comp_id (*++argv)) < 0)
usage ();
goto NXTARG;
@ -25,7 +25,7 @@
case 'D':
if (--argc <= 0)
usage ();
@@ -596,12 +607,13 @@ usage ()
@@ -613,12 +624,13 @@
fprintf (stderr, "Usage: %s -l image\n"
" -l ==> list image header information\n",
params.cmdname);
@ -42,7 +42,7 @@
" -n ==> set image name to 'name'\n"
--- a/tools/mkimage.h
+++ b/tools/mkimage.h
@@ -65,6 +65,7 @@ struct mkimage_params {
@@ -65,6 +65,7 @@
int arch;
int type;
int comp;
@ -52,7 +52,7 @@
unsigned int ep;
--- a/tools/default_image.c
+++ b/tools/default_image.c
@@ -111,7 +111,7 @@ static void image_set_header(void *ptr,
@@ -111,7 +111,7 @@
sbuf->st_size - sizeof(image_header_t));
/* Build new header */

@ -1,6 +1,6 @@
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -159,9 +159,9 @@ NOPEDOBJS := $(addprefix $(obj),$(NOPED_
@@ -162,9 +162,9 @@
# Use native tools and options
# Define __KERNEL_STRICT_NAMES to prevent typedef overlaps
#

Loading…
Cancel
Save