upgrade ppc44x to 2.6.27

SVN-Revision: 13266
v19.07.3_mercusys_ac12_duma
Imre Kaloz 16 years ago
parent 22a7b1b3d3
commit 942025fa14

@ -11,7 +11,7 @@ BOARD:=ppc44x
BOARDNAME:=AMCC/IBM PPC44x
FEATURES:=squashfs
LINUX_VERSION:=2.6.26.8
LINUX_VERSION:=2.6.27.6
LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk

@ -148,6 +148,7 @@ CONFIG_PTE_64BIT=y
# CONFIG_RAINIER is not set
CONFIG_RESOURCES_64BIT=y
CONFIG_RWSEM_XCHGADD_ALGORITHM=y
# CONFIG_SAM440EP is not set
CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER=y
# CONFIG_SECCOMP is not set
# CONFIG_SERIAL_8250_DETECT_IRQ is not set
@ -169,6 +170,7 @@ CONFIG_TASK_SIZE=0x80000000
# CONFIG_UNUSED_SYMBOLS is not set
# CONFIG_USER_NS is not set
# CONFIG_VIA_RHINE is not set
# CONFIG_XILINX_VIRTEX440_GENERIC_BOARD is not set
CONFIG_WANT_EARLY_SERIAL=y
# CONFIG_WARP is not set
# CONFIG_WINDFARM is not set

@ -1,37 +1,24 @@
--- a/arch/powerpc/boot/dts/taishan.dts
+++ b/arch/powerpc/boot/dts/taishan.dts
@@ -185,6 +185,34 @@
interrupt-parent = <&UIC1>;
/* TODO: Add other EBC devices */
+ nor_flash@0,0 {
+ compatible = "cfi-flash";
+ bank-width = <4>;
+ device-width = <2>;
+ reg = <0 000000 4000000>;
+ #address-cells = <1>;
+ #size-cells = <1>;
+ partition@0 {
+ label = "kernel";
+ reg = <0 200000>;
+ };
@@ -195,15 +195,15 @@
#size-cells = <1>;
partition@0 {
label = "kernel";
- reg = <0x0 0x180000>;
+ reg = <0x0 0x200000>;
};
- partition@180000 {
+ partition@200000 {
+ label = "rootfs";
+ reg = <200000 3c00000>;
+ };
label = "root";
- reg = <0x180000 0x200000>;
+ reg = <0x200000 0x3c00000>;
};
- partition@380000 {
- label = "user";
- reg = <0x380000 0x3bc0000>;
+ partition@3e00000 {
+ label = "diagnostics";
+ reg = <3e00000 140000>;
+ };
+ partition@3f40000 {
+ label = "env";
+ reg = <3f40000 80000>;
+ };
+ partition@3fc0000 {
+ label = "u-boot";
+ reg = <3fc0000 40000>;
+ };
+ };
};
+ reg = <0x3e00000 0x140000>;
};
partition@3f40000 {
label = "env";

Loading…
Cancel
Save