gettext-full: refresh patches

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 37184
v19.07.3_mercusys_ac12_duma
Felix Fietkau 11 years ago
parent 0c10f3911d
commit 9360b15176

@ -24,7 +24,7 @@
$(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
--- a/gettext-runtime/intl/Makefile.in
+++ b/gettext-runtime/intl/Makefile.in
@@ -19,7 +19,7 @@
@@ -17,7 +17,7 @@
PACKAGE = @PACKAGE@
VERSION = @VERSION@

@ -1,8 +1,8 @@
--- a/gettext-runtime/Makefile.in
+++ b/gettext-runtime/Makefile.in
@@ -208,7 +208,7 @@ AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGE
ETAGS = etags
@@ -251,7 +251,7 @@ ETAGS = etags
CTAGS = ctags
CSCOPE = cscope
DIST_SUBDIRS = doc intl intl-java intl-csharp gnulib-lib libasprintf \
- src po man m4 tests
+ src po man m4
@ -11,7 +11,7 @@
top_distdir = $(distdir)
--- a/gettext-tools/Makefile.in
+++ b/gettext-tools/Makefile.in
@@ -1248,7 +1248,7 @@ top_builddir = @top_builddir@
@@ -1503,7 +1503,7 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../m4 -I gnulib-m4 -I libgrep/gnulib-m4 -I libgettextpo/gnulib-m4

@ -1,11 +1,11 @@
--- a/gettext-tools/libgettextpo/error.h
+++ b/gettext-tools/libgettextpo/error.h
@@ -49,7 +49,7 @@ extern void error_at_line (int __status,
@@ -58,7 +58,7 @@ extern void error_at_line (int __status,
/* If NULL, error will flush stdout, then print on stderr the program
name, a colon and a space. Otherwise, error will call this
function without parameters instead. */
-extern DLL_VARIABLE void (*error_print_progname) (void);
+void (*error_print_progname) (void);
/* This variable is incremented each time `error' is called. */
/* This variable is incremented each time 'error' is called. */
extern DLL_VARIABLE unsigned int error_message_count;

@ -1,6 +1,6 @@
--- a/gettext-runtime/intl/intl-compat.c
+++ b/gettext-runtime/intl/intl-compat.c
@@ -131,3 +131,7 @@ bind_textdomain_codeset (const char *dom
@@ -129,3 +129,7 @@ bind_textdomain_codeset (const char *dom
{
return libintl_bind_textdomain_codeset (domainname, codeset);
}

@ -1,6 +1,6 @@
--- a/gettext-runtime/intl/localename.c
+++ b/gettext-runtime/intl/localename.c
@@ -2780,7 +2780,7 @@ gl_locale_name_posix (int category, cons
@@ -2679,7 +2679,7 @@ gl_locale_name_posix (int category, cons
{
/* Use the POSIX methods of looking to 'LC_ALL', 'LC_xxx', and 'LANG'.
On some systems this can be done by the 'setlocale' function itself. */

Loading…
Cancel
Save