bcm53xx: refresh kernel patches

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 45426
v19.07.3_mercusys_ac12_duma
Felix Fietkau 9 years ago
parent bdb6c313de
commit 923bef1678

@ -234,7 +234,7 @@
spi_nor_unlock_and_unprep(nor, SPI_NOR_OPS_ERASE);
instr->state = MTD_ERASE_DONE;
@@ -341,11 +380,6 @@ static int spi_nor_lock(struct mtd_info
@@ -341,11 +380,6 @@ static int spi_nor_lock(struct mtd_info
if (ret)
return ret;
@ -333,7 +333,7 @@
/* GigaDevice */
{ "gd25q32", INFO(0xc84016, 0, 64 * 1024, 64, SECT_4K) },
{ "gd25q64", INFO(0xc84017, 0, 64 * 1024, 128, SECT_4K) },
@@ -532,6 +560,7 @@ static const struct spi_device_id spi_no
@@ -536,6 +564,7 @@ static const struct spi_device_id spi_no
{ "mx66l1g55g", INFO(0xc2261b, 0, 64 * 1024, 2048, SPI_NOR_QUAD_READ) },
/* Micron */
@ -341,7 +341,7 @@
{ "n25q064", INFO(0x20ba17, 0, 64 * 1024, 128, 0) },
{ "n25q128a11", INFO(0x20bb18, 0, 64 * 1024, 256, 0) },
{ "n25q128a13", INFO(0x20ba18, 0, 64 * 1024, 256, 0) },
@@ -556,6 +585,7 @@ static const struct spi_device_id spi_no
@@ -560,6 +589,7 @@ static const struct spi_device_id spi_no
{ "s70fl01gs", INFO(0x010221, 0x4d00, 256 * 1024, 256, 0) },
{ "s25sl12800", INFO(0x012018, 0x0300, 256 * 1024, 64, 0) },
{ "s25sl12801", INFO(0x012018, 0x0301, 64 * 1024, 256, 0) },
@ -349,7 +349,7 @@
{ "s25fl129p0", INFO(0x012018, 0x4d00, 256 * 1024, 64, 0) },
{ "s25fl129p1", INFO(0x012018, 0x4d01, 64 * 1024, 256, 0) },
{ "s25sl004a", INFO(0x010212, 0, 64 * 1024, 8, 0) },
@@ -577,6 +607,7 @@ static const struct spi_device_id spi_no
@@ -581,6 +611,7 @@ static const struct spi_device_id spi_no
{ "sst25wf010", INFO(0xbf2502, 0, 64 * 1024, 2, SECT_4K | SST_WRITE) },
{ "sst25wf020", INFO(0xbf2503, 0, 64 * 1024, 4, SECT_4K | SST_WRITE) },
{ "sst25wf040", INFO(0xbf2504, 0, 64 * 1024, 8, SECT_4K | SST_WRITE) },
@ -357,7 +357,7 @@
/* ST Microelectronics -- newer production may have feature updates */
{ "m25p05", INFO(0x202010, 0, 32 * 1024, 2, 0) },
@@ -588,7 +619,6 @@ static const struct spi_device_id spi_no
@@ -592,7 +623,6 @@ static const struct spi_device_id spi_no
{ "m25p32", INFO(0x202016, 0, 64 * 1024, 64, 0) },
{ "m25p64", INFO(0x202017, 0, 64 * 1024, 128, 0) },
{ "m25p128", INFO(0x202018, 0, 256 * 1024, 64, 0) },
@ -365,7 +365,7 @@
{ "m25p05-nonjedec", INFO(0, 0, 32 * 1024, 2, 0) },
{ "m25p10-nonjedec", INFO(0, 0, 32 * 1024, 4, 0) },
@@ -644,32 +674,24 @@ static const struct spi_device_id spi_no
@@ -648,32 +678,24 @@ static const struct spi_device_id spi_no
static const struct spi_device_id *spi_nor_read_id(struct spi_nor *nor)
{
int tmp;
@ -404,7 +404,7 @@
return ERR_PTR(-ENODEV);
}
@@ -704,11 +726,6 @@ static int sst_write(struct mtd_info *mt
@@ -708,11 +730,6 @@ static int sst_write(struct mtd_info *mt
if (ret)
return ret;
@ -416,7 +416,7 @@
write_enable(nor);
nor->sst_write_second = false;
@@ -720,7 +737,7 @@ static int sst_write(struct mtd_info *mt
@@ -724,7 +741,7 @@ static int sst_write(struct mtd_info *mt
/* write one byte. */
nor->write(nor, to, 1, retlen, buf);
@ -425,7 +425,7 @@
if (ret)
goto time_out;
}
@@ -732,7 +749,7 @@ static int sst_write(struct mtd_info *mt
@@ -736,7 +753,7 @@ static int sst_write(struct mtd_info *mt
/* write two bytes. */
nor->write(nor, to, 2, retlen, buf + actual);
@ -434,7 +434,7 @@
if (ret)
goto time_out;
to += 2;
@@ -741,7 +758,7 @@ static int sst_write(struct mtd_info *mt
@@ -745,7 +762,7 @@ static int sst_write(struct mtd_info *mt
nor->sst_write_second = false;
write_disable(nor);
@ -443,7 +443,7 @@
if (ret)
goto time_out;
@@ -752,7 +769,7 @@ static int sst_write(struct mtd_info *mt
@@ -756,7 +773,7 @@ static int sst_write(struct mtd_info *mt
nor->program_opcode = SPINOR_OP_BP;
nor->write(nor, to, 1, retlen, buf + actual);
@ -452,7 +452,7 @@
if (ret)
goto time_out;
write_disable(nor);
@@ -780,11 +797,6 @@ static int spi_nor_write(struct mtd_info
@@ -784,11 +801,6 @@ static int spi_nor_write(struct mtd_info
if (ret)
return ret;
@ -464,7 +464,7 @@
write_enable(nor);
page_offset = to & (nor->page_size - 1);
@@ -803,16 +815,20 @@ static int spi_nor_write(struct mtd_info
@@ -807,16 +819,20 @@ static int spi_nor_write(struct mtd_info
if (page_size > nor->page_size)
page_size = nor->page_size;
@ -487,7 +487,7 @@
}
static int macronix_quad_enable(struct spi_nor *nor)
@@ -825,7 +841,7 @@ static int macronix_quad_enable(struct s
@@ -829,7 +845,7 @@ static int macronix_quad_enable(struct s
nor->cmd_buf[0] = val | SR_QUAD_EN_MX;
nor->write_reg(nor, SPINOR_OP_WRSR, nor->cmd_buf, 1, 0);
@ -496,7 +496,7 @@
return 1;
ret = read_sr(nor);
@@ -875,11 +891,11 @@ static int spansion_quad_enable(struct s
@@ -879,11 +895,11 @@ static int spansion_quad_enable(struct s
return 0;
}
@ -510,7 +510,7 @@
case CFI_MFR_MACRONIX:
status = macronix_quad_enable(nor);
if (status) {
@@ -905,11 +921,6 @@ static int spi_nor_check(struct spi_nor
@@ -909,11 +925,6 @@ static int spi_nor_check(struct spi_nor
return -EINVAL;
}
@ -522,7 +522,7 @@
return 0;
}
@@ -927,16 +938,24 @@ int spi_nor_scan(struct spi_nor *nor, co
@@ -931,16 +942,24 @@ int spi_nor_scan(struct spi_nor *nor, co
if (ret)
return ret;
@ -551,7 +551,7 @@
if (IS_ERR(jid)) {
return PTR_ERR(jid);
} else if (jid != id) {
@@ -961,9 +980,9 @@ int spi_nor_scan(struct spi_nor *nor, co
@@ -965,9 +984,9 @@ int spi_nor_scan(struct spi_nor *nor, co
* up with the software protection bits set
*/
@ -564,7 +564,7 @@
write_enable(nor);
write_sr(nor, 0);
}
@@ -978,7 +997,7 @@ int spi_nor_scan(struct spi_nor *nor, co
@@ -982,7 +1001,7 @@ int spi_nor_scan(struct spi_nor *nor, co
mtd->_read = spi_nor_read;
/* nor protection support for STmicro chips */
@ -573,7 +573,7 @@
mtd->_lock = spi_nor_lock;
mtd->_unlock = spi_nor_unlock;
}
@@ -989,9 +1008,8 @@ int spi_nor_scan(struct spi_nor *nor, co
@@ -993,9 +1012,8 @@ int spi_nor_scan(struct spi_nor *nor, co
else
mtd->_write = spi_nor_write;
@ -585,7 +585,7 @@
#ifdef CONFIG_MTD_SPI_NOR_USE_4K_SECTORS
/* prefer "small sector" erase if possible */
@@ -1032,7 +1050,7 @@ int spi_nor_scan(struct spi_nor *nor, co
@@ -1036,7 +1054,7 @@ int spi_nor_scan(struct spi_nor *nor, co
/* Quad/Dual-read mode takes precedence over fast/normal */
if (mode == SPI_NOR_QUAD && info->flags & SPI_NOR_QUAD_READ) {
@ -594,7 +594,7 @@
if (ret) {
dev_err(dev, "quad mode not supported\n");
return ret;
@@ -1068,7 +1086,7 @@ int spi_nor_scan(struct spi_nor *nor, co
@@ -1072,7 +1090,7 @@ int spi_nor_scan(struct spi_nor *nor, co
else if (mtd->size > 0x1000000) {
/* enable 4-byte addressing if the device exceeds 16MiB */
nor->addr_width = 4;
@ -603,7 +603,7 @@
/* Dedicated 4-byte command set */
switch (nor->flash_read) {
case SPI_NOR_QUAD:
@@ -1089,7 +1107,7 @@ int spi_nor_scan(struct spi_nor *nor, co
@@ -1093,7 +1111,7 @@ int spi_nor_scan(struct spi_nor *nor, co
nor->erase_opcode = SPINOR_OP_SE_4B;
mtd->erasesize = info->sector_size;
} else

@ -8,7 +8,7 @@
/* Intel/Numonyx -- xxxs33b */
{ "160s33b", INFO(0x898911, 0, 64 * 1024, 32, 0) },
@@ -560,14 +561,14 @@ static const struct spi_device_id spi_no
@@ -564,14 +565,14 @@ static const struct spi_device_id spi_no
{ "mx66l1g55g", INFO(0xc2261b, 0, 64 * 1024, 2048, SPI_NOR_QUAD_READ) },
/* Micron */
@ -31,7 +31,7 @@
/* PMC */
{ "pm25lv512", INFO(0, 0, 32 * 1024, 2, SECT_4K_PMC) },
@@ -891,6 +892,45 @@ static int spansion_quad_enable(struct s
@@ -895,6 +896,45 @@ static int spansion_quad_enable(struct s
return 0;
}
@ -77,7 +77,7 @@
static int set_quad_mode(struct spi_nor *nor, struct flash_info *info)
{
int status;
@@ -903,6 +943,13 @@ static int set_quad_mode(struct spi_nor
@@ -907,6 +947,13 @@ static int set_quad_mode(struct spi_nor
return -EINVAL;
}
return status;

@ -12,8 +12,6 @@ Signed-off-by: Arnd Bergmann <arnd@arndb.de>
arch/arm/Kconfig.debug | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/arm/Kconfig.debug b/arch/arm/Kconfig.debug
index 1c4889d..a528843 100644
--- a/arch/arm/Kconfig.debug
+++ b/arch/arm/Kconfig.debug
@@ -113,7 +113,7 @@ choice
@ -34,6 +32,3 @@ index 1c4889d..a528843 100644
default 2
config DEBUG_UART_8250_WORD
--
1.8.4.5

@ -14,8 +14,6 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
2 files changed, 61 insertions(+)
create mode 100644 arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 91bd5bd..ff4a5ae 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -56,6 +56,7 @@ dtb-$(CONFIG_ARCH_AXXIA) += axm5516-amar
@ -26,9 +24,6 @@ index 91bd5bd..ff4a5ae 100644
bcm4708-netgear-r6250.dtb \
bcm4708-netgear-r6300-v2.dtb \
bcm47081-asus-rt-n18u.dtb \
diff --git a/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts b/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
new file mode 100644
index 0000000..946c728
--- /dev/null
+++ b/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
@@ -0,0 +1,60 @@
@ -92,6 +87,3 @@ index 0000000..946c728
+ };
+ };
+};
--
1.8.4.5

@ -19,8 +19,6 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts | 1 -
5 files changed, 5 deletions(-)
diff --git a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
index 5fc0fae..13d51a9 100644
--- a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
+++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
@@ -27,7 +27,6 @@
@ -31,8 +29,6 @@ index 5fc0fae..13d51a9 100644
restart {
label = "Reset";
diff --git a/arch/arm/boot/dts/bcm4708-netgear-r6250.dts b/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
index 4ed7de1..f18c9d9 100644
--- a/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
@@ -71,7 +71,6 @@
@ -43,8 +39,6 @@ index 4ed7de1..f18c9d9 100644
wps {
label = "WPS";
diff --git a/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts b/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
index 12fc2a01..3991042 100644
--- a/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
@@ -61,7 +61,6 @@
@ -55,8 +49,6 @@ index 12fc2a01..3991042 100644
wps {
label = "WPS";
diff --git a/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
index fb76378..0ee85ea 100644
--- a/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
+++ b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
@@ -61,7 +61,6 @@
@ -67,8 +59,6 @@ index fb76378..0ee85ea 100644
restart {
label = "Reset";
diff --git a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
index bbb414f..e23dbbf 100644
--- a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
+++ b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
@@ -27,7 +27,6 @@
@ -79,6 +69,3 @@ index bbb414f..e23dbbf 100644
aoss {
label = "AOSS";
--
1.8.4.5

@ -13,8 +13,6 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts | 67 ++++++++++++++++++++++
2 files changed, 134 insertions(+)
diff --git a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
index 13d51a9..b359c1e 100644
--- a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
+++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
@@ -23,6 +23,73 @@
@ -91,8 +89,6 @@ index 13d51a9..b359c1e 100644
gpio-keys {
compatible = "gpio-keys";
#address-cells = <1>;
diff --git a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
index e23dbbf..db9131e 100644
--- a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
+++ b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
@@ -23,6 +23,73 @@
@ -169,6 +165,3 @@ index e23dbbf..db9131e 100644
gpio-keys {
compatible = "gpio-keys";
#address-cells = <1>;
--
1.8.4.5

@ -14,8 +14,6 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
2 files changed, 39 insertions(+), 1 deletion(-)
create mode 100644 arch/arm/boot/dts/bcm47081-buffalo-wzr-900dhp.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index ff4a5ae..0de664e 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -60,7 +60,8 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
@ -28,9 +26,6 @@ index ff4a5ae..0de664e 100644
dtb-$(CONFIG_ARCH_BCM_63XX) += bcm963138dvt.dtb
dtb-$(CONFIG_ARCH_BCM_MOBILE) += bcm28155-ap.dtb \
bcm21664-garnet.dtb
diff --git a/arch/arm/boot/dts/bcm47081-buffalo-wzr-900dhp.dts b/arch/arm/boot/dts/bcm47081-buffalo-wzr-900dhp.dts
new file mode 100644
index 0000000..7d6868a
--- /dev/null
+++ b/arch/arm/boot/dts/bcm47081-buffalo-wzr-900dhp.dts
@@ -0,0 +1,37 @@
@ -71,6 +66,3 @@ index 0000000..7d6868a
+ };
+ };
+};
--
1.8.4.5

@ -15,8 +15,6 @@ Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
2 files changed, 79 insertions(+), 1 deletion(-)
create mode 100644 arch/arm/boot/dts/bcm4709-netgear-r8000.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 2604d7c..c6e0a4c 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -61,7 +61,8 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
@ -29,9 +27,6 @@ index 2604d7c..c6e0a4c 100644
dtb-$(CONFIG_ARCH_BCM_63XX) += bcm963138dvt.dtb
dtb-$(CONFIG_ARCH_BCM_MOBILE) += bcm28155-ap.dtb \
bcm21664-garnet.dtb
diff --git a/arch/arm/boot/dts/bcm4709-netgear-r8000.dts b/arch/arm/boot/dts/bcm4709-netgear-r8000.dts
new file mode 100644
index 0000000..ea26dd3
--- /dev/null
+++ b/arch/arm/boot/dts/bcm4709-netgear-r8000.dts
@@ -0,0 +1,77 @@
@ -112,6 +107,3 @@ index 0000000..ea26dd3
+ };
+ };
+};
--
1.8.4.5

@ -15,8 +15,6 @@ Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
arch/arm/boot/dts/bcm4708-netgear-r6250.dts | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/arm/boot/dts/bcm4708-netgear-r6250.dts b/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
index f18c9d9..2ed9e57 100644
--- a/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
@@ -45,13 +45,13 @@
@ -35,6 +33,3 @@ index f18c9d9..2ed9e57 100644
};
usb {
--
1.8.4.5

@ -17,11 +17,9 @@ Signed-off-by: Wim Van Sebroeck <wim@iguana.be>
include/linux/bcm47xx_wdt.h | 1 +
2 files changed, 21 insertions(+), 1 deletion(-)
diff --git a/drivers/watchdog/bcm47xx_wdt.c b/drivers/watchdog/bcm47xx_wdt.c
index 9816485..b28a072 100644
--- a/drivers/watchdog/bcm47xx_wdt.c
+++ b/drivers/watchdog/bcm47xx_wdt.c
@@ -169,6 +169,17 @@ static int bcm47xx_wdt_notify_sys(struct notifier_block *this,
@@ -169,6 +169,17 @@ static int bcm47xx_wdt_notify_sys(struct
return NOTIFY_DONE;
}
@ -39,7 +37,7 @@ index 9816485..b28a072 100644
static struct watchdog_ops bcm47xx_wdt_soft_ops = {
.owner = THIS_MODULE,
.start = bcm47xx_wdt_soft_start,
@@ -209,15 +220,23 @@ static int bcm47xx_wdt_probe(struct platform_device *pdev)
@@ -209,15 +220,23 @@ static int bcm47xx_wdt_probe(struct plat
if (ret)
goto err_timer;
@ -64,8 +62,6 @@ index 9816485..b28a072 100644
err_notifier:
unregister_reboot_notifier(&wdt->notifier);
err_timer:
diff --git a/include/linux/bcm47xx_wdt.h b/include/linux/bcm47xx_wdt.h
index b708786..5582c21 100644
--- a/include/linux/bcm47xx_wdt.h
+++ b/include/linux/bcm47xx_wdt.h
@@ -16,6 +16,7 @@ struct bcm47xx_wdt {
@ -76,6 +72,3 @@ index b708786..5582c21 100644
struct timer_list soft_timer;
atomic_t soft_ticks;
--
1.8.4.5

@ -16,8 +16,6 @@ Signed-off-by: Wim Van Sebroeck <wim@iguana.be>
drivers/watchdog/Kconfig | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/watchdog/Kconfig b/drivers/watchdog/Kconfig
index 2aaef7b..ca6c949 100644
--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
@@ -1101,7 +1101,7 @@ config ATH79_WDT
@ -29,6 +27,3 @@ index 2aaef7b..ca6c949 100644
select WATCHDOG_CORE
help
Hardware driver for the Broadcom BCM47xx Watchdog Timer.
--
1.8.4.5

@ -16,8 +16,6 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
drivers/ssb/driver_chipcommon_pmu.c | 2 +-
6 files changed, 7 insertions(+), 3 deletions(-)
diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
index 4733d32..ab18030 100644
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
@@ -2166,6 +2166,8 @@ source "net/Kconfig"
@ -29,8 +27,6 @@ index 4733d32..ab18030 100644
source "fs/Kconfig"
source "arch/arm/Kconfig.debug"
diff --git a/drivers/firmware/Kconfig b/drivers/firmware/Kconfig
index 4198388..ffbc9e4 100644
--- a/drivers/firmware/Kconfig
+++ b/drivers/firmware/Kconfig
@@ -132,6 +132,7 @@ config ISCSI_IBFT
@ -41,11 +37,9 @@ index 4198388..ffbc9e4 100644
source "drivers/firmware/google/Kconfig"
source "drivers/firmware/efi/Kconfig"
diff --git a/drivers/firmware/Makefile b/drivers/firmware/Makefile
index 5373dc5..e251f2b 100644
--- a/drivers/firmware/Makefile
+++ b/drivers/firmware/Makefile
@@ -12,6 +12,7 @@ obj-$(CONFIG_ISCSI_IBFT_FIND) += iscsi_ibft_find.o
@@ -12,6 +12,7 @@ obj-$(CONFIG_ISCSI_IBFT_FIND) += iscsi_i
obj-$(CONFIG_ISCSI_IBFT) += iscsi_ibft.o
obj-$(CONFIG_FIRMWARE_MEMMAP) += memmap.o
@ -53,11 +47,9 @@ index 5373dc5..e251f2b 100644
obj-$(CONFIG_GOOGLE_FIRMWARE) += google/
obj-$(CONFIG_EFI) += efi/
obj-$(CONFIG_UEFI_CPER) += efi/
diff --git a/drivers/net/ethernet/broadcom/b44.c b/drivers/net/ethernet/broadcom/b44.c
index 8a7bf7d..bf3bcd6 100644
--- a/drivers/net/ethernet/broadcom/b44.c
+++ b/drivers/net/ethernet/broadcom/b44.c
@@ -400,7 +400,7 @@ static void b44_set_flow_ctrl(struct b44 *bp, u32 local, u32 remote)
@@ -400,7 +400,7 @@ static void b44_set_flow_ctrl(struct b44
}
#ifdef CONFIG_BCM47XX
@ -66,8 +58,6 @@ index 8a7bf7d..bf3bcd6 100644
static void b44_wap54g10_workaround(struct b44 *bp)
{
char buf[20];
diff --git a/drivers/net/ethernet/broadcom/bgmac.c b/drivers/net/ethernet/broadcom/bgmac.c
index 34c7bc8..943707f 100644
--- a/drivers/net/ethernet/broadcom/bgmac.c
+++ b/drivers/net/ethernet/broadcom/bgmac.c
@@ -18,7 +18,7 @@
@ -79,8 +69,6 @@ index 34c7bc8..943707f 100644
static const struct bcma_device_id bgmac_bcma_tbl[] = {
BCMA_CORE(BCMA_MANUF_BCM, BCMA_CORE_4706_MAC_GBIT, BCMA_ANY_REV, BCMA_ANY_CLASS),
diff --git a/drivers/ssb/driver_chipcommon_pmu.c b/drivers/ssb/driver_chipcommon_pmu.c
index 1173a09..0942841 100644
--- a/drivers/ssb/driver_chipcommon_pmu.c
+++ b/drivers/ssb/driver_chipcommon_pmu.c
@@ -14,7 +14,7 @@
@ -92,6 +80,3 @@ index 1173a09..0942841 100644
#endif
#include "ssb_private.h"
--
1.8.4.5

@ -24,11 +24,9 @@ V2: Change code after receiving Florian's comments:
create mode 100644 arch/arm/mach-bcm/bcm5301x_headsmp.S
create mode 100644 arch/arm/mach-bcm/bcm5301x_smp.c
diff --git a/Documentation/devicetree/bindings/arm/bcm4708.txt b/Documentation/devicetree/bindings/arm/bcm4708.txt
index 6b0f49f..3dd0e9d 100644
--- a/Documentation/devicetree/bindings/arm/bcm4708.txt
+++ b/Documentation/devicetree/bindings/arm/bcm4708.txt
@@ -6,3 +6,27 @@ Boards with the BCM4708 SoC shall have the following properties:
@@ -6,3 +6,27 @@ Boards with the BCM4708 SoC shall have t
Required root node property:
compatible = "brcm,bcm4708";
@ -56,11 +54,9 @@ index 6b0f49f..3dd0e9d 100644
+ reg = <0x0 0x1000>;
+ };
+ };
diff --git a/Documentation/devicetree/bindings/arm/cpus.txt b/Documentation/devicetree/bindings/arm/cpus.txt
index 6aa331d..3507ae3 100644
--- a/Documentation/devicetree/bindings/arm/cpus.txt
+++ b/Documentation/devicetree/bindings/arm/cpus.txt
@@ -188,6 +188,7 @@ nodes to be present and contain the properties described below.
@@ -188,6 +188,7 @@ nodes to be present and contain the prop
can be one of:
"allwinner,sun6i-a31"
"arm,psci"
@ -68,8 +64,6 @@ index 6aa331d..3507ae3 100644
"brcm,brahma-b15"
"marvell,armada-375-smp"
"marvell,armada-380-smp"
diff --git a/arch/arm/boot/dts/bcm4708.dtsi b/arch/arm/boot/dts/bcm4708.dtsi
index 31141e8..c0af5cc 100644
--- a/arch/arm/boot/dts/bcm4708.dtsi
+++ b/arch/arm/boot/dts/bcm4708.dtsi
@@ -15,6 +15,7 @@
@ -97,11 +91,9 @@ index 31141e8..c0af5cc 100644
+ };
+ };
};
diff --git a/arch/arm/mach-bcm/Makefile b/arch/arm/mach-bcm/Makefile
index 4c38674..ca12727 100644
--- a/arch/arm/mach-bcm/Makefile
+++ b/arch/arm/mach-bcm/Makefile
@@ -33,6 +33,9 @@ obj-$(CONFIG_ARCH_BCM2835) += board_bcm2835.o
@@ -33,6 +33,9 @@ obj-$(CONFIG_ARCH_BCM2835) += board_bcm2
# BCM5301X
obj-$(CONFIG_ARCH_BCM_5301X) += bcm_5301x.o
@ -111,9 +103,6 @@ index 4c38674..ca12727 100644
# BCM63XXx
obj-$(CONFIG_ARCH_BCM_63XX) := bcm63xx.o
diff --git a/arch/arm/mach-bcm/bcm5301x_headsmp.S b/arch/arm/mach-bcm/bcm5301x_headsmp.S
new file mode 100644
index 0000000..9ca8d20
--- /dev/null
+++ b/arch/arm/mach-bcm/bcm5301x_headsmp.S
@@ -0,0 +1,45 @@
@ -162,9 +151,6 @@ index 0000000..9ca8d20
+ .align 2
+1: .long .
+ .long pen_release
diff --git a/arch/arm/mach-bcm/bcm5301x_smp.c b/arch/arm/mach-bcm/bcm5301x_smp.c
new file mode 100644
index 0000000..45d7089
--- /dev/null
+++ b/arch/arm/mach-bcm/bcm5301x_smp.c
@@ -0,0 +1,158 @@
@ -326,6 +312,3 @@ index 0000000..45d7089
+
+CPU_METHOD_OF_DECLARE(bcm5301x_smp, "brcm,bcm4708-smp",
+ &bcm5301x_smp_ops);
--
1.8.4.5

@ -16,8 +16,6 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
arch/arm/mach-bcm/bcm_5301x.c | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/arch/arm/mach-bcm/bcm_5301x.c b/arch/arm/mach-bcm/bcm_5301x.c
index e9bcbdb..7aef927 100644
--- a/arch/arm/mach-bcm/bcm_5301x.c
+++ b/arch/arm/mach-bcm/bcm_5301x.c
@@ -18,15 +18,16 @@ static bool first_fault = true;
@ -41,6 +39,3 @@ index e9bcbdb..7aef927 100644
/* Returning non-zero causes fault display and panic */
return 0;
--
1.8.4.5

@ -13,8 +13,6 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
2 files changed, 84 insertions(+)
create mode 100644 arch/arm/boot/dts/bcm4708-asus-rt-ac68u.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 4e1b387..7c1ca2a 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -55,6 +55,7 @@ dtb-$(CONFIG_ARCH_ATLAS6) += atlas6-evb.
@ -25,9 +23,6 @@ index 4e1b387..7c1ca2a 100644
bcm4708-buffalo-wzr-1750dhp.dtb \
bcm4708-luxul-xwc-1000.dtb \
bcm4708-netgear-r6250.dtb \
diff --git a/arch/arm/boot/dts/bcm4708-asus-rt-ac68u.dts b/arch/arm/boot/dts/bcm4708-asus-rt-ac68u.dts
new file mode 100644
index 0000000..8b62836
--- /dev/null
+++ b/arch/arm/boot/dts/bcm4708-asus-rt-ac68u.dts
@@ -0,0 +1,83 @@
@ -114,6 +109,3 @@ index 0000000..8b62836
+ };
+ };
+};
--
1.8.4.5

@ -17,8 +17,6 @@ ARM: BCM5301X: Add DT for Asus RT-AC68U
2 files changed, 97 insertions(+)
create mode 100644 arch/arm/boot/dts/bcm4708-asus-rt-ac56u.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 7c1ca2a..53f8c1a 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -55,6 +55,7 @@ dtb-$(CONFIG_ARCH_ATLAS6) += atlas6-evb.
@ -29,9 +27,6 @@ index 7c1ca2a..53f8c1a 100644
bcm4708-asus-rt-ac68u.dtb \
bcm4708-buffalo-wzr-1750dhp.dtb \
bcm4708-luxul-xwc-1000.dtb \
diff --git a/arch/arm/boot/dts/bcm4708-asus-rt-ac56u.dts b/arch/arm/boot/dts/bcm4708-asus-rt-ac56u.dts
new file mode 100644
index 0000000..71cff8d
--- /dev/null
+++ b/arch/arm/boot/dts/bcm4708-asus-rt-ac56u.dts
@@ -0,0 +1,96 @@
@ -131,6 +126,3 @@ index 0000000..71cff8d
+ };
+ };
+};
--
1.8.4.5

@ -11,11 +11,9 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
drivers/mtd/bcm47xxpart.c | 6 ++++++
1 file changed, 6 insertions(+)
diff --git a/drivers/mtd/bcm47xxpart.c b/drivers/mtd/bcm47xxpart.c
index ee3e010..f13c824 100644
--- a/drivers/mtd/bcm47xxpart.c
+++ b/drivers/mtd/bcm47xxpart.c
@@ -120,9 +120,15 @@ static int bcm47xxpart_parse(struct mtd_info *master,
@@ -120,9 +120,15 @@ static int bcm47xxpart_parse(struct mtd_
/* Parse block by block looking for magics */
for (offset = 0; offset <= master->size - blocksize;
offset += blocksize) {
@ -31,6 +29,3 @@ index ee3e010..f13c824 100644
if (curr_part >= BCM47XXPART_MAX_PARTS) {
pr_warn("Reached maximum number of partitions, scanning stopped!\n");
--
1.8.4.5

@ -13,11 +13,9 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
drivers/mtd/ubi/ubi.h | 1 +
3 files changed, 10 insertions(+)
diff --git a/drivers/mtd/ubi/attach.c b/drivers/mtd/ubi/attach.c
index 380268b..8f525c2 100644
--- a/drivers/mtd/ubi/attach.c
+++ b/drivers/mtd/ubi/attach.c
@@ -95,6 +95,9 @@ static int self_check_ai(struct ubi_device *ubi, struct ubi_attach_info *ai);
@@ -95,6 +95,9 @@ static int self_check_ai(struct ubi_devi
static struct ubi_ec_hdr *ech;
static struct ubi_vid_hdr *vidh;
@ -27,7 +25,7 @@ index 380268b..8f525c2 100644
/**
* add_to_list - add physical eraseblock to a list.
* @ai: attaching information
@@ -1418,6 +1421,8 @@ int ubi_attach(struct ubi_device *ubi, int force_scan)
@@ -1418,6 +1421,8 @@ int ubi_attach(struct ubi_device *ubi, i
if (!ai)
return -ENOMEM;
@ -36,11 +34,9 @@ index 380268b..8f525c2 100644
#ifdef CONFIG_MTD_UBI_FASTMAP
/* On small flash devices we disable fastmap in any case. */
if ((int)mtd_div_by_eb(ubi->mtd->size, ubi->mtd) <= UBI_FM_MAX_START) {
diff --git a/drivers/mtd/ubi/io.c b/drivers/mtd/ubi/io.c
index d361349..f3d29ce 100644
--- a/drivers/mtd/ubi/io.c
+++ b/drivers/mtd/ubi/io.c
@@ -753,6 +753,10 @@ int ubi_io_read_ec_hdr(struct ubi_device *ubi, int pnum,
@@ -753,6 +753,10 @@ int ubi_io_read_ec_hdr(struct ubi_device
}
magic = be32_to_cpu(ec_hdr->magic);
@ -51,8 +47,6 @@ index d361349..f3d29ce 100644
if (magic != UBI_EC_HDR_MAGIC) {
if (mtd_is_eccerr(read_err))
return UBI_IO_BAD_HDR_EBADMSG;
diff --git a/drivers/mtd/ubi/ubi.h b/drivers/mtd/ubi/ubi.h
index 1259e72..142ee3d 100644
--- a/drivers/mtd/ubi/ubi.h
+++ b/drivers/mtd/ubi/ubi.h
@@ -743,6 +743,7 @@ extern struct mutex ubi_devices_mutex;
@ -63,6 +57,3 @@ index 1259e72..142ee3d 100644
int ubi_add_to_av(struct ubi_device *ubi, struct ubi_attach_info *ai, int pnum,
int ec, const struct ubi_vid_hdr *vid_hdr, int bitflips);
struct ubi_ainf_volume *ubi_find_av(const struct ubi_attach_info *ai,
--
1.8.4.5

@ -25,11 +25,9 @@ Do you see any better idea of solving this?
drivers/bcma/main.c | 16 ++++++++++++++--
1 file changed, 14 insertions(+), 2 deletions(-)
diff --git a/drivers/bcma/main.c b/drivers/bcma/main.c
index 9635f10..c394207 100644
--- a/drivers/bcma/main.c
+++ b/drivers/bcma/main.c
@@ -637,13 +637,25 @@ static int bcma_device_uevent(struct device *dev, struct kobj_uevent_env *env)
@@ -637,13 +637,25 @@ static int bcma_device_uevent(struct dev
core->id.rev, core->id.class);
}
@ -65,6 +63,3 @@ index 9635f10..c394207 100644
static void __exit bcma_modexit(void)
{
--
1.8.4.5

Loading…
Cancel
Save