kernel: add workaround to rebuild vdso-o32.so.dbg

Building for octeon fails with

  'arch/mips/vdso/vdso-o32.so.dbg' already contains a '.MIPS.abiflags'
  section

if the file already exists from a prior build.

Use the same workaround as the one for vdso.so.dbg committed in
9eb155353a.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
v19.07.3_mercusys_ac12_duma
Stijn Tintel 8 years ago
parent 3339f14e84
commit 91f205acaf

@ -1,5 +1,7 @@
--- a/arch/mips/vdso/Makefile
+++ b/arch/mips/vdso/Makefile
Index: linux-4.4.9/arch/mips/vdso/Makefile
===================================================================
--- linux-4.4.9.orig/arch/mips/vdso/Makefile
+++ linux-4.4.9/arch/mips/vdso/Makefile
@@ -75,7 +75,7 @@ $(obj-vdso): KBUILD_AFLAGS := $(aflags-v
$(obj)/vdso.lds: KBUILD_CPPFLAGS := $(native-abi)
@ -9,3 +11,12 @@
$(call if_changed,vdsold)
$(obj)/vdso-image.c: $(obj)/vdso.so.dbg $(obj)/genvdso FORCE
@@ -109,7 +109,7 @@ $(obj)/vdso-o32.lds: KBUILD_CPPFLAGS :=
$(obj)/vdso-o32.lds: $(src)/vdso.lds.S FORCE
$(call if_changed_dep,cpp_lds_S)
-$(obj)/vdso-o32.so.dbg: $(obj)/vdso-o32.lds $(obj-vdso-o32) FORCE
+$(obj)/vdso-o32.so.dbg: $(obj)/vdso-o32.lds $(obj-vdso-o32) $(obj)/genvdso FORCE
$(call if_changed,vdsold)
$(obj)/vdso-o32-image.c: VDSO_NAME := o32

Loading…
Cancel
Save