tools: bootstrap libtool to pickup the correct in-tree automake

Also fix 000-relocatable.patch to avoid accidential sed invocations in bootstrap.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>

SVN-Revision: 43959
v19.07.3_mercusys_ac12_duma
Jo-Philipp Wich 9 years ago
parent 73a1f3597b
commit 90283e410b

@ -1,5 +1,5 @@
#
# Copyright (C) 2008 OpenWrt.org
# Copyright (C) 2008-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -20,6 +20,12 @@ include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_VARS += \
lt_cv_sys_dlsearch_path=""
define Host/Prepare
$(call Host/Prepare/Default)
(cd $(STAGING_DIR_HOST)/share/aclocal/ && rm -f libtool.m4 ltdl.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4)
(cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) ./bootstrap)
endef
define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) install
$(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(STAGING_DIR_HOST)/bin/libtool

@ -1,11 +1,15 @@
--- a/libltdl/config/general.m4sh
+++ b/libltdl/config/general.m4sh
@@ -53,7 +53,7 @@ test "${ECHO+set}" = set || ECHO=${as_ec
@@ -53,7 +53,11 @@ test "${ECHO+set}" = set || ECHO=${as_ec
: ${MKDIR="mkdir"}
: ${MV="mv -f"}
: ${RM="rm -f"}
-: ${SED="@SED@"}
+test "${STAGING_DIR+set}" = set && ${SED="$STAGING_DIR/../host/bin/sed"} || ${SED="@SED@"}
+if test -n "$STAGING_DIR"; then
+ : ${SED="$STAGING_DIR/../host/bin/sed"}
+else
+ : ${SED="@SED@"}
+fi
: ${SHELL="${CONFIG_SHELL-/bin/sh}"}
: ${Xsed="$SED -e 1s/^X//"}

@ -1,6 +1,6 @@
--- a/libltdl/config/general.m4sh
+++ b/libltdl/config/general.m4sh
@@ -352,7 +352,7 @@ opt_warning=:
@@ -356,7 +356,7 @@ opt_warning=:
# name if it has been set yet.
func_echo ()
{
@ -9,7 +9,7 @@
}
# func_verbose arg...
@@ -378,14 +378,14 @@ func_echo_all ()
@@ -382,14 +382,14 @@ func_echo_all ()
# Echo program name prefixed message to standard error.
func_error ()
{

Loading…
Cancel
Save