mac80211: don't hardcode /bin/bash

Instead of hardcoding /bin/bash, use /usr/bin/env bash - this fixes the
build on FreeBSD 10.1.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>

SVN-Revision: 44283
v19.07.3_mercusys_ac12_duma
Jo-Philipp Wich 9 years ago
parent 66fe4fd966
commit 8f7ce3aa6d

@ -1,5 +1,14 @@
--- a/Makefile
+++ b/Makefile
@@ -5,7 +5,7 @@
ifeq ($(KERNELRELEASE),)
MAKEFLAGS += --no-print-directory
-SHELL := /bin/bash
+SHELL := /usr/bin/env bash
BACKPORT_PWD := $(shell pwd)
KMODDIR ?= updates
@@ -19,6 +19,7 @@ KLIB_BUILD ?= $(KLIB)/build/
KERNEL_CONFIG := $(KLIB_BUILD)/.config
KERNEL_MAKEFILE := $(KLIB_BUILD)/Makefile

Loading…
Cancel
Save