Added elhttp and tmsnc

SVN-Revision: 2571
v19.07.3_mercusys_ac12_duma
Florian Fainelli 19 years ago
parent fb7ceddc92
commit 8b937f99c5

@ -57,6 +57,7 @@ source "package/dhcp-forwarder/Config.in"
source "package/dropbear/Config.in"
source "package/dsniff/Config.in"
source "package/ebtables/Config.in"
source "package/elhttp/Config.in"
source "package/ether-wake/Config.in"
source "package/ez-ipupdate/Config.in"
source "package/fping/Config.in"
@ -120,6 +121,7 @@ source "package/snort-wireless/Config.in"
source "package/socat/Config.in"
source "package/ssmtp/Config.in"
source "package/srelay/Config.in"
source "package/tmsnc/Config.in"
source "package/tcpdump/Config.in"
source "package/tinc/Config.in"
source "package/tor/Config.in"

@ -0,0 +1,7 @@
config BR2_PACKAGE_ELHTTP
tristate "elhttp - The extra-light http proxy server."
default m if CONFIG_DEVEL
help
The extra-light http proxy server. Features: keep-alive
connections, http connect method, SSL/TLS support, ACLs
and client requests logging.

@ -0,0 +1,35 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=elhttp
PKG_VERSION:=0.22
PKG_RELEASE:=1
PKG_MD5SUM:=b52f68c47f709e9fc9429250eb8f954c
PKG_SOURCE_URL:=http://www.cr0.net:8040/code/network/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_CAT:=gzcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,ELHTTP,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured:
touch $@
$(PKG_BUILD_DIR)/.built:
mkdir -p $(PKG_INSTALL_DIR)/usr/sbin
$(MAKE) CC=$(TARGET_CC) CROSS=$(TARGET_CROSS) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
$(RSTRIP) $(PKG_INSTALL_DIR)/usr/sbin/
touch $@
$(IPKG_ELHTTP):
mkdir -p $(IDIR_ELHTTP)
cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_ELHTTP)/
$(RSTRIP) $(IDIR_ELHTTP)/
$(IPKG_BUILD) $(IDIR_ELHTTP) $(PACKAGE_DIR)

@ -0,0 +1,9 @@
Package: elhttp
Section: net
Architecture: mipsel
Maintainer: Florian Fainelli <florian@alphacore.net>
Source: http://www.cr0.net:8040/code/network/
Description: The extra-light http proxy server. Features: keep-alive
connections, http connect method, SSL/TLS support, ACLs
and client requests logging.
Priority: optional

@ -0,0 +1,21 @@
--- orig/elhttp-0.22/Makefile 2004-06-18 15:32:17.000000000 +0200
+++ elhttp-0.22/Makefile 2005-11-21 18:04:23.000000000 +0100
@@ -1,13 +1,7 @@
-
+all: linux
linux:
- gcc -O -W -Wall -o elhttp elhttp.c
- strip elhttp
-
-sunos:
- gcc -O -W -Wall -o elhttp elhttp.c -lsocket -lnsl
- strip elhttp
-
-unix:
- cc -O -o elhttp elhttp.c
- strip elhttp
+ $(CC) -O -W -Wall -o elhttp elhttp.c
+install:
+ install -d -m0755 $(DESTDIR)/usr/sbin
+ install -m0755 elhttp $(DESTDIR)/usr/sbin/

@ -0,0 +1,6 @@
config BR2_PACKAGE_TMSNC
tristate "text-based MSN client"
default m if CONFIG_DEVEL
TMSNC is a textbased (console) MSN client written in C.
http://tmsnc.sourceforge.net

@ -0,0 +1,60 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=tmsnc
PKG_VERSION:=0.3.0
PKG_RELEASE:=2
PKG_MD5SUM:=cc1791dc5be267d272c9b2927c585f6e
PKG_SOURCE_URL:=@SF/tmsnc
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_CAT:=zcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,TMSNC,tmsnc,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
ac_cv_func_malloc_0_nonnull=yes \
ac_cv_func_realloc_0_nonnull=yes \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
--libexecdir=/usr/lib \
--sysconfdir=/etc \
--datadir=/usr/share \
--localstatedir=/var \
--mandir=/usr/man \
--infodir=/usr/info \
$(DISABLE_NLS) \
--with-libiconv-prefix=$(STAGING_DIR)/usr \
--with-openssl=$(STAGING_DIR)/usr \
--with-ncurses=$(STAGING_DIR) \
--with-gnu-ld \
)
touch $@
$(PKG_BUILD_DIR)/.built:
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
install
rm -rf $(PKG_INSTALL_DIR)/usr/man
touch $@
$(IPKG_TMSNC):
mkdir -p $(IDIR_TMSNC)
cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_TMSNC)/
$(RSTRIP) $(IDIR_TMSNC)
$(IPKG_BUILD) $(IDIR_TMSNC) $(PACKAGE_DIR)

@ -0,0 +1,9 @@
Package: tmsnc
Priority: optional
Section: net
Maintainer: Florian Fainelli <florian@alphacore.net>
Source: http://tmsnc.sourceforge.net
Priority: optional
Section: net
Description: TMSNC is a textbased (console) MSN client written in C. TMSNC should work on most Unix (Linux, BSD, MacOS) compatible operating systems. The goal of this project is to create a client like MSN Messenger (with sound, webcam and file transfer support), but without any graphical features.
Depends: libncurses, libopenssl
Loading…
Cancel
Save