This is the Linksys-ported driver from WRT54G3G-ST_v2.00.9_US.tgz, re-based against 2.4.35 and repaired for obvious breakage (didn't use its device table, etc.).

Changes from Linksys tree:
 - Remove 'vendor' and 'product' parameters; these aren't used in the
mainstream driver and seem to only have served to break it.
 - Remove bogus 'sierra_device_ids' table, used with above.
 - Changed references to 'sierra_device_ids' back to id_table
 - Changed non-standard CONFIG_USB_SERIAL_SIERRA_3G (line 886) to
current module standard CONFIG_USB_SERIAL_SIERRAWIRELESS
 - Added #include to enable pl2303 hack to remain until I can figure
out if it's still necessary.
Signed-off-by:  RB <aoz.syn@gmail.com>

SVN-Revision: 11899
v19.07.3_mercusys_ac12_duma
Travis Kemen 16 years ago
parent 1a47f8142d
commit 8894411b60

File diff suppressed because it is too large Load Diff

@ -20,3 +20,25 @@ diff -Naur linux-2.4.35.4.orig/drivers/usb/serial/Makefile linux-2.4.35.4/driver
# Objects that export symbols.
export-objs := usbserial.o
diff -Naur linux-2.4.35.4.orig/drivers/usb/serial/Config.in linux-2.4.35.4/drivers/usb/serial/Config.in
--- linux-2.4.35.4.orig/drivers/usb/serial/Config.in 2008-01-25 10:09:11.541747549 -0700
+++ linux-2.4.35.4/drivers/usb/serial/Config.in 2008-01-25 10:17:01.890745265 -0700
@@ -39,6 +39,7 @@
dep_tristate ' USB KOBIL chipcard reader (EXPERIMENTAL)' CONFIG_USB_SERIAL_KOBIL_SCT $CONFIG_USB_SERIAL $CONFIG_EXPERIMENTAL
dep_tristate ' USB Prolific 2303 Single Port Serial Driver' CONFIG_USB_SERIAL_PL2303 $CONFIG_USB_SERIAL
dep_tristate ' USB REINER SCT cyberJack pinpad/e-com chipcard reader (EXPERIMENTAL)' CONFIG_USB_SERIAL_CYBERJACK $CONFIG_USB_SERIAL $CONFIG_EXPERIMENTAL
+ dep_tristate ' USB Sierra Wireless Driver' CONFIG_USB_SERIAL_SIERRAWIRELESS $CONFIG_USB_SERIAL
dep_tristate ' USB Xircom / Entregra Single Port Serial Driver (EXPERIMENTAL)' CONFIG_USB_SERIAL_XIRCOM $CONFIG_USB_SERIAL $CONFIG_EXPERIMENTAL
dep_tristate ' USB ZyXEL omni.net LCD Plus Driver (EXPERIMENTAL)' CONFIG_USB_SERIAL_OMNINET $CONFIG_USB_SERIAL $CONFIG_EXPERIMENTAL
fi
diff -Naur linux-2.4.35.4.orig/drivers/usb/serial/Makefile linux-2.4.35.4/drivers/usb/serial/Makefile
--- linux-2.4.35.4.orig/drivers/usb/serial/Makefile 2008-01-25 10:09:11.542749582 -0700
+++ linux-2.4.35.4/drivers/usb/serial/Makefile 2008-01-25 10:17:37.412855271 -0700
@@ -26,6 +26,7 @@
obj-$(CONFIG_USB_SERIAL_IR) += ir-usb.o
obj-$(CONFIG_USB_SERIAL_KLSI) += kl5kusb105.o
obj-$(CONFIG_USB_SERIAL_KOBIL_SCT) += kobil_sct.o
+obj-$(CONFIG_USB_SERIAL_SIERRAWIRELESS) += sierra.o
# Objects that export symbols.
export-objs := usbserial.o

Loading…
Cancel
Save