kmod-sched-cake: bump to 20181002

Revert "Add workaround for wrong skb->mac_len values after splitting GSO"

Remove our local patch which did the same thing.

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
v19.07.3_mercusys_ac12_duma
Kevin Darbyshire-Bryant 6 years ago
parent 7378ca79b9
commit 885052fbfb

@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=sched-cake
PKG_RELEASE:=2
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/dtaht/sch_cake.git
PKG_SOURCE_DATE:=2018-09-11
PKG_SOURCE_VERSION:=42e87f12ea5c390bf5eeb658c942bc810046160a
PKG_MIRROR_HASH:=56c71ae079e4c64aef2564d42d2efd31621e7e9f5220844ad1ea795e2f1cb1fd
PKG_SOURCE_DATE:=2018-10-02
PKG_SOURCE_VERSION:=ddf4c95145f2fbcca16f19e01f3195d213ca760b
PKG_MIRROR_HASH:=c5fd914fa1129e1cbe46e3dff30077b3265446538831e3a668229c22c4cf497a
PKG_MAINTAINER:=Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
include $(INCLUDE_DIR)/package.mk

@ -1,22 +0,0 @@
--- a/sch_cake.c
+++ b/sch_cake.c
@@ -1799,13 +1799,18 @@ static s32 cake_enqueue(struct sk_buff *
cobalt_set_enqueue_time(segs, now);
get_cobalt_cb(segs)->adjusted_len = cake_overhead(q,
segs);
-
+#if !((LINUX_VERSION_CODE >= KERNEL_VERSION(3, 18, 124) && LINUX_VERSION_CODE < KERNEL_VERSION(3, 19, 0)) || \
+ (LINUX_VERSION_CODE >= KERNEL_VERSION(4, 4, 159) && LINUX_VERSION_CODE < KERNEL_VERSION(4, 5, 0)) || \
+ (LINUX_VERSION_CODE >= KERNEL_VERSION(4, 9, 130) && LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0)) || \
+ (LINUX_VERSION_CODE >= KERNEL_VERSION(4, 14, 73) && LINUX_VERSION_CODE < KERNEL_VERSION(4, 15, 0)) || \
+ (LINUX_VERSION_CODE >= KERNEL_VERSION(4, 18, 11)))
/* For encapsulated packets, the mac_len may not be set
* correctly after GSO split. Fix this by resetting it;
* if skb_gso_segment() already does this correctly,
* this is will just recalculate the current value.
*/
skb_reset_mac_len(skb);
+#endif
flow_queue_add(flow, segs);
Loading…
Cancel
Save