update to 2.6.28.2

SVN-Revision: 14247
v19.07.3_mercusys_ac12_duma
Gabor Juhos 16 years ago
parent 04bf46b82b
commit 85963798be

@ -31,8 +31,8 @@ endif
ifeq ($(LINUX_VERSION),2.6.27.13)
LINUX_KERNEL_MD5SUM:=e1035cd771ef2aed59396d8cab543a0c
endif
ifeq ($(LINUX_VERSION),2.6.28)
LINUX_KERNEL_MD5SUM:=d351e44709c9810b85e29b877f50968a
ifeq ($(LINUX_VERSION),2.6.28.2)
LINUX_KERNEL_MD5SUM:=8fce853ebfe658f0833d34bb1dc14d86
endif
# disable the md5sum check for unknown kernel versions

@ -10,7 +10,7 @@ ARCH:=avr32
BOARD:=avr32
BOARDNAME:=Atmel AVR32
FEATURES:=squashfs
LINUX_VERSION:=2.6.28
LINUX_VERSION:=2.6.28.2
include $(INCLUDE_DIR)/target.mk

@ -11,7 +11,7 @@
#include <linux/types.h>
#ifdef __KERNEL__
@@ -239,4 +243,6 @@ struct itimerval {
@@ -240,4 +244,6 @@ struct itimerval {
*/
#define TIMER_ABSTIME 0x01

@ -1,5 +1,5 @@
--- ../../cs5535_gpio.c.orig 2009-01-07 10:16:12.000000000 +0100
+++ linux-2.6.28/drivers/char/cs5535_gpio.c 2009-01-07 10:13:54.000000000 +0100
--- a/drivers/char/cs5535_gpio.c
+++ b/drivers/char/cs5535_gpio.c
@@ -15,6 +15,7 @@
#include <linux/kernel.h>
#include <linux/init.h>
@ -8,7 +8,7 @@
#include <linux/ioport.h>
#include <linux/pci.h>
#include <linux/smp_lock.h>
@@ -48,6 +49,7 @@
@@ -48,6 +49,7 @@ static struct pci_device_id divil_pci[]
MODULE_DEVICE_TABLE(pci, divil_pci);
static struct cdev cs5535_gpio_cdev;
@ -16,7 +16,7 @@
/* reserve 32 entries even though some aren't usable */
#define CS5535_GPIO_COUNT 32
@@ -66,9 +68,14 @@
@@ -66,9 +68,14 @@ static struct gpio_regmap rm[] =
{ 0x30, 0x00, '1', '0' }, /* GPIOx_READ_BACK / GPIOx_OUT_VAL */
{ 0x20, 0x20, 'I', 'i' }, /* GPIOx_IN_EN */
{ 0x04, 0x04, 'O', 'o' }, /* GPIOx_OUT_EN */
@ -31,7 +31,7 @@
};
@@ -177,7 +184,7 @@
@@ -177,7 +184,7 @@ static int __init cs5535_gpio_init(void)
{
dev_t dev_id;
u32 low, hi;
@ -40,7 +40,7 @@
if (pci_dev_present(divil_pci) == 0) {
printk(KERN_WARNING NAME ": DIVIL not found\n");
@@ -232,23 +239,54 @@
@@ -232,23 +239,54 @@ static int __init cs5535_gpio_init(void)
major = MAJOR(dev_id);
}

@ -88,7 +88,7 @@
/*********************************************************************
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -140,6 +140,7 @@ asmlinkage long sys_dup(unsigned int fil
@@ -140,6 +140,7 @@ SYSCALL_DEFINE1(dup, unsigned int, filde
}
return ret;
}

@ -95,7 +95,7 @@
* We enter with non-exclusive mmap_sem (to exclude vma changes,
--- a/mm/vmalloc.c
+++ b/mm/vmalloc.c
@@ -980,6 +980,7 @@ void unmap_kernel_range(unsigned long ad
@@ -981,6 +981,7 @@ void unmap_kernel_range(unsigned long ad
vunmap_page_range(addr, end);
flush_tlb_kernel_range(addr, end);
}
@ -103,7 +103,7 @@
int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages)
{
@@ -1085,6 +1086,7 @@ struct vm_struct *get_vm_area(unsigned l
@@ -1086,6 +1087,7 @@ struct vm_struct *get_vm_area(unsigned l
return __get_vm_area_node(size, flags, VMALLOC_START, VMALLOC_END,
-1, GFP_KERNEL, __builtin_return_address(0));
}

@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
FEATURES:=squashfs
SUBTARGETS=generic harddisk
LINUX_VERSION:=2.6.28.1
LINUX_VERSION:=2.6.28.2
include $(INCLUDE_DIR)/target.mk

@ -11,7 +11,7 @@ BOARD:=orion
BOARDNAME:=Marvell Orion
FEATURES:=squashfs
LINUX_VERSION:=2.6.28
LINUX_VERSION:=2.6.28.2
include $(INCLUDE_DIR)/target.mk

@ -11,7 +11,7 @@ BOARD:=s3c24xx
BOARDNAME:=s3c24xx
FEATURES:=jffs2
LINUX_VERSION:=2.6.28
LINUX_VERSION:=2.6.28.2
DEVICE_TYPE=phone

File diff suppressed because it is too large Load Diff

@ -1,7 +1,5 @@
Index: linux-2.6.28/init/main.c
===================================================================
--- linux-2.6.28.orig/init/main.c 2009-01-03 13:03:03.000000000 +0100
+++ linux-2.6.28/init/main.c 2009-01-03 13:03:14.000000000 +0100
--- a/init/main.c
+++ b/init/main.c
@@ -825,6 +825,7 @@ static int noinline init_post(void)
printk(KERN_WARNING "Failed to execute %s. Attempting "
"defaults...\n", execute_command);

@ -1,10 +1,8 @@
Does not compile. --mb
---
Index: linux-2.6.28/net/netfilter/Kconfig
===================================================================
--- linux-2.6.28.orig/net/netfilter/Kconfig 2009-01-02 00:42:52.000000000 +0100
+++ linux-2.6.28/net/netfilter/Kconfig 2009-01-02 00:43:19.000000000 +0100
--- a/net/netfilter/Kconfig
+++ b/net/netfilter/Kconfig
@@ -314,7 +314,7 @@ if NETFILTER_XTABLES
config NETFILTER_XT_TARGET_CHAOS

@ -1,7 +1,6 @@
diff -ruN linux-2.6.28.orig/drivers/serial/samsung.c linux-2.6.28/drivers/serial/samsung.c
--- linux-2.6.28.orig/drivers/serial/samsung.c 2009-01-19 21:52:17.000000000 +0100
+++ linux-2.6.28/drivers/serial/samsung.c 2009-01-19 21:53:42.000000000 +0100
@@ -882,7 +882,7 @@
--- a/drivers/serial/samsung.c
+++ b/drivers/serial/samsung.c
@@ -882,7 +882,7 @@ static struct uart_ops s3c24xx_serial_op
static struct uart_driver s3c24xx_uart_drv = {
.owner = THIS_MODULE,

@ -11,7 +11,7 @@ BOARD:=sibyte
BOARDNAME:=Broadcom/SiByte SB-1
FEATURES:=broken
LINUX_VERSION:=2.6.28
LINUX_VERSION:=2.6.28.2
include $(INCLUDE_DIR)/target.mk

@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
FEATURES:=ext2
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
LINUX_VERSION:=2.6.28
LINUX_VERSION:=2.6.28.2
include $(INCLUDE_DIR)/target.mk

Loading…
Cancel
Save