xfsprogs: add the usual round of voodoo-workarounds for autofail, issue of the day is overwriting template files when AC_CONFIG_HEADER(S) is used, but only the first one, because consistency is for loosers

SVN-Revision: 25626
v19.07.3_mercusys_ac12_duma
Jo-Philipp Wich 14 years ago
parent cdb0481744
commit 84c1a05826

@ -0,0 +1,82 @@
--- a/m4/package_types.m4
+++ b/m4/package_types.m4
@@ -9,7 +9,7 @@ AC_DEFUN([AC_TYPE_PSINT],
#include <stddef.h>
], [
__psint_t psint;
- ], AC_DEFINE(HAVE___PSINT_T) AC_MSG_RESULT(yes) , AC_MSG_RESULT(no))
+ ], AC_DEFINE([HAVE___PSINT_T], [1], [Define if __psint_t exists]) AC_MSG_RESULT(yes) , AC_MSG_RESULT(no))
])
#
@@ -23,7 +23,7 @@ AC_DEFUN([AC_TYPE_PSUNSIGNED],
#include <stddef.h>
], [
__psunsigned_t psuint;
- ], AC_DEFINE(HAVE___PSUNSIGNED_T) AC_MSG_RESULT(yes) , AC_MSG_RESULT(no))
+ ], AC_DEFINE([HAVE___PSUNSIGNED_T], [1], [Define if __psunsigned_t exists]) AC_MSG_RESULT(yes) , AC_MSG_RESULT(no))
])
#
@@ -37,7 +37,7 @@ AC_DEFUN([AC_TYPE_U32],
#include <stddef.h>
], [
__u32 u32;
- ], AC_DEFINE(HAVE___U32) AC_MSG_RESULT(yes) , AC_MSG_RESULT(no))
+ ], AC_DEFINE([HAVE___U32], [1], [Define if __u32 exists]) AC_MSG_RESULT(yes) , AC_MSG_RESULT(no))
])
#
@@ -50,15 +50,15 @@ AC_DEFUN([AC_SIZEOF_POINTERS_AND_LONG],
AC_CHECK_SIZEOF(long, 4)
AC_CHECK_SIZEOF(char *, 4)
if test $ac_cv_sizeof_long -eq 4 -o $ac_cv_sizeof_long -eq 0; then
- AC_DEFINE(HAVE_32BIT_LONG)
+ AC_DEFINE([HAVE_32BIT_LONG], [1], [Define if long is 32bit])
fi
if test $ac_cv_sizeof_long -eq 8; then
- AC_DEFINE(HAVE_64BIT_LONG)
+ AC_DEFINE([HAVE_64BIT_LONG], [1], [Define if long is 64bit])
fi
if test $ac_cv_sizeof_char_p -eq 4 -o $ac_cv_sizeof_char_p -eq 0; then
- AC_DEFINE(HAVE_32BIT_PTR)
+ AC_DEFINE([HAVE_32BIT_PTR], [1], [Define if char* is 32bit])
fi
if test $ac_cv_sizeof_char_p -eq 8; then
- AC_DEFINE(HAVE_64BIT_PTR)
+ AC_DEFINE([HAVE_64BIT_PTR], [1], [Define if char* is 64bit])
fi
])
--- a/include/builddefs.in
+++ b/include/builddefs.in
@@ -20,6 +20,8 @@
ifndef _BUILDDEFS_INCLUDED_
_BUILDDEFS_INCLUDED_ = 1
+SHELL = @SHELL@
+
DEBUG = @debug_build@
OPTIMIZER = @opt_build@
MALLOCLIB = @malloc_lib@
--- a/include/buildmacros
+++ b/include/buildmacros
@@ -32,7 +32,6 @@ OBJECTS = $(ASFILES:.s=.o) \
INSTALL = $(TOPDIR)/install-sh -o $(PKG_USER) -g $(PKG_GROUP)
-SHELL = /bin/sh
IMAGES_DIR = $(TOPDIR)/all-images
DIST_DIR = $(TOPDIR)/dist
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,8 @@
AC_INIT(include/libxfs.h)
AC_CONFIG_AUX_DIR([.])
AC_CONFIG_MACRO_DIR([m4])
-AC_CONFIG_HEADER(include/platform_defs.h)
+# Put a dummy here (http://www.mail-archive.com/automake@gnu.org/msg09241.html)
+AC_CONFIG_HEADERS([doesnotexist.h include/platform_defs.h])
AC_PREFIX_DEFAULT(/usr)
AC_PROG_LIBTOOL
Loading…
Cancel
Save