kernel: update kernel to 3.10.15

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>

SVN-Revision: 38384
v19.07.3_mercusys_ac12_duma
Hauke Mehrtens 11 years ago
parent 551a250e58
commit 81e2f00367

@ -17,8 +17,8 @@ endif
ifeq ($(LINUX_VERSION),3.9.11)
LINUX_KERNEL_MD5SUM:=edbf88eb7f7d34dbd5d3887726790755
endif
ifeq ($(LINUX_VERSION),3.10.13)
LINUX_KERNEL_MD5SUM:=64ffe74249442fd7452d12348955ccfd
ifeq ($(LINUX_VERSION),3.10.15)
LINUX_KERNEL_MD5SUM:=3fe22263308674d92c6d106f633eca52
endif
# disable the md5sum check for unknown kernel versions

@ -13,7 +13,7 @@ FEATURES:=squashfs atm
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
SUBTARGETS:=generic ac49x
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
include $(INCLUDE_DIR)/target.mk

@ -13,7 +13,7 @@ FEATURES:=squashfs targz mips16
CPU_TYPE=34kc
SUBTARGETS:=generic nand
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
include $(INCLUDE_DIR)/target.mk

@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
FEATURES:=squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
include $(INCLUDE_DIR)/target.mk

@ -14,7 +14,7 @@ MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
CPU_TYPE:=cortex-a9
CPU_SUBTYPE:=vfp
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
include $(INCLUDE_DIR)/target.mk

@ -15,7 +15,7 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
CPU_TYPE:=arm1176jzf-s
CPU_SUBTYPE:=vfp
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835

@ -12,7 +12,7 @@ BOARDNAME:=Broadcom BCM947xx/953xx
FEATURES:=squashfs usb pcmcia
MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += swconfig kmod-diag wpad-mini nvram

@ -11,7 +11,7 @@ BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx
SUBTARGETS:=generic smp
FEATURES:=squashfs usb atm pci pcmcia
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
include $(INCLUDE_DIR)/target.mk

@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
FEATURES:=squashfs
CPU_TYPE:=fa526
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
include $(INCLUDE_DIR)/target.mk

@ -163,13 +163,11 @@ patches for bgmac backported from net-next/master
ring->num_slots * sizeof(struct bgmac_dma_desc));
ring->start = 0;
@@ -908,10 +934,10 @@ static void bgmac_chip_reset(struct bgma
struct bcma_drv_cc *cc = &bgmac->core->bus->drv_cc;
@@ -909,9 +935,9 @@ static void bgmac_chip_reset(struct bgma
u8 et_swtype = 0;
u8 sw_type = BGMAC_CHIPCTL_1_SW_TYPE_EPHY |
- BGMAC_CHIPCTL_1_IF_TYPE_RMII;
BGMAC_CHIPCTL_1_IF_TYPE_MII;
- char buf[2];
+ BGMAC_CHIPCTL_1_IF_TYPE_MII;
+ char buf[4];
- if (bcm47xx_nvram_getenv("et_swtype", buf, 1) > 0) {
@ -188,15 +186,6 @@ patches for bgmac backported from net-next/master
--- a/drivers/net/ethernet/broadcom/bgmac.h
+++ b/drivers/net/ethernet/broadcom/bgmac.h
@@ -333,7 +333,7 @@
#define BGMAC_CHIPCTL_1_IF_TYPE_MASK 0x00000030
#define BGMAC_CHIPCTL_1_IF_TYPE_RMII 0x00000000
-#define BGMAC_CHIPCTL_1_IF_TYPE_MI 0x00000010
+#define BGMAC_CHIPCTL_1_IF_TYPE_MII 0x00000010
#define BGMAC_CHIPCTL_1_IF_TYPE_RGMII 0x00000020
#define BGMAC_CHIPCTL_1_SW_TYPE_MASK 0x000000C0
#define BGMAC_CHIPCTL_1_SW_TYPE_EPHY 0x00000000
@@ -384,6 +384,8 @@ struct bgmac_dma_ring {
u16 mmio_base;
struct bgmac_dma_desc *cpu_base;

@ -13,7 +13,7 @@ FEATURES:=ext4 rtc usb gpio
CPU_TYPE:=arm926ej-s
MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
KERNELNAME:="zImage dtbs"
define Target/Description

@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
CPU_SUBTYPE:=vfpv3
MAINTAINER:=Luka Perkov <luka@openwrt.org>
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
include $(INCLUDE_DIR)/target.mk

@ -13,7 +13,7 @@ FEATURES:=squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
SUBTARGETS=generic harddisk
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
include $(INCLUDE_DIR)/target.mk

@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
FEATURES:=squashfs
SUBTARGETS=xway xrx200 ase falcon
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
CPU_TYPE:=mips32r2

@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
INITRAMFS_EXTRA_FILES:=
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
DEVICE_TYPE:=developerboard

@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
SUBTARGETS=generic p1020
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
include $(INCLUDE_DIR)/target.mk

@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
CPU_SUBTYPE:=vfpv3
MAINTAINER:=Luka Perkov <luka@openwrt.org>
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
include $(INCLUDE_DIR)/target.mk

@ -14,7 +14,7 @@ CPU_TYPE:=octeon
CPU_CFLAGS_octeon:=-march=octeon
MAINTAINER:=John Crispin <blogic@openwrt.org>
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
include $(INCLUDE_DIR)/target.mk

@ -13,7 +13,7 @@ FEATURES:=squashfs
CPU_TYPE:=405
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
include $(INCLUDE_DIR)/target.mk

@ -13,7 +13,7 @@ FEATURES:=squashfs broken
CPU_TYPE:=440
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
include $(INCLUDE_DIR)/target.mk

@ -12,7 +12,7 @@ BOARDNAME:=Ralink RT288x/RT3xxx
SUBTARGETS:=rt305x rt3883 mt7620a rt288x
FEATURES:=squashfs gpio
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=\

@ -11,7 +11,7 @@ BOARD:=rb532
BOARDNAME:=Mikrotik RouterBoard 532
FEATURES:=pci targz broken
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532

@ -14,7 +14,7 @@ CPU_TYPE:=mpcore
CPU_SUBTYPE:=vfp
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
DEVICE_TYPE:=developerboard

@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
FEATURES:=targz ubifs audio
SUBTARGETS:=qi_lb60 n516 n526 id800wt
LINUX_VERSION:=3.10.13
LINUX_VERSION:=3.10.15
DEVICE_TYPE=other

Loading…
Cancel
Save