ipset: bump to 6.34

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
v19.07.3_mercusys_ac12_duma
Stijn Tintel 7 years ago
parent 592abe9ef5
commit 7e58392bcb

@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ipset
PKG_VERSION:=6.32
PKG_RELEASE:=2
PKG_VERSION:=6.34
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://ipset.netfilter.org
PKG_HASH:=d9cbb49a4ae9e32d7808a604f1a37f359f9fc9064c210c4c5f35d629d49fb9fe
PKG_HASH:=d70e831b670b7aa25dde81fd994d3a7ce0c0e801559a557105576df66cd8d680
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
PKG_LICENSE:=GPL-2.0

@ -0,0 +1,31 @@
From 992723e3712a09037338aa9e5506a080e24d1642 Mon Sep 17 00:00:00 2001
From: Stijn Tintel <stijn@linux-ipv6.be>
Date: Mon, 25 Sep 2017 08:09:01 +0300
Subject: [PATCH] ipset: fix build with musl
Include sys/types.h for u_int8_t and define _GNU_SOURCE for musl to
expose it.
Fixes: 54802b2c2826 ("Report if the option is supported by a newer kernel release")
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Signed-off-by: Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
---
src/ipset.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/src/ipset.c b/src/ipset.c
index 79f56b8..8d70abc 100644
--- a/src/ipset.c
+++ b/src/ipset.c
@@ -14,6 +14,8 @@
#include <stdio.h> /* fprintf, fgets */
#include <stdlib.h> /* exit */
#include <string.h> /* str* */
+#define _GNU_SOURCE
+#include <sys/types.h> /* u_int8_t */
#include <config.h>
--
2.13.5
Loading…
Cancel
Save